Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Coupon Code problem - Magento 1.3 template on 1.4.x
 
julie p
Jr. Member
 
Total Posts:  9
Joined:  2009-12-15
 

Hi all. Without quite realizing the dire consequences, our system was upgraded to 1.4 with my 1.3 templates. I have all of it working now with the exception of the coupon code functionality. Basically, the form tag gets stripped on the cart so that the coupon doesn’t actually do anything. Can anyone provide me with either a solution or explanation of the differences between the 1.3 and 1.4 templates, and if there’s anything I can do to resolve this? Our site is ready to go and our client is talking lawsuit!!!

Right now, I have the default coupon code template in there - i.e. no customization.

HELP!!!! smile

Thanks!

PS - this is my first build, so I’m a newbie…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Have you tried the base theme in 1.4 to see if you coupons are working? The coupon tables split in 1.4.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
julie p
Jr. Member
 
Total Posts:  9
Joined:  2009-12-15
 

I haven’t tried the base template, as we don’t want to rebuild the entire thing. Is there a way to merge the old functionality with the new?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

I am not saying this is the problem, all I am saying is to turn on the default theme to verify your problem is not in the theme. This is a 10 sec process System->Config->Design->Theme

 
Magento Community Magento Community
Magento Community
Magento Community
 
julie p
Jr. Member
 
Total Posts:  9
Joined:  2009-12-15
 

oh - i see. sorry - very new at this! Ok - i turned on the default theme and the coupon works! does this mean I should revert my code and redesign?

 
Magento Community Magento Community
Magento Community
Magento Community
 
julie p
Jr. Member
 
Total Posts:  9
Joined:  2009-12-15
 

Also - the only thing I changed functionally with my theme is this:

http://www.magentocommerce.com/boards/viewthread/9797/P30/

I added the multiple cart checkout.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top