Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
Don’t see where to upgrade via Magento Connect Manger
 
bwood5
Jr. Member
 
Total Posts:  6
Joined:  2010-10-26
 

I am getting the error after i enter - magento-core/Mage_All_Latest - into the extension and hit install.

magento-core/Lib_ZF_Locale requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR: install failed

Any solutions to this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ctrol
Member
 
Total Posts:  43
Joined:  2010-10-22
 

Hey Gus:
I have do what you have told me to do,when update via Magento Connect,Error shows
pear/Console_Getopt requires PEAR Installer (version >= 1.9.1), installed version is 1.7.1
pear/PEAR requires package “pear/Console_Getopt” (recommended version 1.2.3)
magento-core/Mage_Pear_Helpers requires package “pear/PEAR” (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package “magento-core/Lib_Google_Checkout” (version >= 1.4.2.0, version <= 1.4.3, excluded versions: 1.4.3)
magento-core/Mage_All_Latest requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.2.0)
magento-core/Mage_Core_Adminhtml requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.2.0)
magento-core/Interface_Adminhtml_Default requires package “magento-core/Mage_Core_Adminhtml” (version >= 1.4.2.0, version <= 1.4.3.0, excluded versions: 1.4.3.0)
magento-core/Interface_Frontend_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.3, excluded versions: 1.4.3)
magento-core/Interface_Install_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.3, excluded versions: 1.4.3)
magento-core/Mage_Centinel requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.3, excluded versions: 1.4.3)
magento-core/Interface_Frontend_Base_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.3, excluded versions: 1.4.3)
magento-core/Phoenix_Moneybookers requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.3, excluded versions: 1.4.3)
magento-core/Find_Feed requires package “magento-core/Mage_Core_Modules” (version >= 1.4.2.0, version <= 1.4.3)
magento-core/Lib_Js_Calendar requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Downloader requires package “magento-core/Lib_Js_Prototype” (version >= 1.6.0.3.0, version <= 1.6.1, excluded versions: 1.6.1)
magento-core/Lib_Js_Mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.6.0.3.3, version <= 1.6.1, excluded versions: 1.6.1)
magento-core/Lib_Js_Ext requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800, version <= 1.0.18800)
magento-core/Lib_Js_TinyMCE requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_ZF requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Varien requires package “magento-core/Lib_ZF” (version >= 1.10.8.0, version <= 1.10.9.0, excluded versions: 1.10.9.0)
magento-core/Lib_ZF_Locale requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR: install failed

Could you pls tell me what’s the problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bwood5
Jr. Member
 
Total Posts:  6
Joined:  2010-10-26
 

OK AFTER PLAYING WITH THIS A WHILE I WAS ABLE TO GET THE magento-core/Mage_All_Latest TO RUN SUCCESSFULLY BY UNINSTALLING ALL THE MODULES UNDER Channel: connect.magentocommerce.com/core.

This was my result.

Starting to download Lib_LinLibertineFont-2.8.14.0.tgz (1,414,362 bytes)
...done: 1,414,362 bytes
install ok: channel://connect.magentocommerce.com/core/Lib_PEAR-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Phpseclib-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Mage_Locale_en_US-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Lib_Mage-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Lib_LinLibertineFont-2.8.14.0

I still do not see the Mage_All_Latest under Channel: connect.magentocommerce.com/core

If I re-enter ‘magento-core/Mage_All_Latest’ in the ‘Paste extension key to install’ field and hit install I will get the error reported in other posts above the 2nd time it is run.

Does anyone know why I am not seeing the Mage_All_Latest with the new 1.4.2.0 update I think it should be highlighted in yeloow?

 
Magento Community Magento Community
Magento Community
Magento Community
 
SiCoUK
Jr. Member
 
Total Posts:  1
Joined:  2010-09-21
 

I am getting exactly the same errors when trying to upgrade Magento on a development server (Windows).

I believe it hinges around this line:

“pear/Console_Getopt requires PEAR Installer (version >= 1.9.1), installed version is 1.7.1”

What is really annoying me is that I have spent all night installing Pear properly at version 1.9.1, however Magento seems to be insistent on using it’s own version?

How do I update the Magento Pear to the version it requires? Can windows be running two versions of Pear, can I delete the rogue 1.7.1 version? Am I remotely on the right track?!

It would of been quicker to upgrade manually!

Simon

 
Magento Community Magento Community
Magento Community
Magento Community
 
baoutch
Jr. Member
 
Total Posts:  11
Joined:  2007-09-04
 

You can use local copy of pear

See here : http://www.magentocommerce.com/boards/viewthread/214395/P15/#t287596

 
Magento Community Magento Community
Magento Community
Magento Community
 
albertequippos
Jr. Member
 
Total Posts:  3
Joined:  2013-04-28
 

Did you get any awnser about that? ta!

nicole2292 - 08 December 2010 04:38 PM

Hi There,

I have just followed all these steps through and it seem to work successfully. Thankfully unlike others I am not getting asny errors. However when I log into the magento admin panel it still says “Magento ver. 1.4.1.1” Why does it still say that afte I just upgraded to 1.4.2 using magento connect?

Have a missed a step? Is there something else I need to do? How can I tell if it worked?

Best Regards,

Nicole

 
Magento Community Magento Community
Magento Community
Magento Community
 
albertequippos
Jr. Member
 
Total Posts:  3
Joined:  2013-04-28
 

did u get any awnser about it?

nicole2292 - 08 December 2010 04:38 PM

Hi There,

I have just followed all these steps through and it seem to work successfully. Thankfully unlike others I am not getting asny errors. However when I log into the magento admin panel it still says “Magento ver. 1.4.1.1” Why does it still say that afte I just upgraded to 1.4.2 using magento connect?

Have a missed a step? Is there something else I need to do? How can I tell if it worked?

Best Regards,

Nicole

 
Magento Community Magento Community
Magento Community
Magento Community
 
albertequippos
Jr. Member
 
Total Posts:  3
Joined:  2013-04-28
 

i did the same, but what is the next step to update 1.4.2.0 to 1.7.2.0? could it be by magento connect manager? ta!

bwood5 - 16 December 2010 08:27 AM

OK AFTER PLAYING WITH THIS A WHILE I WAS ABLE TO GET THE magento-core/Mage_All_Latest TO RUN SUCCESSFULLY BY UNINSTALLING ALL THE MODULES UNDER Channel: connect.magentocommerce.com/core.

This was my result.

Starting to download Lib_LinLibertineFont-2.8.14.0.tgz (1,414,362 bytes)
...done: 1,414,362 bytes
install ok: channel://connect.magentocommerce.com/core/Lib_PEAR-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Phpseclib-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Mage_Locale_en_US-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Lib_Mage-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Lib_LinLibertineFont-2.8.14.0

I still do not see the Mage_All_Latest under Channel: connect.magentocommerce.com/core

If I re-enter ‘magento-core/Mage_All_Latest’ in the ‘Paste extension key to install’ field and hit install I will get the error reported in other posts above the 2nd time it is run.

Does anyone know why I am not seeing the Mage_All_Latest with the new 1.4.2.0 update I think it should be highlighted in yeloow?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2