Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Don’t see where to upgrade via Magento Connect Manger
 
jackied
Member
 
Total Posts:  31
Joined:  2008-07-02
 

How do I upgrade via the Magento Connect Manager? All I see is “Install New Extensions” and “Manage Existing Extensions”.

Am I missing something? I feel ike this should be easy.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

When you run Magento Connect Manager for the first time, you need to initialize the downloader. Enter “magento-core/Mage_All_Latest” in the Extension Key field and click on Install New Extensions. Once the initial setup procedure has completed, click on Refresh, and you should see a list of all the Magento packages currently installed.

To upgrade all core Magento modules, you should select the Mage_All_Latest meta package when you perform the upgrade. This way all dependencies will be maintained.

I hope this information can be useful!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jackied
Member
 
Total Posts:  31
Joined:  2008-07-02
 

Thanks for your help! I wouldn’t have figured that out.

So to upgrade to the latest version of magento, do I select “reinstall” next to Mage_Downloader?

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

If there is an upgrade available, a new option “Upgrade to (version_number)” will appear in the list. I guess you already have 1.1.6 installed, which is the latest version.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

PS: there is also an alternative way to upgrade Magento through the command line. If you have SSH (shell) access on our server, you can run these two commands from the Magento root directory:

./pear mage-setup .
./
pear install -f magento-core/Mage_All_Latest-stable
If there is an upgrade available, it will be installed.

This is the method I prefer, because it is a lot faster than using the Connect Manager.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jackied
Member
 
Total Posts:  31
Joined:  2008-07-02
 

Great! Thank you very much for your help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
spectrumaudio
Member
 
Total Posts:  39
Joined:  2008-07-22
 

This post was very helpful as I had the same question. I entered:

Enter “magento-core/Mage_All_Latest” in the Extension Key field and click on Install New Extensions

and it totally wiped out my Magento on my server! all it shows is:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@mydomain.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at homeavstore.com Port 80

Please help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
spectrumaudio
Member
 
Total Posts:  39
Joined:  2008-07-22
 

This post was very helpful as I had the same question. I entered:

Enter “magento-core/Mage_All_Latest” in the Extension Key field and click on Install New Extensions

and it totally wiped out my Magento on my server! all it shows is:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@mydomain.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at mydomain.com Port 80

Please help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Is your server running suPHP? Magento Connect may change the permissions on your directories/files to a mode not supported in a suPHP configuration. If you have SSH access, try to run these commands from your Magento root directory:

find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;

It should reset the permissions on all directories and files.

PS: you should never attempt to upgrade a production site without first making a backup of your database and files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
redvinny
Member
 
Total Posts:  48
Joined:  2008-11-22
 

Hi,

I’m having similar problems in this post (http://www.magentocommerce.com/boards/viewthread/26403/)

Everytime I enter the magento-core/Mage_All_Latest line it throws up lots of errors.  It also shows that I only have one obscure extension running.

Any help is much appreciated.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
avagraphique
Jr. Member
 
Total Posts:  19
Joined:  2008-11-03
 

@Sindre|ProperHost do you change file / directory permission before or after the attempted core magento update (and failure) ? I am having the same issue.....

Thanks,
Andrew

 
Magento Community Magento Community
Magento Community
Magento Community
 
dhanashri
Jr. Member
 
Total Posts:  24
Joined:  2009-01-08
 

I am trying to upgrade to version 1.3 and when I type magento-core/Mage_All_Latest in the extension key and press install all I get is Preparing for Update please wait and then it tries to open Index.php . If I open index.php nothing happens
When I click check for updates nothing happens. I can’t ssh on my server. Is there any other way I can upgrade.

Thanks
Dee

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mage Guru
Sr. Member
 
Avatar
Total Posts:  79
Joined:  2009-07-07
 

I just tried ‘magento-core/Mage_All_Latest’ in the extension key, and after it finished i am getting Internal Server Error page.

Any ideas on how i can revert to how it was?

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
nicole2292
Jr. Member
 
Total Posts:  10
Joined:  2010-11-17
 

Hi There,

I have just followed all these steps through and it seem to work successfully. Thankfully unlike others I am not getting asny errors. However when I log into the magento admin panel it still says “Magento ver. 1.4.1.1” Why does it still say that afte I just upgraded to 1.4.2 using magento connect?

Have a missed a step? Is there something else I need to do? How can I tell if it worked?

Best Regards,

Nicole

 
Magento Community Magento Community
Magento Community
Magento Community
 
hippoglollum
Sr. Member
 
Total Posts:  97
Joined:  2010-04-07
 
Sindre|ProperHost - 25 November 2008 04:25 PM

find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;

I make sh scripts to do this, but I want to know who must be the owner of magento directory…

actually i set as owner my user and as group apache, so with these rights apache should have the same rights as other “users”.
Is this correct?
Must my user be in the apache group?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bwood5
Jr. Member
 
Total Posts:  6
Joined:  2010-10-26
 

I am getting the error after i enter - magento-core/Mage_All_Latest - into the extension and hit install.

magento-core/Lib_ZF_Locale requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR: install failed

Any solutions to this?

OK AFTER PLAYING WITH THIS A WHILE I WAS ABLE TO GET THE magento-core/Mage_All_Latest TO RUN SUCCESSFULLY BY UNINSTALLING ALL THE MODULES UNDER Channel: connect.magentocommerce.com/core.

This was my result.

Starting to download Lib_LinLibertineFont-2.8.14.0.tgz (1,414,362 bytes)
...done: 1,414,362 bytes
install ok: channel://connect.magentocommerce.com/core/Lib_PEAR-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Phpseclib-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Mage_Locale_en_US-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Lib_Mage-1.4.2.0
install ok: channel://connect.magentocommerce.com/core/Lib_LinLibertineFont-2.8.14.0

I do not see the Mage_All_Latest

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2