Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal error: Allowed memory size of 8388608 bytes exhausted
 
madmat
Jr. Member
 
Total Posts:  7
Joined:  2008-10-18
 

hello i try to install magento on a webhostingbuzz server.

I keep getting errors after the install when i want to go to the frontend or the administration.

Here are the errors I get :

when trying to connect to the admin:

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /home2/sanookst/public_html/magento/app/code/core/Mage/Reports/Model/Mysql4/Order/Collection.php on line 263

when trying to connect to the frontend:

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /home2/sanookst/public_html/magento/app/code/core/Mage/Eav/Model/Entity/Collection/Abstract.php on line 331

Does this sound familiar to someone?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

It sounds like the memory limit on your server is set too low for Magento to run. In your .htaccess, try to set the memory_limit to something like 128 MB:

php_value memory_limit 128M

If that doesn’t help, you can try to contact your host and ask if they can increase the memory limit (unlikely), or alternatively change hosting provider.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Your best bet is to contact your hosting provider as some host does not allow the changing of php.ini information. Be sure to update us on this when they responded to your issue. wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
madmat
Jr. Member
 
Total Posts:  7
Joined:  2008-10-18
 
Sindre|ProperHost - 21 October 2008 07:37 AM

It sounds like the memory limit on your server is set too low for Magento to run. In your .htaccess, try to set the memory_limit to something like 128 MB:

php_value memory_limit 128M

If that doesn’t help, you can try to contact your host and ask if they can increase the memory limit (unlikely), or alternatively change hosting provider.

So the answer form the support was:
-----------------------------------------
Dear Customer,

You can manage all PHP settings with the help of your local php.ini file. In order to use it, you need to create a php.ini file under the folder with your PHP scripts, with the necessary PHP settings. For example, if you need to change the upload_max_filesize for one of your scripts under your public_html to 8M you should create a php.ini file under the folder with the following content:
[PHP]
upload_max_filesize = 8M

Feel free to contact us in case of any further troubles.
-------------------------------------------

I renamed php.ini.sample in the magento folder to php.ini and editied it. I changed max memory to 128 and then....
i got a new error about pdo_mysql but I managed to activate it thanks to the following forum thread:

http://www.magentocommerce.com/boards/viewthread/306/

Now i can access the frontend and the backend but i got a new error when trying to access magento connect manager in order to update.

Here is the error:
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 87076 bytes) in /home2/sanookst/public_html/magento/downloader/Maged/Pear/Package.php on line 36

And i’m stuck again.

Please advise....thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Try to create a php.ini in your downloader/ folder as well, with the memory_limit set to e.g. 128M

 
Magento Community Magento Community
Magento Community
Magento Community
 
DitesVERT
Sr. Member
 
Avatar
Total Posts:  100
Joined:  2009-03-03
 

@Sindre : Thank you so much, that did the trick for me! smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top