Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Creato un nuovo template, sparisce tutto
 
calvo
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2010-09-27
 

Ho appena installato l’ultima versione di Magento (1.4.1.1). Mi succede una cosa strana: seguendo le istruzioni trovate online, ho creato un nuovo template duplicando le cartelle:

app/design/frontend/default/modern
skin/frontend/default/modern

e rinominandole in:

app/design/frontend/default/miotema
skin/frontend/default/miotema

Inoltre, in testa a ogni file, dove c’era scritto:

default_modern

ho scritto:

default_miotema

Spedito il tutto via FTP, se vado in System > Design e dal menu a tendina scelgo ”miotema”, non si vede più nulla. Il sito sparisce. Se scelgo dal menu a tendina qualsiasi altro tema, invece torna tutto a posto.

Dimentico qualche passaggio non indicato nelle guide online?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 
Marco Calvo - 07 October 2010 08:17 AM

Ho appena installato l’ultima versione di Magento (1.4.1.1). Mi succede una cosa strana: seguendo le istruzioni trovate online, ho creato un nuovo template duplicando le cartelle:

app/design/frontend/default/modern
skin/frontend/default/modern


e rinominandole in:

app/design/frontend/default/miotema
skin/frontend/default/miotema


Inoltre, in testa a ogni file, dove c’era scritto:

default_modern

ho scritto:

default_miotema

Spedito il tutto via FTP, se vado in System > Design e dal menu a tendina scelgo ”miotema”, non si vede più nulla. Il sito sparisce. Se scelgo dal menu a tendina qualsiasi altro tema, invece torna tutto a posto.

Dimentico qualche passaggio non indicato nelle guide online?

Che guida hai seguito scusa? Oo ti basta modificare i campi layout template e skin nella voce design in configuration con il nome della cartella.

 
Magento Community Magento Community
Magento Community
Magento Community
 
calvo
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2010-09-27
 
Black Cat - 07 October 2010 02:04 PM

Che guida hai seguito scusa?

Tutte quelle che ho trovato online dicono più o meno la stessa cosa (alcune con delle incongruenze, come voci di menu inesistenti, probabilmente perché si riferivano a vecchie versioni di Magento).

Black Cat - 07 October 2010 02:04 PM

Oo ti basta modificare i campi layout template e skin nella voce design in configuration con il nome della cartella.

Se con “Oo ti basta modificare...” intendevi “Non ti basta modificare...”, magari. Quali altri passaggi servono?

Ho sia modificato il tema in “System” - “Design”, sia in “Configuration” - “Design”. Ma non appena imposto “System” - “Design” già a quel punto il sito diventa una pagina bianca vuota, con zero codice HTML generato.

Ciao.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 
Marco Calvo - 07 October 2010 03:16 PM

Black Cat - 07 October 2010 02:04 PM

Che guida hai seguito scusa?

Tutte quelle che ho trovato online dicono più o meno la stessa cosa (alcune con delle incongruenze, come voci di menu inesistenti, probabilmente perché si riferivano a vecchie versioni di Magento).

Black Cat - 07 October 2010 02:04 PM

Oo ti basta modificare i campi layout template e skin nella voce design in configuration con il nome della cartella.

Se con “Oo ti basta modificare...” intendevi “Non ti basta modificare...”, magari. Quali altri passaggi servono?

Ho sia modificato il tema in “System” - “Design”, sia in “Configuration” - “Design”. Ma non appena imposto “System” - “Design” già a quel punto il sito diventa una pagina bianca vuota, con zero codice HTML generato.

Ciao.

Impossibile…
Comunque System Design io non l’ho mai impostato perchè trovo più comodo muovermi con i campi Layout, Template e skin… e solo quelli devi modificare, gli altri campi devono stare vuoti.

Prova ad eliminare tutto in System Design e impostare quei tre campi con Configuration design dando il nome della cartella in questione… e ricordati di disabilitare la cache di magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
calvo
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2010-09-27
 
Black Cat - 08 October 2010 02:57 AM

Impossibile…
Comunque System Design io non l’ho mai impostato perchè trovo più comodo muovermi con i campi Layout, Template e skin… e solo quelli devi modificare, gli altri campi devono stare vuoti.
Prova ad eliminare tutto in System Design e impostare quei tre campi con Configuration design dando il nome della cartella in questione… e ricordati di disabilitare la cache di magento.

Bravo, ha funzionato. Ho disabilitato tutte le cache, ho cancellato il settaggio in “System” - “Design”, poi sono andato in “System” - “Configuration” - “Design” e qui ho impostato:

Current Package Name: default (era già così)

Templates: miotema

Skin (Images / CSS): miotema

Layout: miotema

Default: [vuoto]

Ora funziona. Ho fatto tutto bene?

Certo però che rispetto a WordPress… grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top