Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Producten worden niet zichtbaar
 
C00lrunnings
Jr. Member
 
Total Posts:  7
Joined:  2010-09-26
 

Hoi,

Ik ben net begonnen met een nieuwe Magento-installatie.
Ik heb de sample-data ook mee-geïnstalleerd en deze is prima zichtbaar op de website.
Ik heb het inmiddels voor elkaar om een nieuwe menu-structuur te laten weergeven op mijn eigen categorieën die ik aangemaakt heb.
nu moet ik nog producten toevoegen welke een aantal opties moeten hebben die men in kan/moet vullen, zoals vulling, kleur, versiering, naam, datum.
Vulling wordt een dropdown-optie.
kleur en versiering worden een list met multiple-select optie.
naam en datum worden beide een tekst-veld.

Als ik zo’n product wil toevoegen, dan lijkt het mij dat ik hier een “configurable product” van maken.
Probleem is echter dat ik mijn eigen toegevoegde producten niet zichtbaar krijg op de website, terwijl de sample-producten geen probleem zijn. (Deze zijn inmiddels disabled, dus niet meer zichtbaar, maar dat terzijde).
Als ik in de backend naar de producten-lijst kijk, dan zie ik daar de voorraad op 0 staan, dus dat zou een verklaring kunnen zijn dat het product niet zichtbaar is.
Als ik echter aangeef dat ik geen voorraadbeheer wil doen (daar de producten pas na bestelling gemaakt worden) dan blijft het product nog steeds niet zichtbaar.

Iemand een idee wat ik verkeerd doe.

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Moderator
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

Heb je hem uberhaupt ‘enabled’? En visibility: Search & Catalog? En heb je het product wel aan een categorie toegevoegd?

 
Magento Community Magento Community
Magento Community
Magento Community
 
C00lrunnings
Jr. Member
 
Total Posts:  7
Joined:  2010-09-26
 

Probleem is inmiddels opgelost. Ik kan nu wel produkten toevoegen. (En ze waren i.i.g. wel enabled, etc.)

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Moderator
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

Het zou mooi zijn de oplossing te delen, zodat niet alleen je vraag voor altijd leesbaar blijft, maar ook het uiteindelijke antwoord.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jeroen Custers
Jr. Member
 
Total Posts:  17
Joined:  2010-10-30
 

Ik had vandaag ongeveer hetzelfde probleem. Het product was actief (voorraad beheer uitgeschakeld). Product gekoppeld aan categorie en aan website en toch was hij niet zichtbaar in de front-end. Vervolgens heb ik het vinkje bij de website weggehaald en weer toegevoegd en toen was hij wel ineens zichtbaar. Heel raar. Vervolgens een nieuw testproduct gemaakt en die had het hetzelfde fenomeen.

Cache beheer staat helemaal uit.

Heeft iemand hier een verklaring voor?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jeroen Custers
Jr. Member
 
Total Posts:  17
Joined:  2010-10-30
 

Ik denk dat ik inmiddels weet waar het aan ligt. Soms is het nodig om de indexen te refreshen terwijl er geen index op rood staat. Alle indexen opnieuw indexeren zorgt er vervolgens voor dat de producten wel zichtbaar worden in de front-end.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top