Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

installations problem
 
oevers
Jr. Member
 
Total Posts:  3
Joined:  2008-10-17
 

Hallo Liebe Magento Community,

ich habe jetzt endlich ein Hosting Paket, welches Magento unterstützt.

Die richtigen Magentorechte sind der Datenbank hinzugefügt worden, aber ich erhalte immer folgenden Fehler:

Error in file"/var/www/web239/html/magento/app/code/core/Mage/Review/sql/review_setup/mysql4-upgrade-0.7.0-0.7.1.php" SQLSTATE[HY000]General error1005 Can't create table './usr_web239_1/#sql-aee_2aacb7.frm' (errno: 121)
Trace:
#0 /var/www/web239/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(286): Mage::exception('Mage_Core', 'Error in file: ...')
#1 /var/www/web239/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(178): Mage_Core_Model_Resource_Setup->_modifyResourceDb('upgrade', '0.7.0', '0.7.3')
#2 /var/www/web239/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(145): Mage_Core_Model_Resource_Setup->_upgradeResourceDb('0.7.0', '0.7.3')
#3 /var/www/web239/html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(120): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /var/www/web239/html/magento/app/code/core/Mage/Core/Model/Config.php(215): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /var/www/web239/html/magento/app/code/core/Mage/Core/Model/App.php(236): Mage_Core_Model_Config->init(Array)
#6 /var/www/web239/html/magento/app/Mage.php(424): Mage_Core_Model_App->init('', 'store', Array)
#7 /var/www/web239/html/magento/app/Mage.php(443): Mage::app('', 'store', Array)
#8 /var/www/web239/html/magento/index.php(52): Mage::run()

Ich bin leider kein PHP Experte und kann somit recht wenig damit anfangen.

Bin für jede Hilfe dankbar.

 
Magento Community Magento Community
Magento Community
Magento Community
 
oevers
Jr. Member
 
Total Posts:  3
Joined:  2008-10-17
 

das problem hat sich von selbst gelöst :D

auch nicht schlecht

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sylvio Rieger
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2008-10-14
Freiberg / Saxonia
 

und was hast Du getan, dass es nicht mehr auftritt?

 
Magento Community Magento Community
Magento Community
Magento Community
 
wheez
Jr. Member
 
Total Posts:  17
Joined:  2008-07-22
Germany
 

Hi,
also ich hatte schön öfters mit dem ähnlichen Problem zu kämpfen. Meine Vermutung ist dass bei der Einrichtung der Datenbank ein Timeout (oder ein anderes Limit) dazwischenfunkt und das Script irgendwo stecken bleibt. bei mir half meistens das:

Wenn der Fehler aufgetreten ist die Datenbank manuell komplett löschen (z.B. mit PhpMyAdmin)

DeinMagentoRoot/downloader im Browser erneut aufrufen (habe die Downloader-Version benutzt)

Auf der Seite bekommt man eine Meldung dass alles bereits geladen wurde und man kann die Installation erneut starten.

Installation erneut starten und die Schritte wie beim ersten mal durchgehen (die ersten Angaben werden übernommen)

.. beten ...

Die Datenebank sollte neu aufgebaut und die Installation fehlerfrei abgeschlossen werden.

Ich hoffe es hilft bei dem einen oder anderen,
Gruß, WHEEZ

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top