Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Need Help With Bundle Products Pricing (v1.3.2.4)
 
Ionix
Jr. Member
 
Total Posts:  24
Joined:  2010-09-29
 

Hello, I need a little help with a problem I’m having with how a bundled product is showing it’s price on our front end product grid.

To provide a little background, I currently have a bundle product with a fixed price ($695.95) and it only has one bundle option ($400) which I have set for default and can’t be changed. The reason behind this is a core charge that absolutely must be included with the product but we would like to clearly disclose it.

The price on the single product page shows $1095.95, which is the correct price for what it should be, however, when viewed from the front end product grid (when searched or browsed) it shows $1495.95, as if the coding in the price file is adding the default option again. I have the price view set to “as low as” but that doesn’t change the outcome when I change it to “price range” either.

I’m not a php coder however I understand its structure, if anyone would be able to help me fix this problem it would be greatly appreciated. I’ve looked at a couple of php files (price.php and view.php within the bundle folder) and tried to find where it is myself however I’m not comfortable playing trial and error to a live site when I’m not 100% sure what lines I’m looking for. Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ionix
Jr. Member
 
Total Posts:  24
Joined:  2010-09-29
 

*Update*

For anyone with this same problem, I figured out what I needed to do to fix it.

All it was needing is to refresh Layered Navigation Indices and problem solved. I was thinking it was some error in the code because of how many other people were having issues with bundle product pricing, turns out it was the only cache refresh option I don’t do normally.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top