Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

<b>Fatal error</b>:  Allowed memory size of 33554432 bytes exhausted
 
webfinity
Jr. Member
 
Total Posts:  2
Joined:  2008-10-06
 

I installed Magento and everything was working.  Then I added all my product and I started the following error on the checkout page:

<b>Fatal error</b>:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 85 bytes) in <b>/home/webcastd/public_html/rubberduckies/lib/Varien/Data/Collection.php</b> on line <b>483</b><br />

I contact my host (Bluehost) They told me to increase the php memory in php.ini and copy it to the folder giving the error.  I copied it to the /home/webcastd/public_html/rubberduckies/lib/Varien/Data/ folder and all subfolders.  I’m still getting the same error.

Does anyone have an idea what to do next?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jot29
Jr. Member
 
Total Posts:  1
Joined:  2008-12-16
 

i am having the same problem… anybody got fix for this?…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

What value are you raising the memory_limit to? Default is 128M, so double it to 256M. See if the error still persists.

And it’s quite possible that the changes you’re making aren’t even being kept. Instead of putting a php.ini file in that directory, just edit the default one in the root directory where Magento is installed. If you don’t override PHP values via a php.ini file, do it in the .htaccess file instead.

You can confirm if your changes are being saved by creating a PHP info file and searching the page for memory_limit. The local value is yours, the master is what the server has set by default.

 
Magento Community Magento Community
Magento Community
Magento Community
 
novelnova
Jr. Member
 
Total Posts:  12
Joined:  2009-09-20
 

I had this same problem and solved it by enabling my cache, which I had disabled to edit.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ivan D
Jr. Member
 
Total Posts:  7
Joined:  2008-12-28
 

I had this same problem and solved it by enabling my cache, which I had disabled to edit.

That’s the problem child…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rohit85
Member
 
Total Posts:  32
Joined:  2008-12-16
 

Cleaning cache worked for me, thank you so much

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top