Magento Forum

   
Fatal error: Class ‘Zend_Db_Statement_Mysqli’ not found
 
buffalokill
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2007-12-12
Coeur d'Alene, Idaho
 

Hey guys,

I’ve been running on Zencart, and have been searching for a better alternative. So far, Magento is too good to be true. I am able to get this running on my windows XP server on my computer. So I tried installing it on my server at DreamHost. After pluggin in the info to connect to the DB, i received this error on this page of the install wizard: domain.com/install/wizard/configPost/

Fatal error: Class ‘Zend_Db_Statement_Mysqli’ not found in /home/.shiksa/buffalokill/domain.com/lib/Zend/Db/Adapter/Mysqli.php on line 330

I’m running PHP 5.2.2 with safe mode off. I searched around and couldn’t find anything related to this issue. Any help would be greatly appreciated, and thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
buffalokill - 12 December 2007 08:35 PM

Fatal error: Class ‘Zend_Db_Statement_Mysqli’ not found in /home/.shiksa/buffalokill/domain.com/lib/Zend/Db/Adapter/Mysqli.php on line 330

Hi buffalokill,

Can you please make sure that you really have the file /home/.shiksa/buffalokill/domain.com/lib/Zend/Db/Statement/Mysqli.php ? It seems like you didn’t upload all the files on the server.

Please let me know if it helps.

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
buffalokill
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2007-12-12
Coeur d'Alene, Idaho
 

Thanks for the response, Michael.  I triple checked and the file is indeed there. I reuploaded it, and still no love.  i even re-downloaded the source files, and reuploaded that directory.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Class not found while the file is there could also happened if APC is enabled and files were removed/recreated.

If that’s a dedicated server and your php configuration has APC enabled, please try to restart apache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
buffalokill
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2007-12-12
Coeur d'Alene, Idaho
 

thanks moshe. i went ahead and wiped all the files, and did a full upload, and it came out okay. i must of missed a file in the original upload. thanks guys!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top