Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problème d’attribut: Fatal error: Class ‘Mage_Eav_Block_Adminhtml_Attribute_Grid_Abstract’ not found
 
LotharZ
Jr. Member
 
Total Posts:  2
Joined:  2010-08-11
 

Bonjour,

je débute sur Magento et j\’ai un petit problème au niveau des attributs: j\’ai créé un attribut par erreur, et quand j\’essaie d\’accéder à la partie Catalogue > Attributs > Gérer les attributs j\’obtiens cette erreur:

Fatal error: Class \’Mage_Eav_Block_Adminhtml_Attribute_Grid_Abstract\’ not found in /home/magento/app/code/core/Mage/Adminhtml/Block/Catalog/Product/Attribute/Grid.php on line 34

Et la ligne 34 du fichier en question :

class Mage_Adminhtml_Block_Catalog_Product_Attribute_Grid extends Mage_Eav_Block_Adminhtml_Attribute_Grid_Abstract

Un nouvel upload du fichier Grid.php depuis une archive téléchargée sur le site de Magento ne règle pas le problème.

Quelqu\’un aurait une idée sur l\’origine du problème et sa résolution ?

Merci d\’avance pour votre aide

 
Magento Community Magento Community
Magento Community
Magento Community
 
leopoldo69
Member
 
Total Posts:  37
Joined:  2010-10-06
 

bonjour, j’ai le meme problème mais je trouve pas la solution

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bakalinge
Jr. Member
 
Total Posts:  7
Joined:  2010-05-26
 

Bonjour,

Idem pour moi, sur une version 1.4.2.0 fraichement installée…

Bizarre, pas d’infos là-dessus sur le forum, ni sur GG !

quelqu’un a une piste ?

Merci d’avance

 
Magento Community Magento Community
Magento Community
Magento Community
 
informatikadomicile
Jr. Member
 
Total Posts:  6
Joined:  2010-01-02
 

Hello i’ve got the same error.
You have to check if all the files are into the admin/attribute/grid/ on Mage Core

If not upload them to the right directory and it will be right.

 
Magento Community Magento Community
Magento Community
Magento Community
 
loubib
Jr. Member
 
Total Posts:  4
Joined:  2013-03-14
 

Bonjour j’ai le même souci ! J’ai aussi remplacé le fichier grid.php par un nouveau et toujours la même erreur !
Comment avez-vous réglé ce problème ?

J’ai trouvé !!!!! OUF

Il manquait le répertoire GRID à cette endroit :
app/code/core/Mage/Eav/Block/Adminhtml/Attribute/Grid/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top