Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento Installation problem
 
ocealoverdude
Jr. Member
 
Total Posts:  1
Joined:  2010-08-09
 

Hello Magento gurus,

I am very much new to this world and may be a simple problem i am facing.
I am trying to install the magento in my own pc. but when i go for installation , the step3 of installation stage i get stuck.  after giving the database info and password when i click next it says as below:

Fatal error: Maximum execution time of 180 seconds exceeded in D:\Program Files\Apache Software Foundation\Apache2.2\htdocs\magento\lib\Varien\Db\Adapter\Pdo\Mysql.php on line 288

when i look at the line 288 in that mysql.php file . i found there is a problem with function raw_query().
i have uploaded the magento sample data 1.2.0 version.

Plz tell me how to resolve this problem .

 
Magento Community Magento Community
Magento Community
Magento Community
 
glaDiator
Moderator
 
Avatar
Total Posts:  65
Joined:  2008-03-17
 

Change the max_execution_time in php.ini to a greater value.

Fatal error: Maximum execution time of 180 seconds exceeded in D:\Program Files\Apache Software Foundation\Apache2.2\htdocs\magento\lib\Varien\Db\Adapter\Pdo\Mysql.php on line 288

Currently it is set to 180 on your php.ini.

For reference::
http://www.php.net/manual/en/info.configuration.php#ini.max-execution-time
http://php.net/manual/en/function.set-time-limit.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
MatthiasHH
Jr. Member
 
Total Posts:  1
Joined:  2010-09-30
 

If you are using WAMP, make sure to change

max_execution_time
and
max_input_time

to a greater value (e.g. 1800) in your php.ini file.

Don\\\’t forget to restart apache after the changes!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Abedein
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2010-10-05
 

If you are using wamp in windows, then you should enable mod_rewrite and check mark the mod_rewrite option in instillation wizard.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Habib Hadi
Jr. Member
 
Total Posts:  1
Joined:  2010-11-27
 

I would like to tell you add this line at the top of Mysql.php

set_time_limit(0);
 
Magento Community Magento Community
Magento Community
Magento Community
 
matinict
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2012-07-26
Bangladesh
 

I found these steps work:

1. create a .htaccess file with the line ‘php_value max_execution_time 300’
2. in Apache config change these lines for the virtual host:
- from
Options None
AllowOverride None
- to
Options All
AllowOverride All
3. Restart Apache.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top