Magento Forum

Can’t update Magento from 1.4.1.0 to 1.4.1.1, and can’t remove “One or more of the Indexes are not up to date”
 
edge13
Jr. Member
 
Total Posts:  3
Joined:  2010-07-16
 

Hi there,

I\’m running the Magento 1.4.1.0 now, and I used both connect manager way and SSH way to update it to 1.4.1.1, the progress seemed OK, but result never changes, it still 1.4.1.0. Please check pictures below.

Connect Manager Way:

updating

updated

SSH Way:

./pear install magento-core/Mage_All_Latest
In file included from 
/usr/include/features.h:359,
                 
from /tmp/glibctestUqJVLD:1:
/
usr/include/gnu/stubs.h:7:27errorgnu/stubs-32.hNo such file or directory
magento
-core/Lib_Varien requires PHP extension \"dom\"
magento-core/Lib_Varien requires PHP extension \"gd\"
magento-core/Lib_Varien requires PHP extension \"mcrypt\"
magento-core/Mage_Core_Modules requires package \"magento-core/Lib_Varien\" (version >= 1.4.1.1version <= 1.4.2excluded versions1.4.2)
magento-core/Mage_All_Latest requires package \"magento-core/Mage_Core_Modules\" (version >= 1.4.1.1version <= 1.4.1.1)
magento-core/Mage_Core_Adminhtml requires package \"magento-core/Mage_Core_Modules\" (version >= 1.4.1.1version <= 1.4.1.1)
magento-core/Interface_Adminhtml_Default requires package \"magento-core/Mage_Core_Adminhtml\" (version >= 1.4.1.1version <= 1.4.2.0excluded versions1.4.2.0)
magento-core/Interface_Frontend_Default requires package \"magento-core/Mage_Core_Modules\" (version >= 1.4.1.0version <= 1.4.2excluded versions1.4.2)
magento-core/Interface_Install_Default requires package \"magento-core/Mage_Core_Modules\" (version >= 1.4.1.1version <= 1.4.2excluded versions1.4.2)
magento-core/Mage_Centinel requires package \"magento-core/Mage_Core_Modules\" (version >= 1.4.1.1version <= 1.4.2excluded versions1.4.2)
magento-core/Interface_Frontend_Base_Default requires package \"magento-core/Mage_Core_Modules\" (version >= 1.4.1.1version <= 1.4.2excluded versions1.4.2)
magento-core/Phoenix_Moneybookers requires package \"magento-core/Mage_Core_Modules\" (version >= 1.4.1.1version <= 1.4.2excluded versions1.4.2)
magento-core/Lib_PEAR requires PHP extension \"dom\"
magento-core/Lib_PEAR requires PHP extension \"gd\"
magento-core/Lib_PEAR requires PHP extension \"mcrypt\"
No valid packages found
install failed
rm 
-rf downloader/pearlib/cache/* downloader/pearlib/download/*
rm -rf var/cache/*/
/tempend ?>

After That:

magent header

magento bottom

And Another Questions

In the Admin Panel, below the update message, there is another message \"One or more of the Indexes are not up to date\” , I\’ve cleared the \"Locks\" documents, but it\’s still here.

Any help will be appreciated!!!

edge13

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yoakim
Sr. Member
 
Total Posts:  126
Joined:  2008-11-24
 

It’s most likely a file permission problem, have a look at my post in this threed and it may help you.

About the indexes message, it mean you need to to visit (menu) System->Index Manager and reindex the red stuff you see there, this is something anyone upgrading to 1.4.1 have to do. The system simply keep track and warn you about it and gives you a url to click taking you there. you core channel list looks a bit short though, lots of stuff missing there. I guess this is after, but how does it look before?

I hope it was helpful

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

Hi there!

Try this, it should work via SSH:

First, log in to a shell session as the user.

Once logged in, change to the Magento store directory:

cd yourmagentodirectory

Sometimes file permissions get the best of us, so run these two lines:

find ./ -type f -exec chmod 0644 {} \;
find ./ -type d -exec chmod 0755 {} \;

And go ahead and clear out the cache, why not?

rm -rf ./var/cache ./var/session

And let’s clean the downloader:

cd downloader/pearlib
chmod 755 ./clean
./clean
chmod 644 ./clean
cd ../..

Delete the cache and pearlib download directories:

rm -rf downloader/pearlib/cache/* downloader/pearlib/download/*

Change the permissions on the pear executable:

chmod 744 ./pear

Run the upgrade commands:

./pear update-channels
./pear mage-setup
./pear upgrade-all

If the above didn’t work, try:

./pear install -f magento-core/Mage_All_Latest-stable

Clear the Zend Cache IF AND ONLY IF you are upgrading to 1.4.0.0 or higher from a previous version:

rm -rf ./app/code/core/Zend/

Change the pear executable back to its original permissions

chmod 644 ./pear

Clear the store cache again:

rm -rf ./var/cache ./var/session

And load up the domain name in your browser.

In case you upgraded to magento 1.4, and noticed that your category listings that require pagination (page 1, 2, 3) no longer show, here’s the fix…

1. copy the new 1.4 toolbar.phtml from

app/design/frontend/base/default/template/catalog/product/list/toolbar.phtml

and paste it into your custom theme

app/design/frontend/default/YOURTHEME/template/catalog/product/list/toolbar.phtml

(note: make sure you put this into your currently used theme directory. If you installed a theme via Admin-->System-->Design then get the name of the theme from there)

2. edit your app/design/frontend/default/YOURTHEME/layout/catalog.xml

Find:

<block type="catalog/product_list_toolbar" name="product_list_toolbar" template="catalog/product/list/toolbar.phtml">

Replace all instances with:

<block type="catalog/product_list_toolbar" name="product_list_toolbar" template="catalog/product/list/toolbar.phtml">
<block type="page/html_pager" name="product_list_toolbar_pager"/>

3. edit your catalogsearch.xml:

Find:

<block type="catalog/product_list" name="search_result_list" template="catalog/product/list.phtml"></block>

Replace all instances with:

<block type="catalog/product_list" name="search_result_list" template="catalog/product/list.phtml">
<block type="catalog/product_list_toolbar" name="product_list_toolbar" template="catalog/product/list/toolbar.phtml">
<block type="page/html_pager" name="product_list_toolbar_pager"/>
</block>
<action method="setToolbarBlockName"><name>product_list_toolbar</name></action>
</block>

And that should do it… (you’ll also probably have to restyle the toolbar, as it will be barebone)

 
Magento Community Magento Community
Magento Community
Magento Community
 
edge13
Jr. Member
 
Total Posts:  3
Joined:  2010-07-16
 

Hi Yoakim, Thank you for your help! Unfortunately, it doesn’t work for me. :( can’t update magento still. Anyway, thank you for you help again! And I haven’t tried to resolve the 2nd issue yet.

Hi SimpleHelix.com, I tried your first part, then failed, then used “./pear install -f magento-core/Mage_All_Latest-stable” it works and seemed successful, but when I loaded up both front store and admin panel in my browser, they are turned white!!! nothing here any more. big surprise  Anyway, I’m really appreciated for your help! What should I do next? Please keep help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
sahuspilwal
Member
 
Avatar
Total Posts:  37
Joined:  2009-08-02
Hastings, United Kingdom
 

Hi Peps,

Using SSH, when I try to run ./pear update-all it downloads Mage_Core_Modules-1.4.1.1.tgz without a problem but then displays the error:

Fatal errorAllowed memory size pf 33554432 bytes exhausted (tried to allocate 40 bytesin /var/www/magento/downloader/pearlib/php/PEAR/Registry.php on line 1145

Any ideas why this is happening? Thanks in advance for suggestions!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
DaemonOfChaos
Member
 
Total Posts:  35
Joined:  2008-08-18
Hendersonville, TN
 

Disregard.

 
Magento Community Magento Community
Magento Community
Magento Community
 
IZZIWeb Design Studio
Jr. Member
 
Total Posts:  2
Joined:  2010-11-30
 
KayakJim - 17 September 2010 12:09 PM

Disregard.

Very informing… NOT !!!
Next time try to help other people who are having the same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top