Magento Forum

Page 1 of 16
Hosting in Italia per Magento
 
Sidonia
Jr. Member
 
Total Posts:  4
Joined:  2007-12-08
 

Ciao a tutti,

vorrei chiedervi se potete segnalarmi un societa’ di hosting dove posso intallare Magento e farlo funzionare senza aver problemi di release e quantaltro.
Ho tentato col mio attuale fornitore, ma le versioni di PHP e MySQL non permettono il corretto funzionamento.

Grazie in anticipo
Sidonia

 
Magento Community Magento Community
Magento Community
Magento Community
 
Luscarpa
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2007-09-25
Sottomarina (Ve) - Italia
 

Credo che tu debba cercare una società di hosting che supporta lo zend framework e che quindi abbia come requisiti di sistema:

minimum PHP version of 5.1.4

 
Magento Community Magento Community
Magento Community
Magento Community
 
Luscarpa
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2007-09-25
Sottomarina (Ve) - Italia
 

Un server italiano con questi requisiti

http://www.magentocommerce.com/system-requirements

credo sia difficile da trovare, ti conviene ricercare su google direttamente hosting php5, cmq farò una ricerca pure io e ti farò sapere.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sidonia
Jr. Member
 
Total Posts:  4
Joined:  2007-12-08
 

Ciao Luscarpa,

grazie per l’aiuto…
Mi piacerebbe sapere qualcosa da qualcuno che gia’ ha installato Magento senza aver avuto problemi.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dave
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2007-09-01
Lecce
 
Sidonia - 11 December 2007 03:43 AM

Ciao Luscarpa,

grazie per l’aiuto…
Mi piacerebbe sapere qualcosa da qualcuno che gia’ ha installato Magento senza aver avuto problemi.

ciao sidonia,
lo sto installando come prova su ipensieridismilla.com ma sarà off fino a lunedì.

procedo come manuale di installazione, se ci sono problemi ti tengo aggiornato.

ciao

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dave
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2007-09-01
Lecce
 

<< i requisiti sono soddisfatti, ma attualmente la versione di magento
non funziona causa problemi software di magento. >>

questa è stata la risposta dopo che ho provato ad installare magento sui loro server in data 23/12

premetto che la prova che feci il 12 risultava 100% compatibile.

Non so cosa può essere cambiato in magento, ma spero per la release finale tutto si risolva!

 
Magento Community Magento Community
Magento Community
Magento Community
 
pluto
Jr. Member
 
Total Posts:  6
Joined:  2007-12-29
 

mi aggrego alla richiesta

grazie

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tassoman
Member
 
Avatar
Total Posts:  32
Joined:  2007-10-24
Bologna, Italy
 

Io faccio hosting solo PHP5 (vedere in signature)

 
Magento Community Magento Community
Magento Community
Magento Community
 
MToscan
Jr. Member
 
Total Posts:  21
Joined:  2008-01-16
 

Ho conosciuto questo splendido pacchetto solo questa settimana e sono rimasto stupefatto dalla sua eleganza e potenza.

Purtroppo ancora non sono riuscito a installarlo in remoto. Ho un sito su Aruba ma purtroppo è fermo alla versione PHP 4, ho provato ad aggirare la limitazione installando PHP5 come CGI (come suggerito dalla KB di Magento) ma il file a disposizione precompilato da loro si blocca a 5 mega su 17 e non sono risucito a scaricarlo neppure dopo ore (si pianta sempre li). Rimane l’opzione aperta di compilarmelo da solo ma al momento non ne ho voglia/tempo se qualcuno ci riesce per favore lo faccia sapere!

Ho provato a caricare i file sul free hosting di ilbello.com che supporta PHP5 ma non i file htaccess…

Sembra proprio che per il momento dovrò accontentarmi di testarlo su una macchina Linux che dovrò configurare apposta (controvoglia, la mia installazione di Debian stable stava bene anche con PHP4… che palle).

Mi sono guardato un po’ attorno: c’è un provider che si chiama Hosting Professionale,che offre buone condizioni a prezzi un pelino piu alti di Aruba, però ha il Safe Mode = Off e una serie di vantaggi non comuni come hosting *NIX. Purtroppo 2 caselle pop3 e 300 mega di spazio non sono tantissimi se uno vuole caricare 10000 articoli con foto e pdf allegati (come nel mio caso). Il pericolo è passare per noiosissima burocrazia per cambiare provider e rendersi conto quando è già troppo tardi che purtroppo non può soddisfare le tue richiesta di una piccola menata che salterà fuori solo durante l’installazione…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Matteo Raggi
Guru
 
Total Posts:  312
Joined:  2007-11-18
Italy
 

Sembra che tophost.it non va da bene, ecco cosa mi dice:
Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around

infatti tophost.it : PHP Version 4.4.4
.

mentre consiglio http://www.siteground.com/index.htm?referrerid=79233

 
Magento Community Magento Community
Magento Community
Magento Community
 
micael
Jr. Member
 
Total Posts:  4
Joined:  2008-01-21
 

salve a tutti anche io mi aggrego a questo post dato che sono 10 giorni che cerco di scaricare il file php5-cgi ma niente da fare....quindi avendo anche io un dominio su aruba ancora non posso testarlo… se qualcuno di voi lo possiede me lo puo inviare,ve ne sarei grato,cosi creo io un link sul mio server e lo metto a disposizione

questo e’ il mio indirizzo di posta

inoltre vi segnalo questo sito http://www.ilbello.com dove e’ possibile attivare uno spazio su server php 5.2 con 100 mb di spazio mysql completamente gratuito anche se non sono riuscito sui loro server a completare l’installazione c’e’ un topic aperto, sul problema a cui spero i tecnici rispondano

grazie in anticipo per l’aiuto

 
Magento Community Magento Community
Magento Community
Magento Community
 
Matteo Raggi
Guru
 
Total Posts:  312
Joined:  2007-11-18
Italy
 

vorrei spedirti il file, ma è 17.6 MB un po’ pesantino, vedo di spedirtelo con http://www.yousendit.com forse devi solo attendere pe avere questo file nel download, a me è venuto igù benissimo, a presto!

 
Magento Community Magento Community
Magento Community
Magento Community
 
micael
Jr. Member
 
Total Posts:  4
Joined:  2008-01-21
 

1) grazie matteo per la velocita....

2)ho caricato il file sul server ma ancora non ne vuole sapere di partire quindi volevo chiedere aiuto a chi cerca di farlo girare sui server aruba

3)ho editato aggiungendo le due righe nel file httacces che ho copiato nella root principale del sito ma niente l’unica cosa che per non riesco a testare e’:

http://www.example.com/cgi-bin/php5-cgi with your web browser. If you see a Internal Server Error message, then that means your PHP5 binary is in the correct location. If you get a File not found message, then this is not the correct location.

http://www.dolmenbari.com/cgi-bin/php5-cgi

quindi dopo aver copiato il file senza fare altr modifiche mi dovrebbe segnalare “server error message...ma niente

4)la struttura dei siti su aruba è:

/public
/cgi-bin
/magento (all’interno della quale ho copiato il software che parte ma mi dice invalid php.perche aruba ovviamente gira su php 4)
/htaccess (spero andava copiato qui, anche se l’ho provato a copiare anche nella directori di magento ma niente)

come promesso ecco il file php5-cgi inviatomi da Matteo in caso qualcun’altro non lo riesca a scaricare
...

File Attachments
php5-cgi.zip  (File Size: 7416KB - Downloads: 542)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Matteo Raggi
Guru
 
Total Posts:  312
Joined:  2007-11-18
Italy
 

scusa la mia ignoranza, ma quel file che ti ho dato è obbligatorio da usare per l’installazione? in quali casi va usato?
io sto iniziando molto lentament l’installazione su siteground.com dove di base ha php 5.05 ma posso ordinargli di mettere dentr oa delle cartelle anche php 5.2 motl ocomodo, sono proprio a questo passo, di dover sperimentare qusta cosa, qindi mi pare + indietro di te..
quindi aruba ha php 5.2 , bene!

 
Magento Community Magento Community
Magento Community
Magento Community
 
micael
Jr. Member
 
Total Posts:  4
Joined:  2008-01-21
 

ora ti spiego ARUBA usa php 4 che non e’ compatibile con magento, perche come saprai e’ compatibile con php 5.2 e successivi, per ovviare a questo problema hanno creato un interprete (in modo rozzo sarebbe un codice che interpreta le richieste fatte in php 5 da magento e le converte in php 4 compatibile col server aruba e viceversa) tale inteprete OVVIAMENTE RENDE IL SISTEMA MENO EFFICIENTE E VELOCE rispetto ad un server con php 5.2 nativo pero almeno dovrebbe consentire a magento di funzionare.....

anche se ancora sbaglio qualcosa perche non va....

 
Magento Community Magento Community
Magento Community
Magento Community
 
Matteo Raggi
Guru
 
Total Posts:  312
Joined:  2007-11-18
Italy
 

io su siteground invece ho questo errore alla fase di configurazione: PHP Extension “pdo_mysql” must be loaded
e si ferma li..

cercavo di installarlo su una sottodirectory di un mio dominio.. http://www.hotel-supplies.biz

provo a cercare nel motore di ricerca questo errore a vedere se c’è soluzione o se mi aiuta siteground tramite il forum..

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 16