Magento Forum

Page 1 of 2
Google Base - Read Timed Out after 10 seconds
 
T@rget IT
Jr. Member
 
Total Posts:  8
Joined:  2010-07-15
 

Hi,

I have 20,000+ products to upload to Google Base. I’ve managed the first 6,000. But now every time I upload to Google Base (Merchant Centre) the Magento Admin tries and then says ‘Read Timed out after 10 seconds’. It uploads about 5 and then times out.

Is there a way to resolve this? Is there a ‘time out’ setting somewhere I can maybe increase above 10 seconds?

The other option is to manually upload to Google Base. I see the SingleExport extension but this is only supported upto v1.3. I am using v1.4.1.1. Is there another free extension to export from Magento into a product feed and then upload to Google Base...and the other shopping sites?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
gary1976
Jr. Member
 
Total Posts:  26
Joined:  2010-07-01
Dorset
 

I have the same problem, Been using it fine for a while but get this error:

! read timed out after 10 seconds

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yellow Satsuma
Member
 
Total Posts:  41
Joined:  2010-02-13
 

This problem has also just started to occour for me, until recently had no problems now this has come out of no where, has google changed the system perhaps? i am using 1.4.1.1 but this morning i was on 1.4.1.0 with the same problem (upgraded in the hope of fixing)

 
Magento Community Magento Community
Magento Community
Magento Community
 
T@rget IT
Jr. Member
 
Total Posts:  8
Joined:  2010-07-15
 

Hi,

I think this is a case for Google. I\’ll contact them and advise them accordingly.

I\’ll let you know what I find.

Kind regards

Chris

 
Magento Community Magento Community
Magento Community
Magento Community
 
emzngaz
Jr. Member
 
Total Posts:  6
Joined:  2010-04-28
 

I had been having this problem too, but just tried to upload products again and it has worked ok. I wonder if maybe the servers get clogged up? I’m not very technical so thats probably a wrong guess, but all in all seems to be working now smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yellow Satsuma
Member
 
Total Posts:  41
Joined:  2010-02-13
 

I tried again, it sent 128 products before giving me the 10 second time out rather than the usual 2 products, so its better just not quite right still.

 
Magento Community Magento Community
Magento Community
Magento Community
 
T@rget IT
Jr. Member
 
Total Posts:  8
Joined:  2010-07-15
 

Hi,

Yes, it certainly looks like Google have improved the service which is great! I wonder if my post on their forum was noticed or it was just chance!??

Anyhoo, looking better.

Thanks for everyone’s input.

How are you all finding Magento? Easy to use?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yellow Satsuma
Member
 
Total Posts:  41
Joined:  2010-02-13
 

Ive built 6 sites with magento now over the last year + and it can be frustrating at times (one of the current shops i run myself) but its getting easier

 
Magento Community Magento Community
Magento Community
Magento Community
 
T@rget IT
Jr. Member
 
Total Posts:  8
Joined:  2010-07-15
 

Indeed

I cant say I’ve found much frustrating except the speed of it.

Oh, and the advanced search doesnt actually find anything.

Have you resolved these issues at all?

Apart from that, can’t really complain. It’s a great package...and free too smile

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yellow Satsuma
Member
 
Total Posts:  41
Joined:  2010-02-13
 

i guess that depends how much code and customization you do smile the search in general in the free version is pretty poor, the enterprise edition uses solr there is an addon for spinx

http://www.magentocommerce.com/magento-connect/PremierWeb/extension/922/premierweb-sphinx-enterprise-search

but its a bit expensive for my current needs.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gary1976
Jr. Member
 
Total Posts:  26
Joined:  2010-07-01
Dorset
 

Back to Google Base???

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yellow Satsuma
Member
 
Total Posts:  41
Joined:  2010-02-13
 

Google base appears to be working better, i tried to re upload all my products it took 128 products the first time before the 10 second error, then it took 139 in my second go and the third go finished up adding all my products. I can only assume therefore that its some kind of problem with the google system as i have made no changes to my magento installation.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gary1976
Jr. Member
 
Total Posts:  26
Joined:  2010-07-01
Dorset
 

Yes - Google Base is now working for me!

 
Magento Community Magento Community
Magento Community
Magento Community
 
TheGingerOne
Jr. Member
 
Total Posts:  3
Joined:  2010-10-06
 

Hi,

I had a similar problem recently with only being able to submit a few records at a time before the timeout message. I found out that you can increase the timeout limit in the Zend directories and thus give yourself a better chance of your items going through.

Edit the following file on your server:  /lib/Zend/Http/Client.php

Locate the following line:
‘timeout’ => 10

Increase it to what you need it to be. I set it to 30 which did the job for me.

I’m very new to Magento and haven’t got to grips with it’s complexity. Therefore please do your own tests and make sure your happy with making this change. Backup, test etc.

Ginger.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Boreded
Jr. Member
 
Total Posts:  15
Joined:  2010-09-20
 

Thanks to TheGingerOne. That fixed the problem for me smile
Looks like google was taking longer than 10 seconds and magento thought it had timed out. Setting to 30 worked fine. Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hungover
Jr. Member
 
Total Posts:  7
Joined:  2010-03-05
 

I too owe a thanks to the ginger one.

It did take more than one attempt to get google to accept the upload but never-the-less it worked- so thank you…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2