Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error 501 when using Magento Downloader. 
 
TSCAD-FX
Jr. Member
 
Total Posts:  10
Joined:  2008-10-06
Sacramento CA
 

I’ve been using Magento for a while and have found it to be great.  For some reason I never attempted to use the Magento Connect downloader until just this past week.  When I attempt to use it I get an error that I’ve been unable to solve.  I’m hoping someone else out there can help me out with this one!

First of all (go ahead and sigh) we provide web hosting for some of our clients and we use MS Servers.  We are running IIS7 on Server ‘08 with PHP, IsapiRewrite Modules and everything else.  We’ve had the site up for a few months and there’s not another single issue other than this one!  Magento has been fast and runs great (so far) on a windows platform.  So hopefully someone can help out with this!

PHP Fatal error: Uncaught exception ‘Mage_Core_Model_Store_Exception’ in (Directory Path)\wwwroot\app\code\core\Mage\Core\Model\App.php:1131 Stack trace: #0 (Directory Path)\wwwroot\app\code\core\Mage\Core\Model\App.php(570): Mage_Core_Model_App->throwStoreException() #1 (Directory Path)\wwwroot\app\Mage.php(212): Mage_Core_Model_App->getStore(NULL) #2 (Directory Path)\wwwroot\app\code\core\Mage\Core\Model\Session\Abstract.php(74): Mage::getStoreConfig(’web/cookie/cook...’) #3 (Directory Path)\wwwroot\app\code\core\Mage\Core\Model\Session\Abstract\Varien.php(52): Mage_Core_Model_Session_Abstract->getCookieLifetime() #4 (Directory Path)\wwwroot\app\code\core\Mage\Core\Model\Session\Abstract\Varien.php(111): Mage_Core_Model_Session_Abstract_Varien->start(NULL) #5 (Directory Path)\wwwroot\app\code\core\Mage\Core\Model\Session\Abstract.php(43): Mage_Core_Model_Session_Abstract_Varien->init(’admin’, NULL) # in (Directory Path)\wwwroot\app\code\core\Mage\Core\Model\App.php on line 1131

Thanks in advance for your kind words!

 
Magento Community Magento Community
Magento Community
Magento Community
 
TSCAD-FX
Jr. Member
 
Total Posts:  10
Joined:  2008-10-06
Sacramento CA
 

FIXED:

Deleted line 1131 (3rd from last line) of app/code/core/mage/core/model/app.php and everything works fine!  It’s great to have Magento FULLY functional and working without flaws on Windows OS.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top