Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Product Import Does not work in 1.4.1.1
 
timberdawolf
Member
 
Total Posts:  40
Joined:  2009-06-04
 

Post upgrade to 1.4.1.1 the Import Feature does not work.

I have tried running the import using a CSV File as well as a XML File still no luck

2010-07-31T11:41:20+00:00 DEBUG (7): HEADERS ALREADY SENT: <pre>[0] /home/abc/abc.com/app/code/core/Mage/Core/Controller/Response/Http.php:44
[1] /home/abc/abc.com/lib/Zend/Controller/Response/Abstract.php:727
[2] /home/abc/abc.com/app/code/core/Mage/Core/Controller/Response/Http.php:75
[3] /home/abc/abc.com/app/code/core/Mage/Adminhtml/controllers/System/Convert/ProfileController.php:211
[4] /home/abc/abc.com/app/code/core/Mage/Core/Controller/Varien/Action.php:418
[5] /home/abc/abc.com/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php:254
[6] /home/abc/abc.com/app/code/core/Mage/Core/Controller/Varien/Front.php:177
[7] /home/abc/abc.com/app/code/core/Mage/Core/Model/App.php:304
[8] /home/abc/abc.com/app/Mage.php:596
[9] /home/abc/abc.com/index.php:91
</pre>

 
Magento Community Magento Community
Magento Community
Magento Community
 
timberdawolf
Member
 
Total Posts:  40
Joined:  2009-06-04
 

Attached Screenshot

Image Attachments
8-1-2010 7-27-15 AM.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
milk8800
Jr. Member
 
Total Posts:  5
Joined:  2010-05-09
 

I have import 87 items by Import All Products, detail for here below,

\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"Starting Mage_Dataflow_Model_Convert_Adapter_Io :: load
Loaded successfully: \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"/home/otfcnet1/public_html/axision.com/var/export/export_all_products.csv\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\".
Starting Mage_Dataflow_Model_Convert_Parser_Csv :: parse
Found 87 rows.
Starting catalog/convert_adapter_product :: parse
Processed 100% 87/87 records
Imported 87 records\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\”

But after I check my products it only show 2 items ( one is the base item, the 2nd is the last item from my CSV \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"last\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\" item.

can any one help me, thanks a lot

 
Magento Community Magento Community
Magento Community
Magento Community
 
RobOrr
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2008-06-04
 

I’m having problems too.  9 in 10 products are getting an error on the ‘sku’ column though there are no discernable problems.  image import isn’t working either (but that may just be me)

 
Magento Community Magento Community
Magento Community
Magento Community
 
AjOL
Jr. Member
 
Total Posts:  20
Joined:  2010-06-12
 

I haven’t been able to upload images via csv either…

 
Magento Community Magento Community
Magento Community
Magento Community
 
sleiweke
Sr. Member
 
Total Posts:  85
Joined:  2009-03-10
Germany
 
AjOL - 05 August 2010 11:47 PM

I haven’t been able to upload images via csv either…

me too :-(

Any ideas how to fix it?

Thanks
Sebastian

 
Magento Community Magento Community
Magento Community
Magento Community
 
demophoon88
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2010-08-11
 

magento\’s not stable after all :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
kamark
Jr. Member
 
Total Posts:  23
Joined:  2010-02-09
 

Same problem cannot import image? How strange? It says 100% done but then no images.

 
Magento Community Magento Community
Magento Community
Magento Community
 
BVBAccelerate
Member
 
Avatar
Total Posts:  73
Joined:  2009-05-19
Rochester, NY
 

I’m also having troubles. When I try to do an upload it sporadically tells me that the SKU is not defined, even though I know it is.

*** I’ve also been having trouble importing the images for the products. ***
EDIT: I have now been able to upload the images. I was missing a leading ‘/’ in my fields so they weren’t picking them up correctly from the /media/import folder.

I’ve tried to troubleshoot by altering the code to print different error messages and log them during the import, but haven’t even gotten these to work!

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
BVBAccelerate
Member
 
Avatar
Total Posts:  73
Joined:  2009-05-19
Rochester, NY
 

Okay, I found out that some of the rows that are getting imported are completely empty which is why I was getting the SKU error. I added the following lines of code to the beginning of the saveRow() function in /app/code/core/Mage/Catalog/Model/Convert/Adapter/Product.php

/* Edit By Brian to figure out if the imported array is just empty */
     if (empty($importData)) {
             $message 
Mage::helper('catalog')->__('There is no data in the row for this product');
             
Mage::throwException($message);
     
}
/* End Edit by Brian */

It is actually throwing this error message / exception so it appears that the rows are coming in entirely empty. Now to find out where this saveRow function is being called so I can trace this problem. Hope this helps some of you troubleshoot as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
BVBAccelerate
Member
 
Avatar
Total Posts:  73
Joined:  2009-05-19
Rochester, NY
 

Still trying to figure this out. Updated my code to:

/* Edit By Brian to figure out if the imported array is just empty */
if (empty($importData)) {
        $keysStr 
implode(',',array_keys($importData));
        
$message Mage::helper('catalog')->__("There is no data in the row for this product. It has keys: $keysStr");
        
Mage::throwException($message);
}
/* End Edit by Brian */

It’s not ecfhoing out the keys, so I’m pretty sure this is just a totally empty array being passed in. I can’t seem to trace this back though. I’ve found the saveRow() is being used in saveRowSilently() and parse() but I can’t find where either of those two functions are being called.

I have feeling that instead of notifying us that there is some sort of error in a certain field (like it used to if you have an invalid character or something) it is just completely emptying the array when it finds a problem and then tries to save the row. Then, by default the SKU field being empty is the first error it comes across, so we are being given this error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ewinz87
Jr. Member
 
Total Posts:  8
Joined:  2008-10-23
 

Why are you guys hi-jacking his thread with your sku problems? Anyhow, timber, I am also experiencing this issue with my host but seems fine on my local server for testing?? Have you found a fix for this, I’m desperate as importing is a necessity for us.

 
Magento Community Magento Community
Magento Community
Magento Community
 
BVBAccelerate
Member
 
Avatar
Total Posts:  73
Joined:  2009-05-19
Rochester, NY
 

No one is trying to hi-jack the thread Ewinz87. We are all experiencing problems with the bulk product import in this version of Magento. If you read the posts you can see that the error being thrown is about a SKU but the problem is that the entire array of product data is empty.

I’m just trying to contribute any information I have in case someone can use it to solve their problem. Please do not accuse me of hi-jacking a thread. I still have a problem with the product import not working, not a problem with SKUs.

 
Magento Community Magento Community
Magento Community
Magento Community
 
brunomarshall
Guru
 
Avatar
Total Posts:  367
Joined:  2009-08-04
 

First of all check your csv file if it has all required fields filled.i have split my csv file in to three parts

1) csv file with all product name description sku etc without images-->this csv must be UTF-8 encoded (to avoid unnecessary errors)
2)csv file with small image,image,thumbnail,sku,store,websites
3)csv file with gallery filed ,sku , store,website

and then i uploaded first two csv files in normal profile in system>import/export

third csv file is uploaded with a module on following link

product gallery uploader

this is working fine

 
Magento Community Magento Community
Magento Community
Magento Community
 
sleiweke
Sr. Member
 
Total Posts:  85
Joined:  2009-03-10
Germany
 

Hello brunomarshall, thanks a lot for you info.

could you please publish a sample of your 3 csv files?

Thanks a lot
Sebastian

 
Magento Community Magento Community
Magento Community
Magento Community
 
emmenko
Sr. Member
 
Total Posts:  96
Joined:  2010-10-20
 

Hi everybody,

I was having problems too with the import but step-by-step I managed to fix them.

If you’re interested here I wrote what I did to fix the problems (you can start reading from post #2)

I attach my sample csv, so that can help better.

PS: I use Open Office in a Mac with magento 1.4.1.1 (with excel I wasn’t able to work with csv without errors)

Nicola

File Attachments
prova_calc.csv.zip  (File Size: 2KB - Downloads: 213)
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2