Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Yet another SSL problem
 
bitkidoku
Jr. Member
 
Total Posts:  6
Joined:  2007-10-09
 

Hello,
Magento Commerce is awesome, god bless coding fingers of those developers smile

This is the second time I am trying to install Magento, and again I am facing SSL problems.
I have shared hosting and my host (site5.com) provides shared SSL. Here is the guide they provided for it:

You can use the Site5 shared SSL certificate by accessing your site at
https://server.site5.com/~user/page.file
where:

* server is the server on which your site is hosted
* user is your username for the SiteAdmin account for your site
* page.file is the name of the file in your root directory that you want to access (you can also specify a subdirectory)

I provided these info:
Secure host: psyche.site5.com
Path: /~myusername/
Protocol: https
Port: 443

It does not pass the validation. If I skip validation I cannot access backend, because it uses https.
I tried accessing https://psyche.site5.com/~myusername/favicon.ico it works perfectly.

Can anyone help me? I am clueless now hmmm

PS: I am using Magento ver. 0.6.14100

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi bitkidoku,

Is Magento installed under your web-root folder ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bitkidoku
Jr. Member
 
Total Posts:  6
Joined:  2007-10-09
 

Hello Michael;
yes, it is under public_html which is my web-root on my sharing hosting plan.
Temporarily I set the secure connection as http and port 80, to access the magento store

 
Magento Community Magento Community
Magento Community
Magento Community
 
Konstantinos
Jr. Member
 
Total Posts:  4
Joined:  2007-12-15
Athens Greece
 

hello, im facing a similar situation with site5 and magento…

did you find any solution ?

In my case the magento system is located under a ( different domain pointer ) subdirectory of my main site…

Thanks,

Konstantinos

 
Magento Community Magento Community
Magento Community
Magento Community
 
bitkidoku
Jr. Member
 
Total Posts:  6
Joined:  2007-10-09
 

Konstantinos : nope no solutions yet…
I changed the secure settings to something and I cannot access my admin panel right now. I am too busy to look into it. But any help is appreciated smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Konstantinos
Jr. Member
 
Total Posts:  4
Joined:  2007-12-15
Athens Greece
 

i came up a very <b>very</b> dirty hack to be able to access my admin panel ...

(of course i would not use this on a production env ...)

go to all subdirectories under
/magento/app/code/core/Mage

backup the *.xml files under “etc” in each one
edit them and remove from all files all lines between
<secure_url>
</secure_url>

(if they contain any)

Then.
edit
magento/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php (of course back it up first)
to to line 63
is
$shouldBeSecure = Mage::getStoreConfig(’web/secure/protocol’)===’https’;
and change it to
$shouldBeSecure = Mage::getStoreConfig(’web/secure/protocol’)===’http’;

smile

This is not considered by any way a solution, it was just a quick way for me to try magento extensively under my site5 account
without having to mess with SSL.

My frontend was working ok, but u had to do this hack for to get any “https” url working.
Now everything seems to be working ok

Best luck,

Konstantinos

Ps. in default magento .htaccess i just added
AddHandler application/x-httpd-php5 .php
for site5 to work with magento.
i did NOT use the Action php5-cgi /cgi-bin/php5-cgi AddHandler php5-cgi .php way for php4

 
Magento Community Magento Community
Magento Community
Magento Community
 
bitkidoku
Jr. Member
 
Total Posts:  6
Joined:  2007-10-09
 

You didnt need to that, if you have entered the same configuration as insecure(http) part for secure part it should have worked fine. That is what I did before to make it work. and not dirty as yours wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Konstantinos
Jr. Member
 
Total Posts:  4
Joined:  2007-12-15
Athens Greece
 

i had no access to the admin panel and every time i tried to write a http (without the “s") i was automatically redirected to
the “https” secure url - and of course it would not work....

this is why i went in all this trouble....

maybe u used some extra rules at .htaccess for that ?

Konstantinos

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

During installation wizard did you leave default values for secure connection?
Protocol: HTTPS
Port: 443

If yes, you can remove app/etc/local.xml and go through installation wizard again (which will be redirected to by going to any magento link) and setting for secure connection:
Protocol: HTTP
Port: 80

Or alternatively you could change values in the database, table core_config_data:

update core_config_data set value='http' where path='web/secure/protocol';
update core_config_data set value='80' where path='web/secure/port';
 
Magento Community Magento Community
Magento Community
Magento Community
 
bitkidoku
Jr. Member
 
Total Posts:  6
Joined:  2007-10-09
 

Moshe: Doesnt that mean a temporary solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Konstantinos
Jr. Member
 
Total Posts:  4
Joined:  2007-12-15
Athens Greece
 

Thank you Moshe…

Temporary or not, it works! smile

Konstantinos

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top