Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Unable to send New Order Emails
 
gregoir
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2009-01-28
 

Hi,

I’m having problems with sending out transactional/sales emails when using version 1.4.1.0 of Magento - although contact us forms, new registration and password reset emails are being sent with no issues.

This is the output of my exceptions.log:-

2010-07-21T09:29:13+00:00 ERR (3):
exception ‘Mage_Core_Exception’ with message ‘Invalid block type: Mage_CatalogInventory_Block_Qtyincrements’ in /home/schoolun/public_html/schooluniform/app/Mage.php:550
Stack trace:
#0 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Layout.php(469): Mage::throwException(’Invalid block t...’)
#1 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Layout.php(411): Mage_Core_Model_Layout->_getBlockInstance(’cataloginventor...’
#2 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Layout.php(446): Mage_Core_Model_Layout->createBlock(’cataloginventor...’
#3 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Layout.php(238): Mage_Core_Model_Layout->addBlock(’cataloginventor...’
#4 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Layout.php(204): Mage_Core_Model_Layout->_generateBlock(Object(Mage_Core_Model_Layout_Element)
#5 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Layout.php(209): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#6 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Controller/Varien/Action.php(343): Mage_Core_Model_Layout->generateBlocks()
#7 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Catalog/controllers/ProductController.php(115): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()
#8 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Catalog/controllers/ProductController.php(149): Mage_Catalog_ProductController->_initProductLayout(Object(Mage_Catalog_Model_Product))
#9 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Catalog_ProductController->viewAction()
#10 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch(’view’)
#11 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#12 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch()
#13 /home/schoolun/public_html/schooluniform/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#14 /home/schoolun/public_html/schooluniform/index.php(80): Mage::run(’’
#15 {main}
2010-07-21T09:30:09+00:00 ERR (3):
exception ‘Zend_Mail_Transport_Exception’ with message ‘Unable to send mail’ in /home/schoolun/public_html/schooluniform/lib/Zend/Mail/Transport/Sendmail.php:113
Stack trace:
#0 /home/schoolun/public_html/schooluniform/lib/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /home/schoolun/public_html/schooluniform/lib/Zend/Mail.php(973): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Email/Template.php(392): Zend_Mail->send()
#3 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/Email/Template.php(445): Mage_Core_Model_Email_Template->send(’greg.hunt@monit...’
#4 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Sales/Model/Order.php(899): Mage_Core_Model_Email_Template->sendTransactional(’sales_email_ord...’
#5 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Checkout/Model/Type/Onepage.php(647): Mage_Sales_Model_Order->sendNewOrderEmail()
#6 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Checkout/controllers/OnepageController.php(451): Mage_Checkout_Model_Type_Onepage->saveOrder()
#7 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Checkout_OnepageController->saveOrderAction()
#8 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch(’saveOrder’)
#9 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#10 /home/schoolun/public_html/schooluniform/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch()
#11 /home/schoolun/public_html/schooluniform/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#12 /home/schoolun/public_html/schooluniform/index.php(80): Mage::run(’’
#13 {main}

Help greatly appreciated....

G

 
Magento Community Magento Community
Magento Community
Magento Community
 
furnitureforyoultd
Enthusiast
 
Total Posts:  833
Joined:  2009-03-09
 

Having the same issue. The person who submitted a bug for this said he fixed it by copying his email locale files back into his current locale as the upgrade deleted them: http://www.magentocommerce.com/bug-tracking/issue?issue=9385

It didn’t work for me, maybe it’ll work for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gregoir
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2009-01-28
 

Thanks for the reply furnitureforyoultd, but I also tried this and it failed to work. I’ve submitted a Bug Ticket, so will update you if I get a response/resolution....

 
Magento Community Magento Community
Magento Community
Magento Community
 
furnitureforyoultd
Enthusiast
 
Total Posts:  833
Joined:  2009-03-09
 

Had to reinstall 1.4.1.0 in order to fix this as there is no mention of anywhere else of how to solve it. If it’s not too much trouble then I suggest you do the same

 
Magento Community Magento Community
Magento Community
Magento Community
 
gregoir
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2009-01-28
 

...a fresh install failed to resolve the issue :- (

I even tried a new installation of version 1.4.1.1, but still unable to send the transactional emails.

Thanks for all you help and advice.

G

 
Magento Community Magento Community
Magento Community
Magento Community
 
kandip
Member
 
Total Posts:  38
Joined:  2008-04-09
 
gregoir - 26 July 2010 10:40 PM

...a fresh install failed to resolve the issue :- (

I even tried a new installation of version 1.4.1.1, but still unable to send the transactional emails.

Thanks for all you help and advice.

G

did u find a fix to this.. I am having the same issue.

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top