Magento Forum

   
Performance question
 
citrustech
Jr. Member
 
Total Posts:  5
Joined:  2009-03-28
 

Hello everyone,
My site took about 25 seconds to load the homepage (un-cached).
Here’s what i have done to bring that number down:

Enabled Gzip.
Installed Fooman_Speedster (correctly)
Most images on the homepage are gif. The larger (2) ones are low quality jpg.
I spent about a week going over tons of “Magento performance guides”, and did all i could do.

Now, it takes about 10 seconds to load the homepage. Still t0o long.

My host in Mediatemple (shared / grid service)

Is my host the cause for the slow speeds? When running a website analyzer, i get these as problem results:

Total-size for homepage: 243 kilobytes. Should be under 97 kilobytes.
Total Objects: 50. Should be under 20.
Image-size: 184 kilobytes. Should be under 97 kilobytes.
Script Size: 54 kilobytes. Should by under 19 kilobytes.
Total Images: 48. Says combine images. But, i only counted 23 images.

So, what could be the problem?
Visit my site: oconnellgallery.com It will only be up for a day, as the site isn’t finished.

Thank you in advance, everyone.
- John

 
Magento Community Magento Community
Magento Community
Magento Community
 
Hoku
Jr. Member
 
Total Posts:  2
Joined:  2009-11-26
 

I’m not an expert at this, but it does seem like the host is to blame. I tried running and setting up Magento on a shared host before and it was a painful experience. I bought a VPS package about 6 months ago and now installed Magento on that and it runs more or less fine.
If you look up the System Requirements for Magento it says the memory_limit should be at LEAST 256 M and the recommended is 512 M. I’m not too sure a shared hosting provider would be too happy if you set memory_limit so high.
As a negative test, I put the variable at just 64 M, and the page simply refused to load.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top