Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Erro na instalação do tema MODERN pelo Magento Connect
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

Falae Pessoal,
Estou tentando instalar o tema MODERN( http://www.magentocommerce.com/extension/146/modern-theme-for-magento-frontend-interface ) através do magento connect.
Dou inicio ao processo, começa a instalar mas para no seguinte erro:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 24 bytes) in /home/avesport/public_html/loja/downloader/pearlib/php/Archive/Tar.php on line 1239

Alguém já conseguiu? Já viu esse erro? Sabe do q se trata?
Se puderem me ajudar…
Valeu!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

É, estranho pq eu acabei de instalar o Magento novamente, e a primeira coisa que fiz foi tentar instalar esse tema e nao deixou.
Instalou várias paradinhas mas nao finalizou a instalaçao do tema. :(

Ainda instalou:
Lib_Google_Checkout 1.1.1 (stable)
Lib_Js_Calendar 1.0.18800 (stable)
Lib_Js_Mage 1.1.2 (stable)
Lib_Js_Prototype 1.1.2 (stable)
Lib_ZF_Locale 1.1.1 (stable)

E parou no erro :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

Se mandar instalar várias vezes ele deixa de exibir o erro acima e começa a mostra outro.
A cada tentativa, ele instala novas coisas as poucos, mas para de vez nesse erro:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 8192 bytes) in /home/avesport/public_html/loja/downloader/pearlib/php/PEAR/Installer.php on line 540

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

Falae Denis, não tinha visto que existiam essas considerações sobre o php.ini
Mas agora outra questão. Minha loja já está na Web, como vou mexer no php.ini do servidor lá?! :(

E realmente, as configs do php são bem diferentes destas acima:

Resource Limits max_execution_time 30
Resource Limits max_input_time 60
Resource Limits memory_limit 32M

To ferrado?! hehehe

Valeu a força!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

Valeu pela Dica Denis! smile
Vou entrar em contato com o host pra ver dessa possibilidade.

O resultado eu posto aqui em breve.
Abraço!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

Entrei em contato com o pessoal do host e eles disseram que é só jogar as configurações que quero usar dentro dum arquivo txt e chama-lo de php.ini
Dai jogar esse arquivo na pasta onde o script que quero rodar esteja. Mas ai entra a questão:
Em que pasta jogo!?  hehehehe

Já tentei na pasta onde está o arquivo q da erro e nao deu certo :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
João Vagner
Member
 
Total Posts:  33
Joined:  2008-10-03
 

Pessoal,

Instalei o tema pelo magento connect, porém não consigo ativa-lo nem usar, onde e como eu configuro isso?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

Posso estar errado, pois não consegui instalar o tema… Mas pelo q li, vc deve ir em CMS > Manage Pages
Ai vc escolhe a HOME e muda o layout la. Da uma renovada no cache tb pra ajudar.

flw

 
Magento Community Magento Community
Magento Community
Magento Community
 
João Vagner
Member
 
Total Posts:  33
Joined:  2008-10-03
 

Modifiquei em: Sistema > Configuração > Design, em Temas, modifiquei de default pra modern ou blank, depende do seu tema instalado wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 
Denis Akao - 09 October 2008 08:44 AM

Estava pesquisando no forum sobre esse erro e encontrei esse topico http://www.magentocommerce.com/boards/viewthread/2510/
você fez as configurações recomendadas que vieram no php.ini.sample ???

memory_limit = 64M
max_execution_time = 18000

pode ser que resolva, eu configurei meu php.ini iqual o sample que eles mandaram.

ps.: backup antes de alterar não faz mal nenhum hehehe
abraços

Tentei e não consegui…
To achando que é meu host. To puto já
A loja nao envia emails pelo php() nem pelo SMTP. O Modern theme não instala… raiva. :/

 
Magento Community Magento Community
Magento Community
Magento Community
 
João Vagner
Member
 
Total Posts:  33
Joined:  2008-10-03
 

André,

cria um arquivo com o conteudo: <?php echo phpinfo(); ?> e mostra aqui, lá consegue ver a memoria estipulada, e as configurações a mais. Quanto a loja não enviar pelo mail(), talvez esteja desconfigurada, e só aceite conf. de SMTP mesmo, se nem o smtp envia, heheh troca de host rasberry

http://www.iw2.com.br/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 
João Vagner - 19 October 2008 10:30 AM

André,

cria um arquivo com o conteudo: <?php echo phpinfo(); ?> e mostra aqui, lá consegue ver a memoria estipulada, e as configurações a mais. Quanto a loja não enviar pelo mail(), talvez esteja desconfigurada, e só aceite conf. de SMTP mesmo, se nem o smtp envia, heheh troca de host rasberry

http://www.iw2.com.br/

Falae João, fiz tudo isso já. Conversei com várias pessoas.
Peguei um plugin que instala o envio SMTP no magento, nao funcionou. Até adicionei o criador no skype, ele tentou me ajudar mas nada! Não conseguimos de jeito algum.

O problema era com as configurações da peste do host. Ao invés de tentar acertar 1 a 1, eu troquei de host!
Agora ta tudo funcionando como deveria. Passei muita raiva… mas agora já foi.
Valeu a força galera!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andre Xori
Member
 
Avatar
Total Posts:  70
Joined:  2008-05-02
 

Ah, outra coisa, consegui instalar o MODERN, mas ele só se aplicou a página inicial…
Como faço para aplicar as outras?!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top