Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Formulário de contato não envia email
 
albertobraschi
Member
 
Avatar
Total Posts:  43
Joined:  2008-09-06
Curitiba/PR
 

Estou postando um problema que encontrei ao utilizar templates do 1.3 no 1.4.

O formulario de contato não consegue enviar o email.

Nos template para magento 1.4 no template/contacts/form.phtml, foi adicionado um input “hidden” logo antes do botão de enviar.

Antes era assim:

<div class="button-set">

        <
class="required"><?php echo Mage::helper('contacts')->__('* Required Fields'?></p>
        <
input type="image" src="<?php echo $this->getSkinUrl('images/btn_submit.gif');?>" alt="<?php echo Mage::helper('contacts')->__('Submit') ?>"/>

    </
div>

Agora ficou assim:

<div class="button-set">

        <
class="required"><?php echo Mage::helper('contacts')->__('* Required Fields'?></p>
      <
input type="text" name="hideit" id="hideit" value="" style="display:none !important;" />

        <
input type="image" src="<?php echo $this->getSkinUrl('images/btn_submit.gif');?>" alt="<?php echo Mage::helper('contacts')->__('Submit') ?>"/>

    </
div>

A diferença esta aqui:

<input type="text" name="hideit" id="hideit" value="" style="display:none !important;" />

Espero que seja util..abrax

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top