Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fiz a actualização e deu-me erro 500
 
Luís Salvador
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2010-06-14
Loures (Portugal)
 

É o seguinte, eu tinha o Magento 1.4.0.1 (se não estou em erro) instalado e a funcionar. Mas resolvi actualizar manualmente* para a versão 1.4.1.0 (se não estou em erro).

*manualmente = envia zip para o servidor, descompactá-lo e trocar pelos ficheiros antigos.

Ao fazer isto deu-me o erro 500:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@sillabori.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

E não sei o que fazer para resolver isto. O Magento deve ter deixado de estar ligado à Base de Dados, não?

Alguém me ajuda?

Abraço.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Luís Salvador
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2010-06-14
Loures (Portugal)
 

Acho que troquei o .htaccess que já tinha pelo .htaccess que vem por defeito e o problema deve estar aí. Não tenho a certeza…

Só sei que fiz copy dos novos ficheiros para o alojamento, substitui-os e ficou com o erro…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Luís Salvador
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2010-06-14
Loures (Portugal)
 

Se ajudar, o site é http://sillabori.com/store e o ficheiro .htaccess tem isto (por default):

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    
php_value memory_limit 128M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    
php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

    
php_flag zend.ze1_compatibility_mode Off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none


# AddDefaultCharset Off
AddDefaultCharset UTF-8
 
Magento Community Magento Community
Magento Community
Magento Community
 
Luís Salvador
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2010-06-14
Loures (Portugal)
 

Já consegui resolver sozinho, obrigado na mesma.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bruno Assarisse
Sr. Member
 
Avatar
Total Posts:  119
Joined:  2009-09-13
São Paulo - Brasil
 

Luis, seria legal você compartilhar conosco qual foi a solução, para que outras pessoas com o mesmo problema possam descobrir o que fazer.

Acredito que tenha sido problema de permissões, estou correto?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Celson Camelo
Jr. Member
 
Total Posts:  1
Joined:  2010-07-09
 
Bruno Assarisse - 06 July 2010 05:10 AM

Luis, seria legal você compartilhar conosco qual foi a solução, para que outras pessoas com o mesmo problema possam descobrir o que fazer.

Acredito que tenha sido problema de permissões, estou correto?

o amigo ai nao deixou a experiencia dele, mas deixarei a minha, o problema no meu caso estava na permissão do arquivo index.php tem que ser alterada para 755

Abraços!

Celson Camelo

 
Magento Community Magento Community
Magento Community
Magento Community
 
celsopimentel
Jr. Member
 
Total Posts:  1
Joined:  2013-02-16
 

Tive o mesmo problema, e é uma pena que tem pessoas que só buscam soluções e não as compartilham quando as encontram. Mas graças ao amigo Celson, alterei as permissões do index.php e solucionou meu problema também.

Obrigado

Celson Camelo - 27 August 2010 08:01 AM

Bruno Assarisse - 06 July 2010 05:10 AM
Luis, seria legal você compartilhar conosco qual foi a solução, para que outras pessoas com o mesmo problema possam descobrir o que fazer.

Acredito que tenha sido problema de permissões, estou correto?

o amigo ai nao deixou a experiencia dele, mas deixarei a minha, o problema no meu caso estava na permissão do arquivo index.php tem que ser alterada para 755

Abraços!

Celson Camelo

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top