Magento Forum

Problème avec la v1.1.6
 
dev21
Jr. Member
 
Total Posts:  21
Joined:  2008-07-03
la roche sur foron
 

Hello !
J’ai un problème depuis que j’ai installé la v 1.1.6 (nouvelle installation, pas d’update), et en particulier avec le Pack FR, donc voila, si je met l’interface admin en francais, dans la gestion des produit, je ne peut plus éditer les options de l’onglet “bundle” et “custom options”.
Alors qu’avec l’interface en anglais tout roule !

merci pour l’aide…

voir mon post ici http://www.magentocommerce.com/boards/viewthread/18025/

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Salut,

Je n’arrive pas à reproduire ton pb.
J’ai une version v1.1.6 de Magento avec le pack FR v1.1.5.

As-tu rafraichi le cache de ton serveur et celui de ton navigateur ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dev21
Jr. Member
 
Total Posts:  21
Joined:  2008-07-03
la roche sur foron
 

désolé, j’ai résolu mon problème depuis, j’utilisai la traduction disponible ici ici au lieu d’installer le pack fr depuis magentoConnect. Merci toutefois pour ton aide. au fait pourquoi ca ne marche pas avec ces fichiers ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Dans cette version, il doit rester des apostrophes dans du texte utilisé dans le javascript. Et du coup, le javascript plante.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FredB
Jr. Member
 
Total Posts:  7
Joined:  2008-10-26
 

Bonjour,

Impossible de pouvoir installer Magento en local, j’ai ce retour d’erreur :

Fatal error: Call to a member function children() on a non-object

C’est d’ailleurs une question posée il y a un an par le Capitaine :
http://www.magentocommerce.com/boards/viewthread/57/

Config :
Apache 2.2.4
PHP 5.2.1
Mysql : 5.0.27
Toutes les extensions nécessaires chargées.

J’ai bien télécharger le magento-check ( http://www.magentocommerce.com/knowledge-base/entry/how-do-i-know-if-my-server-is-compatible-with-magento), qui ne fonctionne pas correctement puisqu’il me dit que ma version de mysql est < à la 4.1.2, mais c’est une erreur dans leur fichier php.

J’ai ensuite essayé sans succès le downloader, qui a bloqué après la configuration.

Fatal error: Uncaught exception ‘Zend_Db_Statement_Exception’ with message ‘SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘magento.core_resource’ doesn’t exist’ in C:\Program Files\wamp\www\magento2\lib\Zend\Db\Statement\Pdo.php:238 Stack trace: #0 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Statement.php(283): Zend_Db_Statement_Pdo->_execute(Array) #1 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Adapter\Abstract.php(406): Zend_Db_Statement->execute(Array) #2 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Adapter\Pdo\Abstract.php(206): Zend_Db_Adapter_Abstract->query(Object(Varien_Db_Select), Array) #3 C:\Program Files\wamp\www\magento2\lib\Varien\Db\Adapter\Pdo\Mysql.php(199): Zend_Db_Adapter_Pdo_Abstract->query(Object(Varien_Db_Select), Array) #4 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Adapter\Abstract.php(694): Varien_Db_Adapter_Pdo_Mysql->query(Object(Varien_Db_Select), Array) #5 C:\Program Files\wamp\www\magento2\app\code\core\Mage\Core\Model\Mysql4\Re in C:\Program Files\wamp\www\magento2\lib\Zend\Db\Statement\Pdo.php on line 238

Merci de vos explications

Fred

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Bonjour,

Il aurait été préférable de créer un autre sujet dans le forum installation !!!

Apparemment, Magento détecte une mauvaise installation de MySQL, antérieure à la 4.1.2, et ne se comporte pas correctement.
La première chose à faire serait de complètement désinstaller toute installation de MySQL et réinstaller la dernière.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FredB
Jr. Member
 
Total Posts:  7
Joined:  2008-10-26
 
SeL - 27 October 2008 04:40 AM

Bonjour,

Il aurait été préférable de créer un autre sujet dans le forum installation !!!

Apparemment, Magento détecte une mauvaise installation de MySQL, antérieure à la 4.1.2, et ne se comporte pas correctement.
La première chose à faire serait de complètement désinstaller toute installation de MySQL et réinstaller la dernière.

Pourquoi créer un autre sujet, puisque le titre de celui-ci est parfaitement explicite ?
Si 100 personnes ont un problème avec la v1.1.6, ils ne vont pas créer 100 sujets différents qui vont nécessiter 100 lectures différentes, sauf si un de ces sujets est résolu. Il est beaucoup plus opportun de tout regrouper sur le même sujet. wink

Je l’ai dit, ce n’est pas Magento qui détecte une mauvaise installation de MySQL, c’est le script magento-check.php qui n’est pas correct.

preg_match('/[0-9]\.[0-9]+\.[0-9]+/'shell_exec('mysql -V')$version);
if(
version_compare($version[0]'4.1.20''<')) {
            $fail 
.= '<li>You need<strong> MySQL 4.1.20</strong> (or greater)</li>';
        
}
        
else {
            $pass 
.='<li>You have<strong> MySQL 4.1.20</strong> (or greater)</li>';
        
}
Si $version n’est pas un tableau, le script va toujours renvoyer $fail au lieu de $pass.
Il serait strictement inutile de réinstaller MySQL puisque j’ai la bonne version, à savoir 5.0.27.
D’ailleurs, il suffit de lancer ce script pour le savoir, même si l’info est déjà donnée par Wamp :
<?php
$link 
mysql_connect('localhost''root''');
if (!
$link{
die('Impossible de se connecter Ã  la base : ' mysql_error());
}
printf
("Version du serveur MySQL : %s\n"mysql_get_server_info());
echo 
'<hr />';
?>
Je peux même lancer cette requête qui me donnera aussi une version de 5.0.27 :
SELECT VERSION();
Donc, SeL, ce n’est pas Magento qui se comporte pas correctement suite à une “mauvaise” installation, c’est Magento qui renvoie une erreur fatale alors que toute la configuration demandée est correcte.
 
Magento Community Magento Community
Magento Community
Magento Community
 
Fibo
Sr. Member
 
Avatar
Total Posts:  107
Joined:  2008-06-25
Marseille, France
 

Peux-tu regarder les fichiers que tu as modifiés, notamment les xml (dont etc/local.xml) pour vérifier qu’ils son bein en UTF8?

 
Magento Community Magento Community
Magento Community
Magento Community
 
FredB
Jr. Member
 
Total Posts:  7
Joined:  2008-10-26
 
Fibo - 27 October 2008 09:36 AM

Peux-tu regarder les fichiers que tu as modifiés, notamment les xml (dont etc/local.xml) pour vérifier qu’ils son bein en UTF8?

Je n’ai rien modifié, pourquoi cette interprétation ?
Je m’exprime mal ou vous comprenez mal ? wink

1) Avec la full release 1.1.6, j’ai la première erreur notée (qui a été signalée il y a un an de cela par le capitaine sans réponse).

Fatal error: Call to a member function children() on a non-object

2) avec le downloader, j’ai la deuxième erreur notée.

Fatal error: Uncaught exception ‘Zend_Db_Statement_Exception’ with message ‘SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘magento.core_resource’ doesn’t exist’ in C:\Program Files\wamp\www\magento2\lib\Zend\Db\Statement\Pdo.php:238 Stack trace: #0 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Statement.php(283): Zend_Db_Statement_Pdo->_execute(Array) #1 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Adapter\Abstract.php(406): Zend_Db_Statement->execute(Array) #2 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Adapter\Pdo\Abstract.php(206): Zend_Db_Adapter_Abstract->query(Object(Varien_Db_Select), Array) #3 C:\Program Files\wamp\www\magento2\lib\Varien\Db\Adapter\Pdo\Mysql.php(199): Zend_Db_Adapter_Pdo_Abstract->query(Object(Varien_Db_Select), Array) #4 C:\Program Files\wamp\www\magento2\lib\Zend\Db\Adapter\Abstract.php(694): Varien_Db_Adapter_Pdo_Mysql->query(Object(Varien_Db_Select), Array) #5 C:\Program Files\wamp\www\magento2\app\code\core\Mage\Core\Model\Mysql4\Re in C:\Program Files\wamp\www\magento2\lib\Zend\Db\Statement\Pdo.php on line 238

Mon problème est simple, pas forcément sa réponse.
Quel que soit la méthode utilisée, et malgré que mes configurations soient bonnes, j’obtiens toujours un erreur.
Et cela même en répétant plusieurs fois l’opération.
Comment se fait-il que vous puissiez ne pas en avoir ?
Il y a forcément une anguille quelque part, ou une config requise qui a été oubliée.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Re bonjour,

La première erreur ne me dit rien. La Capitaine l’a peut-être eu il y a un an, mais c’était sur la version beta. Donc, on oublie.

La deuxième erreur est plus explicite. Il ne trouve pas la table “magento.core_resource” dans ta BDD.
Cette table est une des premières que Magento crée et utilise car il y stocke les informations des versions de modules installées.
Es-tu certain de ta config et des pré-requis ???

 
Magento Community Magento Community
Magento Community
Magento Community
 
FredB
Jr. Member
 
Total Posts:  7
Joined:  2008-10-26
 
SeL - 27 October 2008 11:42 PM

Re bonjour,

La première erreur ne me dit rien. La Capitaine l’a peut-être eu il y a un an, mais c’était sur la version beta. Donc, on oublie.

La deuxième erreur est plus explicite. Il ne trouve pas la table “magento.core_resource” dans ta BDD.
Cette table est une des premières que Magento crée et utilise car il y stocke les informations des versions de modules installées.
Es-tu certain de ta config et des pré-requis ???

Salut SeL,

J’ai une bonne nouvelle, car j’ai réussi à installer Magento.
Oui, j’étais bien certain de mes configs et des pré-requis.
Ce que j’ai fait, c’est désinstaller Wamp5 (qui n’est plus développé de toute façon) pour installer à la place Wampserver 2. Et c’est tout.
Je pense donc qu’il est tout à fait probable que des prés-requis supplémentaires dans le http.conf et/ou le php.ini soient nécessaires.
Ca pourrait être bien de faire remonter le problème à la core team, car il ne suffit pas visiblement d’avoir uniquement php 5.2.0 ou +, mysql 4.1.2 ou + et les extensions php nécessaires.
J’ai laissé mes rapports de bug sur le site.

Je suis impatient de pouvoir tester Magento maintenant qui me semble rien d’autre que fabuleux.

Meci en tout cas d’avoir porté une attention à mes problèmes d’install.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top