Magento Forum

Page 5 of 5
Skipping import row, required field “sku” is not defined. 
 
hdaict
Jr. Member
 
Avatar
Total Posts:  10
Joined:  2011-08-02
Netherlands (Groningen)
 

How did you made the CSV file?

It\’s also a verry big one of i look to the headers, maybe you can look if you really need everything?

I did it with our feed, i only putted the data in the feed that i need to import. So i don\’t have anny empty fields, on that way you have some overview.

We had in first time imported the products into other tables than the database tables of Magento. After that, i made a PHP script that made my new CSV to use in Magento Dataflow Profile.

I think you first need to determine wich information you whant to impor, try to get only this data in youre CSV file

You tried to import with the standard import? Dont use that one, go to Dataflow Profiles and add a profile. You can give the profile the standard Magento CSV file or you can make youre own. Than you can make youre own CSV in divisions.

While making the Profile, you have the option to make youre own profile. The first row is from the database the second row is the row of youre CSV file.

Try to give it the same order as in youre CSV!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JoshCMayorga
Member
 
Avatar
Total Posts:  31
Joined:  2008-10-07
Miami, FL
 

Thanks but I figured it out on my own. I exported the products again, this time through dataflow, export all products. Then had an issue with images, but I just had to move the images from the “media/catalog/products” folder into “media/import” folder. All products imported!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zbynja
Jr. Member
 
Total Posts:  3
Joined:  2009-11-27
 

In my case it was due to encoding. Using both Windows and Linux.

Saving as UTF8 was not enough, I had to save as UTF8 without BOM
(took me ages and lot of new gray hair to figure this out)

HTH
Z

 
Magento Community Magento Community
Magento Community
Magento Community
 
highwaykind
Jr. Member
 
Total Posts:  10
Joined:  2010-08-25
 

Holy hell this was a hassle to figure out!!! I finally got it to work.

Here’s a quick ‘how to’ for those who had the same issues.

In the Backend of Magento : System - Import/Export - Dataflow Profiles.

Choose Export All Products. Save the CSV.

Open that CSV in Calc in Open Office.
Check that everything looks ok, replace/add products then click
Save As - Text CSV
Another window will popup Export Text File.
Set the top option to UTF-8
second leave as , (comma)
third leave as “(double quote)
Check the box that says ‘Quote all cells”
Hit save - this will save the CSV

Backend Magento - System - Import/Export - Dataflow Profiles - Import All Products.
Upload your file in the Upload file tabe (I hit Save and continue edit).
then click Run Profile.
This will import everything.
Done!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jselvam
Jr. Member
 
Total Posts:  11
Joined:  2012-08-12
Trichy
 
nasshop - 30 June 2010 05:47 AM

I did have the same problem, gave me serious headache but i found a solution that works for me, the only way i can get it to work is to use open office instead of MS excell for it, no matter what i try with excell, i cannot get it to work.

Open it in open office, then save it as a text .csv and it worked for me surprisingly, i do not know why but excell does something with it that it is unreadable.

I use excell 2007 version and magento 1.4.1.0 , so that does not work.
Download open office and try it out.
I also use dutch translation, I hope this works for you !!!!  Because it is hell if you break your head over it for a week and can’t upload a thing.

Doe anybody knows How I can upload new products, as this still gives me problems.
If it does not have an excisting SKU, i cant upload new products from a csv???

And that is really Works. Thanks for this post and Open office software.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jensen_tw
Newbie
 
Total Posts:  0
Joined:  2013-03-31
 

have the same problem

 
Magento Community Magento Community
Magento Community
Magento Community
 
SirPereira
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2013-07-11
 
highwaykind - 17 July 2012 04:34 AM

Holy hell this was a hassle to figure out!!! I finally got it to work.

Here’s a quick ‘how to’ for those who had the same issues.

In the Backend of Magento : System - Import/Export - Dataflow Profiles.

Choose Export All Products. Save the CSV.

Open that CSV in Calc in Open Office.
Check that everything looks ok, replace/add products then click
Save As - Text CSV
Another window will popup Export Text File.
Set the top option to UTF-8
second leave as , (comma)
third leave as “(double quote)
Check the box that says ‘Quote all cells”
Hit save - this will save the CSV

Backend Magento - System - Import/Export - Dataflow Profiles - Import All Products.
Upload your file in the Upload file tabe (I hit Save and continue edit).
then click Run Profile.
This will import everything.
Done!

This made it.

I was using LibreOffice (in Linux), but it worked.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
sopedro
Jr. Member
 
Total Posts:  17
Joined:  2011-12-06
 

Hi to all,

The solution for this issue is in Dataflow - Profiles, select the apropriate delimiter.
For default the delimiter is “;”, in my case i have to change it to “,” and works fine.

Regards,

Pedro

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 5 of 5