Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Skipping import row, required field “sku” is not defined. 
 
fourroses666
Sr. Member
 
Total Posts:  90
Joined:  2010-11-15
 

thanks for your explination, so upload files places it there..

i noticed by export, my category ids have 17,18 and the tab is also , so the tables where not correct so that was a struggle.

anyway i fixed it by exporting a new file, (picked only 1 category for the exported file), and then added my products etc and imported it. Now it does work but it was a hell of a ride…

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Like your description, heh. Frustrating, maddening, irritating and sadly, once you get it working, you wonder what all the fuss was about. Until you upgrade from 1.3.1.1 to 1.4.1.1 and find that your dataflow starts taking hours of time and gigabytes of memory. And after several months of frustration and using workarounds, this arrives eliminating a vast memory leak, and you proceed to get on with it.

Been there, done that, and they were out of the tee shirts when I got to the exit gate.  shut eye

 
Magento Community Magento Community
Magento Community
Magento Community
 
fourroses666
Sr. Member
 
Total Posts:  90
Joined:  2010-11-15
 

its a learning experience hehe, when my site is finished im gona check out how to make it faster, it just takes too much time to load while it stands on a server made for magento webshops. Must be tweaks out there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Hello,

I have to import products from 1.3.2.4 to 1.5.0.1, but I have the same error message.

The columns titles of my .csv export file are:
store
websites
attribute_set
type
sku
category_ids
...

To compare I exported the samples products of 1.5.0.1, and the columns titles of the .csv export file are differents:
sku
_store
_attribute_set
_type
_category
_product_websites
...

Do you think I must modify my .csv export file 1.3.2.4,and replace the columns titles like 1.5.0.1?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Boatmagic
Sr. Member
 
Avatar
Total Posts:  91
Joined:  2010-08-14
 

I believe the new import functionality is crapola..

Nothing I do seems to fix the issue and when I upen the file and click check data, I get the error
‘csv’ file extension is not supported
Please fix errors and re-upload file

What the heck does that even mean Magento team?  And btw, thanks for no documentation again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ceefour
Member
 
Avatar
Total Posts:  52
Joined:  2008-09-16
Bandung, Indonesia
 
Boatmagic - 12 March 2011 10:07 AM

I believe the new import functionality is crapola..

Nothing I do seems to fix the issue and when I upen the file and click check data, I get the error
‘csv’ file extension is not supported
Please fix errors and re-upload file

What the heck does that even mean Magento team?  And btw, thanks for no documentation again.

Disable the Magento Compiler under System > Tools > Compilation. Then retry the import. Should work now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Boatmagic
Sr. Member
 
Avatar
Total Posts:  91
Joined:  2010-08-14
 

Thanks for the tip. It worked, but now I get errors

Product Type is invalid or not supported in rows: 1, 2, 3, 4, 5

This is quiet funny since I deleted that column in my .csv file.

This just gets better and better!

If you use the Dataflow - Profiles it will take the csv with a column named product_type?
But not with the new import/export

 
Magento Community Magento Community
Magento Community
Magento Community
 
ceefour
Member
 
Avatar
Total Posts:  52
Joined:  2008-09-16
Bandung, Indonesia
 
Boatmagic - 23 March 2011 04:43 PM

Thanks for the tip. It worked, but now I get errors

Product Type is invalid or not supported in rows: 1, 2, 3, 4, 5

This is quiet funny since I deleted that column in my .csv file.

This just gets better and better!

If you use the Dataflow - Profiles it will take the csv with a column named product_type?
But not with the new import/export

You shouldn’t delete the product_type column.

It should contain e.g. “simple”, “configurable”, etc.

I’m using Magento 1.5.0.1’s new import/export and currently loving it. I still can’t import multiple images per product but overall the process works smoothly and quick.

 
Magento Community Magento Community
Magento Community
Magento Community
 
charford
Jr. Member
 
Total Posts:  28
Joined:  2009-05-07
 

I am not sure if anyone is still following this thread, but I recently had this issue after upgrading from 1.3 to 1.5 and switching servers at the same time. For me the sku error had nothing to do with the sku column at all. I was able to figure out which products were giving me a problem and then I deleted a column at a time from the spreadsheet until I was able to figure out what caused the error.

I am not sure if this will work for anyone else, but for me I deleted the long and short descriptions and all of a sudden everything worked. Also I switched to UTF-8 encoding and that solved another separate issue that I was having.

I am not exactly sure what caused the error in these long and short descriptions but I have 2 theories. First, I copy and pasted this text into the columns from MS Word. I have run into this problem before when adding products through the admin- somehow the formatting is not correct and it screws everything up. For me, this only happened with 10 products so I will just add the descriptions through the admin- if you have a million different products that could be a real issue, I would try clearing all formatting from the text in MS Word before pasting.

Also, in these categories I pasted in some HTML tags such as <strong> and a few breaks I think. I do not think this was the issue as there were about 50 other products that also have some HTML in them that did not have an error.

It is possible it could have had something to do with incorrect symbols as well, I remember someone telling me once that if you have a slash or apostrophe that is misplaced it could cause a problem, although I do not think this is the case.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ceefour
Member
 
Avatar
Total Posts:  52
Joined:  2008-09-16
Bandung, Indonesia
 
charford - 29 March 2011 06:17 PM

I am not sure if anyone is still following this thread, but I recently had this issue after upgrading from 1.3 to 1.5 and switching servers at the same time. For me the sku error had nothing to do with the sku column at all. I was able to figure out which products were giving me a problem and then I deleted a column at a time from the spreadsheet until I was able to figure out what caused the error.

I am not sure if this will work for anyone else, but for me I deleted the long and short descriptions and all of a sudden everything worked. Also I switched to UTF-8 encoding and that solved another separate issue that I was having.

This is caused because your short/long description field contents contain line breaks e.g. CR/LF/CRLF characters.
When opening your CSV file with a text editor (turn off word wrap) this should be obvious.

Replace all line break characters with space or with “<br />” (HTML line break) and this error should be gone.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FntsyBlacksmith
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2009-09-28
 
fguarien - 06 July 2010 08:16 AM

THE SOLUTION IS IN UTF-8

I have had the exact same problem.
I used numbers (apple ilife) and exported to UF-8 format.
It is working perfectly…

this worked for me!

 
Magento Community Magento Community
Magento Community
Magento Community
 
harrydecosta
Jr. Member
 
Total Posts:  1
Joined:  2011-04-07
 

I did have the same problem, I gave me a serious headache but works for me, the only way ı can get it to work for a solution to open office, ms Excel, no matter what I try to use bulunduı instead of ‘almak it work with Excel can’t. Open office save as .csv text, then open it and it worked for me, I don’t know why, but something with it in either Excel, Marvel does.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Excel has a slightly hidden setting that must be enabled. Here’s how to export CSV with UTF-8 encoding from Excel Excel 2007 Excel 2003

 
Magento Community Magento Community
Magento Community
Magento Community
 
sh4d0w
Jr. Member
 
Total Posts:  16
Joined:  2009-04-10
 
Hendy Irawan at Soluvas.com - 16 March 2011 08:58 AM

Boatmagic - 12 March 2011 10:07 AM
I believe the new import functionality is crapola..

Nothing I do seems to fix the issue and when I upen the file and click check data, I get the error
‘csv’ file extension is not supported
Please fix errors and re-upload file

What the heck does that even mean Magento team?  And btw, thanks for no documentation again.

Disable the Magento Compiler under System > Tools > Compilation. Then retry the import. Should work now.

Thank you, this solved my issue. I couldn’t figure out why my test site would except the CSV and my live site wouldn’t.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bananarama
Jr. Member
 
Total Posts:  4
Joined:  2011-04-21
 

Having this issue using Microsoft Office Excel for Mac OS I believe having some odd characters copy and pasted into my csv from another exported csv in the description column may have been the cuplrit.

In any event simply saving out my .csv then opening it in Mac’s

TextEdit application -> Save As -> Plain Text Encoding : Switch to Unicode UTF-8

This was the easiest tool to convert the csv UTF-8 IMO, as Dreamweaver and Excel for Mac offered no options for conversion when saving as a .csv

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top