Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 5
Skipping import row, required field “sku” is not defined. 
 
jotacee
Jr. Member
 
Total Posts:  7
Joined:  2010-02-16
 
TiaID - 27 June 2010 11:26 AM

oke do you have an example for the header names ? I mean the whole row ...

Because ..

Im dutch and I use also the dutch translation of magento… must I use for example SKU or article number ? Or must I do it in Dutch ?

It’s not an issue with header names. It must contain attribute names, exactly as they are set in Attributes page under Catalog, in Admin.

I get the same error when importing a CSV file with 39 rows: it loads only 10, and I get 29 “skipping import...” errors.

Anybody figured out why?

Thanks
jc

 
Magento Community Magento Community
Magento Community
Magento Community
 
ocshawn
Jr. Member
 
Total Posts:  16
Joined:  2010-06-17
 
jotacee - 08 July 2010 07:25 AM


I get the same error when importing a CSV file with 39 rows: it loads only 10, and I get 29 “skipping import...” errors.

Anybody figured out why?

Thanks
jc

Its the same reason the others were getting errors try using anything but MS Excel to make your csv

 
Magento Community Magento Community
Magento Community
Magento Community
 
leer0ybr0wn
Jr. Member
 
Total Posts:  1
Joined:  2010-07-22
 

Hi guys,

We had the same problem - some products were importing, others didn\’t (all on the same spreadsheet). I tried editing in notepad, checking columns, everything and still had the same issue.
Eventually we realised that the products that weren\’t importing contained fractions (like ¼) so I replaced these with .25, .5, or .75. Uploaded the csv and it worked! grin

So check your csv files for strange characters!

Lee

 
Magento Community Magento Community
Magento Community
Magento Community
 
izpub
Jr. Member
 
Total Posts:  4
Joined:  2008-07-08
 

I have also the \"Skipping import row, required field \"sku\" is not defined.\” problem.

I solved the problem by entering a unique SKU value in the SKU column (XML/CSV). The funny part is that I set the attribute \"SKU\" to \"not required\”, but needs it anyway while importing the products. Hope it helped you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vinnycool
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2010-06-20
 

Like it has been mentioned before, the answer is UTF-8. I’ve decided to write a tutorial to help those who are getting errors when importing a .csv file in Magento. Here’s the link:

http://www.designincontrast.com/blog/2010/07/skip-import-row-required-field-sku-not-defined-skip-import-row-required-field-store-not-defined-solution-magento/

I hope this helps you!

Professional & Affordable Website Design Services

 
Magento Community Magento Community
Magento Community
Magento Community
 
jotacee
Jr. Member
 
Total Posts:  7
Joined:  2010-02-16
 

I found how to use Excel to export CSV in UTF-8… Thanks google smile

In the screenshots attached you’ll see that at Save us… box, there is a “Tools” button that will drive you to setting up the UTF-8 encoding format (for me it’s so important as in Spanish we have characters like á é ó ú...)

Hope it helped somebody.

Regards from Spain (World Champions wink)
jc

 
Magento Community Magento Community
Magento Community
Magento Community
 
Xavante
Jr. Member
 
Total Posts:  16
Joined:  2009-05-15
 

I’ve got the same problem and now been solved by using UTF-8, thanks vinnycool!

 
Magento Community Magento Community
Magento Community
Magento Community
 
johnlouis
Sr. Member
 
Avatar
Total Posts:  92
Joined:  2008-08-27
 

I also encountered the same problem. What i did was opened the CSV file in notepad++ ,and in notepad++ we have an option for converting the file to utf-8 without bom .Do it and then save (format>>convert to utf-8 without bom). After that there was no such messages as skipping import row.

Hope it helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
ferddi
Jr. Member
 
Total Posts:  1
Joined:  2010-10-01
costa rica
 

Same problem but now is fixed and work..thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
stu1903
Jr. Member
 
Total Posts:  25
Joined:  2010-06-06
 
ferddi - 01 October 2010 02:50 PM

Same problem but now is fixed and work..thanks

So how did you solve it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
noobuserr
Jr. Member
 
Total Posts:  11
Joined:  2009-01-18
Ohio
 
nasshop - 30 June 2010 05:47 AM

I did have the same problem, gave me serious headache but i found a solution that works for me, the only way i can get it to work is to use open office instead of MS excell for it, no matter what i try with excell, i cannot get it to work.

Open it in open office, then save it as a text .csv and it worked for me surprisingly, i do not know why but excell does something with it that it is unreadable.

I use excell 2007 version and magento 1.4.1.0 , so that does not work.
Download open office and try it out.
I also use dutch translation, I hope this works for you !!!!  Because it is hell if you break your head over it for a week and can’t upload a thing.

Doe anybody knows How I can upload new products, as this still gives me problems.
If it does not have an excisting SKU, i cant upload new products from a csv???

Worked for me!!! Did not realize how useful Open Office was. I will use office 2007, but copy it over to open office before submitting to correct the Character set (should be Unicode UTF-8 or ASCII). Thanks so much!

 
Magento Community Magento Community
Magento Community
Magento Community
 
CoolThinker
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2009-03-08
 
vinnycool - 30 July 2010 12:24 AM

Like it has been mentioned before, the answer is UTF-8. I’ve decided to write a tutorial to help those who are getting errors when importing a .csv file in Magento. Here’s the link:

http://www.designincontrast.com/blog/2010/07/skip-import-row-required-field-sku-not-defined-skip-import-row-required-field-store-not-defined-solution-magento/

I hope this helps you!

Professional & Affordable Website Design Services

This worked for me. Sorry to say I had to read most of the postings about this issue before I came across your answer. I wish the Magento team would allow forum visitors to rank answers based on how helpful they are so people can tell right away when something is the right solution (or at least the most likely to work) based on user comments.

Thanks again VINNYCOOL!

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

@ jotacee

Looks like you’re using Excel 2007 for your data.

I’d looked for the UTF-8 encoding, but actually use Access 2003 because Excel is kind of a poor database tool, but an excellent spreadsheet and exporting UTF-8 is one of Access’s normal options during CSV export (Click Advanced… button on export dialog box.) smile

Since a lot of my work is comparing data exported from various programs, having it in databases is a natural. But most people aren’t going to go buy Access when they have Excel just sitting there begging to be used. Excel 2003 is slightly different, on the Save As… dialog box, the Tools button is at the top. Select Web Options, and then the Encoding Tab on the secondary dialog box. Change to UTF-8.

Saves you having yet another office productivity suite (loading Open Office) just to save files with UTF-8 encoding

 
Magento Community Magento Community
Magento Community
Magento Community
 
fourroses666
Sr. Member
 
Total Posts:  90
Joined:  2010-11-15
 

tried it all, no success…

downloaded open office, notepat ++, and tried excel but still get the skip errormessage in 1.4.1.1
is there anyone who wants to convert my csv file correct then plz pm?

also im having 2 import options??

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

@fourroses666

What you’re showing is an ever expanding list of uploaded import files that grows with each import, unless you go to /var/import and delete the import files. I put in a cron job that deletes files in /var/import to eliminate anything older than a day, you can just navigate to /var/import after doing an import and simply empty the folder.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 5