Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problemas instalacion en Arsys
 
Viebone
Jr. Member
 
Total Posts:  5
Joined:  2008-09-22
 

Hola a todos!

Me esta resultando imposible instalar Magento en Arsys, tenemos un plas ISP sobre linux, con PHP 5.1.6.

Todos los requisitos menos el del PHP 5.2 y la extension myscript parece que los cumple por el test que he hecho.

He subido el CGI y configurado el archivo .htacces, pero me sique diciendo que la versión de php no es la correcta, aquí podeis ver un php info por si sirve de ayuda.

Si alguien me puede echar una mano se lo agradecería un montón.

El .htaccess es el siguiente:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

Action php5-cgi /cgi-bin/php5-cgi
AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sebastian G
Guru
 
Total Posts:  336
Joined:  2007-09-15
 

Viebone, en el test mismo tienes el resultado de porqué tu servidor no cuenta con los requisitos de instalación:

Your server does not meet the following requirements in order to install Magento.
The following requirements failed, please contact your hosting provider in order to receive assistance with meeting the system requirements for Magento:

* You need PHP 5.2.0 (or greater)
* You are missing the mcrypt extension

Por lo que se ve en tu php info todavía cuentas con php 5.1.6 cuando para poder utilizar Magento debes contar con php 5.2.0 (o mayor)
Espero sea de ayuda smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Viebone
Jr. Member
 
Total Posts:  5
Joined:  2008-09-22
 

Gracias!

Si, ya se que no tiene php 5.2, pero para eso el equipo de Magento ofrece una solución, que es utilizar un cgi, pero que yo no consiguo hacer funcionar, y no se por que motivo.

He seguido todos los pasos pero parece ser que mi servidor no permite anular el fileinfo via .htaccess.

Lo que no se es si hay alguna manera de arreglar esto o lo mejor es cambiar de hosting.

Gracias otra vez.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sebastian G
Guru
 
Total Posts:  336
Joined:  2007-09-15
 

Preferentemente sería mejor que tu proveedor de Hosting cuente con los requisitos smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top