Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Customer login problem
 
fifaking1
Jr. Member
 
Total Posts:  1
Joined:  2010-06-06
 

The customer can’t login the front-end.  (When I typed the wrong login info, it could return warning msg.)
The server seems has no response after I used correct login info to login.
It still has no response even I called the site in new tag and new browser.
At last, I need to restart the Apache server. But the problem just repeated when I tried to login again.

I suspect that the problem is caused by actions of adding rules, adding attribute, etc..
anybody have idea can help to figure out the problem~~
I’m using 1.4.1.0 version.
thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
DCAlmeida
Sr. Member
 
Avatar
Total Posts:  164
Joined:  2008-12-28
PRT
 

Without any log or report we can’t help…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jerry Guo
Sr. Member
 
Total Posts:  85
Joined:  2008-08-18
china
 

same as me,

I tried to solve it , login into backend , and find the customer, open and then save the account again,

it can be login in. I don’t know why.

but it will be happened again in few days after.

 
Magento Community Magento Community
Magento Community
Magento Community
 
luca.dapruzzo
Jr. Member
 
Total Posts:  4
Joined:  2010-03-18
 

same as me, we are running 1.4.1.1
Save the customer seems to solve, but the problem come back chronically. Sometimes even on the same customer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Media Heroes
Jr. Member
 
Total Posts:  4
Joined:  2011-01-18
 

I have a similar issue, but mine is specific to only my second store view, the default store view works fine, but my second store view which runs off its own template just refreshes after the correct log ins are used, I also can’t request a new password from the second store view either.

If anyone can help me with this you will be saving me from ripping my hair out! Im completely out of ideas and i can’t seem to find anyone with the same problem.

SOS!

 
Magento Community Magento Community
Magento Community
Magento Community
 
BjoneMan
Member
 
Total Posts:  45
Joined:  2009-03-04
 

Has anybody found a solution?
faceing the same problem!
Login onbackend works!
Customers cant login no error nothing just a loop back to the
account login page !
If i use a wrong customer or password i get the normal error message!
Thankfull for any help!!!!!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
BjoneMan
Member
 
Total Posts:  45
Joined:  2009-03-04
 

Hello erverybody,
i have solved the issus on my problem.
I dont know if it’s relevant to you but
there extensions like Aitoc Booster
which uses a kind of cookie rewirte.
In my case the cookie that should have .domain.de
in the CookieDomain description was changed
to .www.domain.de because it uses a rewrite with
the value of ‘.’ . $_SERVER[’HTTP_HOST’] which is
not always the same as the value set in backend for
the cookie domain.
So if you have set cookie domain in backend to something
like .domain.de have a look at your cookies in your brwoser and
check if they are really valid.
in Firefox you could look under config/data privacy.
Hope this will help, but it’s a not known bug so far.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lopedd
Jr. Member
 
Total Posts:  9
Joined:  2010-05-14
 

I have the same problem. Any solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
forhomeshop11
Jr. Member
 
Total Posts:  8
Joined:  2011-06-14
 

Had this issue before and I’ll document what worked for me.

Go to you admin panel and navigate to; System=> Configuration=> Web (under General)=> Session Validation Settings and make sure all of them are set to “No”. In my case I was using SID on frontend, seems it was giving bad SIDs or something which made the session unvalid (which it wasn’t actually).

Hope this solves at least some people’s problems:)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Flipmedia
Member
 
Avatar
Total Posts:  43
Joined:  2009-09-24
 

I am experiencing this exact same issue.

I have applied the suggested cookie configuration, this has not resolved the problem.

Once a user is having an issue with logging in the account becomes \\\"locked\\\". The initial login will fail with the browser (Chrome) returning:-

No data received
Unable to load the webpage because the server sent no data.
Here are some suggestions:
Reload this webpage later.
Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

Attempting to visit any Magento delivered page in the site following this will always return the above result.

Deleting the cookies and therefore disassociating the browser with the session allows the site to be accessed again but the user is not logged in.

Updating / changing the password removing basket contents via the admin area allows the user to login.

We are using Magento ver. 1.4.2.0

Any feedback would be appreciated.

Laurie

 
Magento Community Magento Community
Magento Community
Magento Community
 
developerindia
Member
 
Total Posts:  58
Joined:  2009-06-25
 

Solved only this

Go to System->Comfiguration->Web->Session Cookie->Management

Cookie Domain = .yourdomain.com [this is (dot)yourdomain.com]

 
Magento Community Magento Community
Magento Community
Magento Community
 
derbas
Jr. Member
 
Total Posts:  19
Joined:  2009-09-06
 

I’m running Magento 1.7.0.2 with extension store restriction pro. This is my solution for customer login problem:

Check the Cookie settings under System -> Configuration -> Web

Cookie Domain = .yourdomain.com

I had to remove the dot infront of “.yourdomain.com”. Changing to “yourdomain.com” worked for me purpose.

 
Magento Community Magento Community
Magento Community
Magento Community
 
normanyclark
Jr. Member
 
Total Posts:  28
Joined:  2012-05-07
India
 

I think this cause from the local host problem. If you have set up Magento to run locally then you may be accessing the Apache webserver using the localhost hostname. A security setting in browsers means that the cookie will not be set.
So simply stop using localhost, you can use your localhost interface. To determine your localhost interface you can look at the contents of your hosts file:
Look for the number to the left of localhost
cat /etc/hosts
Once you know which number to use, you can replace localhost with the number. If you have already installed Magento using localhost then it will keep writing out links to localhost, even after you have changed to using the IP address, you will need to change the base_url values in the core_config_data table, you can run a query like this to find the right config values to change:

SELECT * FROM core_config_data WHERE VALUE LIKE “&#xlo;calhost%”;

 
Magento Community Magento Community
Magento Community
Magento Community
 
bkscott
Sr. Member
 
Avatar
Total Posts:  137
Joined:  2009-07-16
Sacramento
 

thank you forhomeshop11, this appears to be the cause of this problem in my case. I havent had the error since i changed this option, and i was getting the error on a daily basis.

forhomeshop11 - 23 December 2011 02:10 PM

Had this issue before and I’ll document what worked for me.

Go to you admin panel and navigate to; System=> Configuration=> Web (under General)=> Session Validation Settings and make sure all of them are set to “No”. In my case I was using SID on frontend, seems it was giving bad SIDs or something which made the session unvalid (which it wasn’t actually).

Hope this solves at least some people’s problems:)

 
Magento Community Magento Community
Magento Community
Magento Community
 
yashpalaegis
Jr. Member
 
Total Posts:  3
Joined:  2013-01-01
 

Sometime when the user are login in the page at that time give the error so can\’t excess the user in the login page. There are many different time of problem possible. Like, database error, site problem etc. Another thing an administrator give not the permission so that\’s a problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
track-23
Member
 
Total Posts:  33
Joined:  2011-02-09
 

I was having problems where after certain customers (not all) tried logging in with their correct credentials they would get returned to the login page without being logged in and with no error message being displayed. I tried the cookie domain “fix” and the session validation settings “fix” both mentioned in this thread, but none of that helped. Finally I was able to find this: http://www.novusweb.com/1340/e-commerce-technology/fix-for-passing-magento-session-ids/ and everything has seemed to work smashingly since. (It’s been almost a week.)

In case the link disappears here’s a summary of the code changes:

Duplicate the file app/code/core/Mage/Customer/Model/session.php to app/code/local/Mage/Customer/Model/session.php so your changes don’t get overwritten when upgrading. Then (on line 216 in Magento CE 1.7.0.2) change the following:

public function login($username$password)
    
{
        
/** @var $customer Mage_Customer_Model_Customer */
        
$customer Mage::getModel('customer/customer')
            ->
setWebsiteId(Mage::app()->getStore()->getWebsiteId());

        if (
$customer->authenticate($username$password)) {
            $this
->setCustomerAsLoggedIn($customer);
            
$this->renewSession();
            return 
true;
        
}
        
return false;
    
}

to

public function login($username$password)
    
{
        
/** @var $customer Mage_Customer_Model_Customer */
        
$customer Mage::getModel('customer/customer')
            ->
setWebsiteId(Mage::app()->getStore()->getWebsiteId());

        if (
$customer->authenticate($username$password)) {
            $this
->setCustomerAsLoggedIn($customer);
            
// $this->renewSession(); // Commented out to fix customer login loop
            
return true;
        
}
        
return false;
    
}

All you’re doing is commenting out

$this->renewSession();
so that the customer’s session is not renewed upon logging in.

I haven’t received any reports so far that it has resulted in any unforeseen related issues. For a full rundown go here: http://www.novusweb.com/1340/e-commerce-technology/fix-for-passing-magento-session-ids/

I hope that helps someone else. And thank you, Bret Williams of Novusweb!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2