Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP-CGI as a work-around. 
 
Viebone
Jr. Member
 
Total Posts:  5
Joined:  2008-09-22
 

Hi there,

Thanks for your time.

I’m trying to install Magento on a php 5.1.6 server using the php-cgi but I allways catch the same error:

Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.

I checked with my ISS that allows the FileInfo overrides via .htaccess files and they said me YES

I’ve checked the cgi path and all looks right

Someone can let my a hand???

Thanks a lot.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Post a link to your PHP info file:

http://www.magentocommerce.com/wiki/groups/227/create_a_php_info_file

 
Magento Community Magento Community
Magento Community
Magento Community
 
Viebone
Jr. Member
 
Total Posts:  5
Joined:  2008-09-22
 

Hello,

Thanks for your reply!!!

The file info url is:

file info

If you need anything else, please let me know.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

As the original error message stated, you need PHP 5.2.0 or greater. According to your PHP info file, you’re only running PHP 5.1.6, so that needs to be upgraded.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Viebone
Jr. Member
 
Total Posts:  5
Joined:  2008-09-22
 

Yes, I know that.

There is a CGI created to simulate de php 5.2, and I’m trying to run my shop with this cgi, but for something that I don’t know, I can’t.

I followed all the steps in the installation guide but seems to be a problem with de fileinfo via .htaccess, maybe my ISP doesn’t allow override the fileinfo via .htaccess. There is an other way to do that????

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
PhilipJTerry
Jr. Member
 
Total Posts:  4
Joined:  2009-01-07
 

Hi Viebone and Crucial

Did you manage to solve this issue?

Judging by the broken link - I assume not! I am having precisely the same problem.

The problem for us both as I understand is that we don’t want to upgrade our host to 5.2 for various reasons. Mine being for SEO reasons which is controversial. But I am not changing anything to do with my host.

Is there a way of installing to a 5.1 hosting provider?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top