Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t login to admin after installation! Please help! 
 
Emerald214
Jr. Member
 
Total Posts:  1
Joined:  2010-03-25
 
Mukesh Chapagain - 11 March 2010 02:02 AM

Update (For Magento 1.4.*)

In Magento 1.4, you have to comment code from line 86 to 98 in app/code/core/Mage/Core/Model/Session/Abstract/Varien.php. Like this:-

/*  if (!$cookieParams['httponly']) {
    unset($cookieParams['httponly']);
    if (!$cookieParams['secure']) {
        unset($cookieParams['secure']);
        if (!$cookieParams['domain']) {
            unset($cookieParams['domain']);
        }
    }


if (isset($cookieParams['domain'])) {
    $cookieParams['domain'] = $cookie->getDomain();
} */

Thanks.

Thank you very much. It works!!! I read all previous posts but they all doesn’t help. Now I can log in admin!!! ^^

 
Magento Community Magento Community
Magento Community
Magento Community
 
jetblab
Jr. Member
 
Total Posts:  5
Joined:  2009-01-24
 

I tried commenting out the lines as described above and I still can’t log-in to the admin.  This is VERY VERY frustrating.

Does anybody have any other ideas????

(On a side note: I find it funny that the first word in the captcha for making this post is the word “regret")

UPDATE:

I got it to work, and wanted to share my results.

I first had to update the cookie lengths as described earlier in this post using phpMyAdmin:

update core_config_data set value=86400 where path=’web/cookie/cookie_lifetime’

Once I did that, I got a new error on the admin screen, a “Fatal error: Exception thrown without a stack frame in Unknown on line 0” .  To fix that I had to increase my client’s diskspace on the server. 

So now I’m in!

 
Magento Community Magento Community
Magento Community
Magento Community
 
rxaviers
Jr. Member
 
Total Posts:  1
Joined:  2010-03-31
 

Hi all,

I had the same issue with magento 1.4.0.1. It has been solved without commenting any code out. I just changed my php.ini file and increased the amount of memory a script may consume from 16M to 32M.

/etc/php5/apache2/php.ini:
memory_limit = 32M

Hope that helps.

Att,
Rafael Xavier

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

Changing the Cookie Lifetime also fixed my issue. I had been able to login and add products using firefox and upgraded to 1.4 a month ago. Conversion rate dropped but orders were still coming so I was unsure what the problem was. Customers would contact saying they could not add to cart. Finally realized with IE and Chrome I could not add items to cart or login on backend. I knew this problem existed many many versions ago but I assumed Varien had figured out the solution and this was fixed a long time ago. Guess not!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
g0nzo
Jr. Member
 
Total Posts:  9
Joined:  2009-08-28
 

Most of the time this is due to a cookie problem and the time settings as previously mentioned.  You need to verify that both the SERVER time and your PC time is correct.  I had this issue and when I adjusted by PC time (it was set 1 day ahead of correct date) I could login to the admin using Internet Explorer without issue.

For those of you expecting priority support on an open source / community product you are dreaming.  The reason why we have such a great product here is because there is a paid version.  Read the forums and do more research if you are unwilling to pay for support.  Many of you already know this but I am responding the comments I saw where users were appalled that Magento reps weren’t responding to their post.

Hope this helps some peeps out there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
balifive0
Jr. Member
 
Total Posts:  6
Joined:  2010-02-18
 

I experienced this issue after moving hosting and using a temporary domain while my DNS was propagating.  I had to change three settings in the core_config_data table through PHPMyAdmin.

1. Change base URLs to new domain
2. Change cookie length as described earlier
3. Remove cookie domain setting (most probably the culprit as it was set the original domain)

I don’t know if anyone will come across this scenario, but I thought I’d share.  It is pretty frustrating when you can’t find an answer for something on this forum.

Good luck all

 
Magento Community Magento Community
Magento Community
Magento Community
 
Template fans
Guru
 
Total Posts:  446
Joined:  2009-11-02
 

I suggest to backup the SQL data and re-install the magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ashley01
Jr. Member
 
Total Posts:  15
Joined:  2010-05-06
 

i have given up on this issue. its been several weeks and magento has yet to solve this issue for me and obviously everyone else.

___________________
“Want to get-on Google’s first page in 48 hours and flood your site with traffic?
Try Traffic Geyser, the internet’s #1 video marketing software at Traffic Geyser

 
Magento Community Magento Community
Magento Community
Magento Community
 
moomoo
Sr. Member
 
Avatar
Total Posts:  192
Joined:  2009-07-10
 
laurabinos - 24 March 2010 10:53 AM

This solution is for magento-1.4.0.1:

- Go to magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php

- and comment just line 100 like this

// call_user_func_array(’session_set_cookie_params’, $cookieParams);

Trust me, It will work after that!

Worked great, on a live (non-localhost) upgrade from 1.3.2.4 to 1.4.0.1

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
g0nzo
Jr. Member
 
Total Posts:  9
Joined:  2009-08-28
 

I wouldn’t recommend this as a permanent fix.  You are disabling important security protection relating to cookies.

 
Magento Community Magento Community
Magento Community
Magento Community
 
moomoo
Sr. Member
 
Avatar
Total Posts:  192
Joined:  2009-07-10
 
g0nzo - 02 June 2010 09:57 AM

I wouldn’t recommend this as a permanent fix.  You are disabling important security protection relating to cookies.

Thanks for the incentive to stop being lazy! I went and uncommented the line I had commented out before and had a look in the table. Sure enough there was a hangover domain from testing. (I guess the installer didn’t change the cookie domain)

Anyone else with this issue I reckon you’ll fix it by running this code in your phpMyAdmin, replace [www.domain.com] with your domain…

UPDATE  `core_config_dataSET  `value` =  'http://[www.domain.com]/' WHERE  `core_config_data`.`config_id` =800 LIMIT 1 ;
UPDATE  `core_config_dataSET  `value` =  'http://[www.domain.com]/' WHERE  `core_config_data`.`config_id` =801 LIMIT 1 ;
UPDATE  `core_config_dataSET  `value` =  '[www.domain.com]' WHERE  `core_config_data`.`config_id` =191 LIMIT 1 ;
UPDATE  `core_config_dataSET  `value` =  '86400' WHERE  `core_config_data`.`config_id` =193 LIMIT 1 ;
 
Magento Community Magento Community
Magento Community
Magento Community
 
Jaso
Jr. Member
 
Total Posts:  6
Joined:  2010-05-27
 

Hi there,

I am using this simple procedure under Windows7:
1. install XAMPP and enable “iconv”

2. edit the file “hosts” to this: 127.0.0.1 localhost.com

3. copy the magento files to the directory: C:\xampp\htdcs\magento\

4. start the Apache and MySQL

5. Go to the address: http://localhost.com/magento

6. Follow the installation wizard.

7. Now You will be able login to the administration.

ENJOY!

=D

 
Magento Community Magento Community
Magento Community
Magento Community
 
Louis.Kattenpoel
Jr. Member
 
Total Posts:  1
Joined:  2010-08-11
 

I agree with some of the fixes u are disabling some cookie related security features. But u need them to get in the admin area while u are there u need to check the cookies section in: System --> Configuration --> Web --> Session Cookie Management.

In my case I changed the field to:

Cookie Lifetime:  86400
Cookie Path:  /
Cookie Domain:  .legoonline.nl
Use HTTP Only:  Yes

This wiki page might help: http://www.magentocommerce.com/wiki/modules_reference/english/mage_adminhtml/system_config/edit/web#session_cookie_management_field_descriptions

After I changed these settings I reverted the varien.php to normal and everything worked again.

TIP: clear cache and session folders.. and clear the browser cookies

 
Magento Community Magento Community
Magento Community
Magento Community
 
mike.angstadt@atomni.net
Jr. Member
 
Total Posts:  8
Joined:  2010-10-01
 

There are several things that aren’t included in the native GoDaddy php.ini, actually there are several steps to modifying a native goDaddy hosting account to be able to use magento out of the box.  There is no mod_bandwidth to remove, and using the IP doesn’t work if you want to use GoDaddy’s previewdns functionality.

I\’ve seen some posts that recommend taking a machete to Magento source, which isn’t the answer…

To Fix This
1. rename the php.ini file GoDaddy creates in the root to php5.ini
2. add

cgi.fix_pathinfo 1
to the end of the php5.ini file
3. take all of the specifications in magento\’s php.ini.sample file located at magento/app/code/core/Mage/php.ini.sample and tack them onto the end of the php5.ini file, the entirety of it is
This file is for CGI/FastCGI installations.
; Try 
copying it to php5.ini, if it doesn\'t work

; adjust memory limit

memory_limit = 64M

max_execution_time = 18000

; disable magic quotes for php request vars

magic_quotes_gpc = off

; disable automatic session start
; before autoload was initialized

flag session.auto_start = off

; enable resulting html compression

zlib.output_compression = on

; disable user agent verification to not break multiple image upload

suhosin.session.cryptua = off

; turn off compatibility with PHP4 when dealing with objects
    
zend.ze1_compatibility_mode = off

; PHP for some reason ignores this setting in system php.ini 
; and disables mcrypt if this line is missing in local php.ini

extension=mcrypt.so

This will also allow you to use GoDaddy’s previewdns functionality to test your site before it goes live.

Check out more great tips and tricks for Magento, Code Igniter, and PHP at atomni !

 
Magento Community Magento Community
Magento Community
Magento Community
 
crazyjava
Jr. Member
 
Total Posts:  3
Joined:  2010-05-24
 
chrischip - 06 November 2008 09:49 PM

I find out what happened. My server time is incorrect and actually behind the time of my client. The invalidates session cookie in IE and Chrome. For some reason Firefox allows this. As soon as I corrected the system time on my Apache server time it works.

This works for me. After install Magento on different CentOS servers, some work and some don’t (IE/Chrome cannot do user login or admin login). Today I read your post and checked server date and timezone. Just like what your said. I’ve fixed date and timezone and everything works. Thanks a lot.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top