Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Sorry…this goes with previous post of One Page Checkout Problem. 
 
bee1
Jr. Member
 
Total Posts:  20
Joined:  2008-06-13
 

This was after upgrading to 1.1.6 (from 1.0.19870.4). Any help would be appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

quite a bit of changes had made since v1.1.0.

Have you checked this yet?
http://www.magentocommerce.com/wiki/upgrading_magento_themes_for_the_latest_releases

Though the above page didn’t mention it, customer widget is introduced in v1.1.0. All forms that need to fill up name and date of birth (and taxes too, but I think this is for EU countries) are pulled from widget.  A visit to your site and see how the checkout page works right after I proceed to step 2, I am pretty certain it’s caused by the missing names.  if your upgrade replaced the new shipping, billing and other files that have the form fields for names, date of birth, I suggest you restore back the newest version for those files. This is not only concerning the One page checkout, but multi-address as well as the customer login/ logged in area.

Hope this helps!

 
Magento Community Magento Community
Magento Community
Magento Community
 
bee1
Jr. Member
 
Total Posts:  20
Joined:  2008-06-13
 

Thanks for the reply but I’m not sure exactly what you mean? Where/how would I make the changes that I need to make to get it to work?

Thanks again!

 
Magento Community Magento Community
Magento Community
Magento Community
 
bee1
Jr. Member
 
Total Posts:  20
Joined:  2008-06-13
 

I checked some of the files listed on the link you gave me and my files match so I’m not really sure where to look next. I have noticed that I can not register nor checkout as a guest. It’s almost like it isn’t moving to the next section of the form for some reason. I can create a new account (using the My Account link) and complete the billing information in the order form after that but when I hit continue I get the same 404 Page Not Found error and the same “undefined.” So, where/how to I change it to be “defined?”

Also, wouldn’t all these changes be in the newest version without requiring me to make these changes? In looking at a few of the files listed as offenders I seem to have the same data as they ask that I change it to. I beleive that I have the newest version and I have attempted reuploading all corresponding files (just in case it was an issue during the ftp processes) but that has not resolved the problem.

I would appreciate any further assistance you could provide.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

sorry, I think I am wrong in my ‘diagnostic’. red face

I experienced something with ‘undefined’ in opc page too when ungraded from v1.0987 to v1.1 and I thought it was caused by name widget. However, after browsing your site more thoroughly, it appears that you didn’t modify any of the phtml files correct? Mine was heavily edited. I actually dumped my custom billing and shipping files and replace with the updated version, then re-edit, thus was able to solve the problem.

How did you do the update? Was there folders/files from v1.0987 that you simply move back to their locations?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 
chinesedream - 05 October 2008 03:39 PM

sorry, I think I am wrong in my ‘diagnostic’. red face

I experienced something with ‘undefined’ in opc page too when ungraded from v1.0987 to v1.1 and I thought it was caused by name widget. However, after browsing your site more thoroughly, it appears that you didn’t modify any of the phtml files correct? Mine was heavily edited. I actually dumped my custom billing and shipping files and replaced with the updated version, then re-edit, thus was able to solve the problem.

How did you do the update? Was there folders/files from v1.0987 that you simply move back to their locations?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bee1
Jr. Member
 
Total Posts:  20
Joined:  2008-06-13
 

I upgraded to 1.1.6 from 1.0.19870.4 - all I did was write over the top of the 1.0.19870.4 files with the new files from 1.1.6. I have not nor did I in the past modify the phtml files (other than to change the demo store text and such where needed). Upgrade went okay but I had a couple of bugs to work out with the images and the grid view. Everything else seems to be working fine...just not the onepage checkout. I have not reverted back to the old files from version 1.0.19870.4 - do you think I should do that?

thanks again!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top