Magento Forum

Problems with indexes of table `eav_attribute
 
jackstraw
Member
 
Total Posts:  62
Joined:  2008-06-02
Carbondale,Colorado
 

Hi, I have been in the process of speeding things up and trying to make the coupon codes work.  >:(

At any rate, I was futzing with the db and came across this......  when checking tables.

Problems with indexes of table `eav_attribute`
The indexes IDX_USED_FOR_SORT_BY and IDX_USED_IN_PRODUCT_LISTING seem to be equal and one of them could possibly be removed.

Anyone encounter this?  Not sure what the implications are.  Everything but coupon codes is working as it should finally.

thanks,
Nigel

 
Magento Community Magento Community
Magento Community
Magento Community
 
webcitz
Sr. Member
 
Avatar
Total Posts:  128
Joined:  2008-11-10
Appleton, WI
 

I found this while doing a database check as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jeyhun
Member
 
Total Posts:  38
Joined:  2010-02-20
 

I got the same error in v.1.5.0.1 as follow:

The following indexes appear to be equal and one of them should be removed: IDX_USED_FOR_SORT_BY, IDX_USED_IN_PRODUCT_LISTING

The problem is similar to the issue #14271
I reported this as new issue #26383

 
Magento Community Magento Community
Magento Community
Magento Community
 
vdheuvel
Jr. Member
 
Total Posts:  5
Joined:  2013-01-26
 

So how did this get solved because it is bugging me too.

I’m doing a DB export / import going from a 1.4.0.1 to a 1.7.0.2 and this is stopping the show.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top