Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Unable to Send Emails - tried hideit fix already
 
mistrzu20
Jr. Member
 
Total Posts:  13
Joined:  2009-05-24
 

Hey,
After upgrading to 1.4.0.1 from 1.3.4.0, I noticed that all services that send emails are no longer doing their job.
Newsletters (also newsletter signup confirmation), contact form, product notifications, etc.

I looked at a couple of fixes, but they all seem to tackle each module individually, when it appears to me the problem is in the core since it affects multiple modules.

Nevertheless, I tried the “hide” fix in the contact us form, but didn’t help. I tried changing setting in the configuration, tried uncommenting IndexController.php also no help.

Any help would be appreciated. Oh and remind me never to upgrade/update again! smile

Thanks,
Adrian

 
Magento Community Magento Community
Magento Community
Magento Community
 
mistrzu20
Jr. Member
 
Total Posts:  13
Joined:  2009-05-24
 

guys, please help.

Here are some updates since I initially posted…

Magento sends emails to friends and order confirmations.

Magento does not send contact us and newsletters (neither blasts nor signup confirmations which I had set up)

I am using Modern theme, but tried cycling to default and base themes with same unsuccessful results.

I tried the “hideit” fix as posted by others, but it didn’t help.

Any workarounds for this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jackstraw
Member
 
Total Posts:  62
Joined:  2008-06-02
Carbondale,Colorado
 

It’s called a “bait and switch”

:( This is what happens when a company [Varien] does not give a shit about its user base.  Oh wait, I am not the user base.  I didn’t pay them for the community edition.

It does not matter if the issue is crippling or not, you have programmers on board, etc.  This shit does not work as advertised, period, nor has it ever.  They have still have not fixed the connect issues FFS.

All of us open source fellows have been taken for a ride with this stuff.

We have all been duped by their marketing.  “The community is our biggest asset” my ass.  The lowest rate for magento to actually work is 3,000 a year.  In fact, I can’t tell you when the last time I actually saw a staff member floating around.

There are a wide range of commercial carts that are cheaper(one off payments as well), do the same, things, are not slow as feck and have proper community level support. But, more noteworthy, they work and are faster by a factor of about 100.

http://www.commercestyle.com/e-commerce/magneto-sucks

I should bother to Google things more often.

You are not going to “bait and switch” me. 

A poofy looking admin panel does not make an operable shopping cart.

Nigel

 
Magento Community Magento Community
Magento Community
Magento Community
 
jackstraw
Member
 
Total Posts:  62
Joined:  2008-06-02
Carbondale,Colorado
 

It’s called a “bait and switch”

:( This is what happens when a company[Vairen] does not give a shit about its user base.  Oh wait, I am not the user base.  I didn’t pay them for the community edition.

It does not matter if the issue is crippling or not, you have programmers on board, etc.  This shit does not work as advertised, period, nor has it ever.  They have still not fixed connect issues FFS.

All of us open source fellows have been taken for a ride with this stuff.

We have all been duped by their marketing.  “The community is our biggest asset” my ass.  The lowest rate for magento to actually work is 3,000 a year.

http://www.commercestyle.com/e-commerce/magneto-sucks

I should bother to Google things more often.

If Varien wants to test the theory that there is no such thing as bad advertising, fine.  I will oblige in detail.  You are not going to “bait and switch” me.

Nigel

EDIT:  Sorry, did not mean to double post but the forum does not work either.  Aside from taking 3.5 minutes to actually post my thread it posted my thread even though the captcha was wrong.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mistrzu20
Jr. Member
 
Total Posts:  13
Joined:  2009-05-24
 

I hear you and share your frustration.
They have developed some nice solutions and I would really like this project to succeed.  The success lies not only with active members, but also with the development team.  I have invested hundreds of hours developing before making a decision to upgrade, so for me to look into another cart at this point is not an option.

Since nobody has any ideas on how to resolve my issue, I decided to reinstall and hopefully reconfigure everything successfully.

I understand your venting, trust me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
marc-andre
Jr. Member
 
Total Posts:  21
Joined:  2010-02-08
Perpignan
 
mistrzu20 - 01 June 2010 11:46 AM

I have invested hundreds of hours developing before making a decision to upgrade, so for me to look into another cart at this point is not an option.

So did we, we tried many solutions and Magento is the best looking solution.

Since nobody has any ideas on how to resolve my issue, I decided to reinstall and hopefully reconfigure everything successfully.

Please let us know if it solved the problem for you !

Marc-André

 
Magento Community Magento Community
Magento Community
Magento Community
 
daniel6683
Jr. Member
 
Total Posts:  1
Joined:  2008-09-16
 

Hi, the problem is not in the core, but in templates.
I discover it by myself, and I still investigate other ocurrences.

New security rules are implemented in version 1.4.0.1, (for send e-mail) and the oldest template show problems in some pages.

1. Solve problem in contact form
----------------------------------------

For solve the problem in contact form, add the line before the input buttom
<input type="text" name="hideit" id="hideit" value="” style="display:none !important;” />

The file is in the:

app/design/frontend/blank/yourtheme/template/contacts/form.phtml

Please, look in your correct theme for this folder.

2. Solve problem in send to a friend
------------------------------------------------

For solve the problem in this file, add the line in the form:

<?php echo $this->getBlockHtml('formkey')?>

The file is in the:

app/design/frontend/blank/yourtheme/template/sendfriend/send.phtml

-------------------------------------------------

I hope had helped with this one!!

Obs. For comparasion, see the oroginal file in the new template from 1.4.0.1 version, locate in app/base/default/defalt/template, and look for differences.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top