Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Installation Problem - Fatal error: Call to undefined method Zend_Locale_Data
 
RichardS
Jr. Member
 
Total Posts:  2
Joined:  2007-12-06
 

Hi there

I am getting this error:

Fatal error: Call to undefined method Zend_Locale_Data::setcache() in /home/courseme/public_html/app/code/core/Mage/Core/Model/Locale.php on line 70

I have uploaded Magento to the root of my shared hosting account.

It’s running MySQL 5.0.27 and PHP 5.2.4 on Linux with Apache.

I have looked at the requirements page and can find all of these listed in my phpinfo.php file:

PDO/MySQL
MySQLi
mcrypt
mhash
simplexml
DOM

When I attempt to access the server, it’s obviously redirecting to the install location - so I guess mod-rewrite isn’t causing a problem (it’s also ‘on’ in my .htaccess file).

Can anyone help?

Many thanks

Richard

 
Magento Community Magento Community
Magento Community
Magento Community
 
RichardS
Jr. Member
 
Total Posts:  2
Joined:  2007-12-06
 

Hi All

My Magento install now works.  I uploaded the php5 file to the cgi-bin and am using that.  Strange - as my host provides php5.

But - working - and first impressions are good.

Richard

 
Magento Community Magento Community
Magento Community
Magento Community
 
ralphie
Member
 
Total Posts:  59
Joined:  2007-12-20
London
 

hi

i get the same error.. working on a mac with mamp (some 5er mysql and php 5.2.3). i have all modules required except the mhash, however i do not expect that this would be the reason for this error. unfortunately the pre compiled binary (the via cgi way) does not work for me either, dunno if it is because of the platform? it results in the following error:

Premature end of script headers: php5-cgi

which is reported in the installation problem tread.

has anybody a hint how i can get magento running easiest under the circumstances given?

thanks,

ralph

 
Magento Community Magento Community
Magento Community
Magento Community
 
lkbryant
Member
 
Avatar
Total Posts:  60
Joined:  2007-09-03
 

just to let you know, ralphie problem was fixed.

the problem was that, all the files didn’t get properly uploaded or extracted.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top