Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Issues with local installation on OSX with MAMP
 
Travis
Sr. Member
 
Avatar
Total Posts:  125
Joined:  2007-08-31
 

Was having issues with installing the past two releases on my (mt) Media Temple (dv) server, so I decided to work on a local server until Magento 1.0 is released.

Downloaded and installed MAMP for OSX.  Created a database named “magento” and a user that has access to everything.  Moved the magento folder into the appropriate directory and proceeded with the installation.

All seems to go well, but I’m left with an admin that only shows the header background and Logged in as Travis.

For the storefront, none of the product pages are accessible.  Receive a “Whoops, our bad” 404 for those pages, and a blank white for the Cart, Account, etc… pages.

The information I’m entering in the Magento setup screen is:

Database Connection

Host:  localhost
Database Name:  magento
User Name:  My user name
User Password:  My password

Default store

Host: localhost
Base Path:  /magento/
Protocol:  http
Port:  8888

Secure Connection

Secure Host:  localhost
Secure Base Path:  /magento/
Secure Protocol:  http
Secure Port:  8888

I’m then taken to the Create Admin Account page, fill that info out, and everything seems to be fine until I go into the admin or storefront.

Have tried making the Database Connection host localhost:8888, which didn’t seem to make a difference.

Has anyone experience the same issues and found a solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
rodrigo81
Jr. Member
 
Total Posts:  4
Joined:  2007-09-04
 

Did you try setting up on a different port other than 8888?
I’ve it running on the deafult ports with MAMP and havent had any problems.. OSX 10.4.11.

Rodrigo

 
Magento Community Magento Community
Magento Community
Magento Community
 
Travis
Sr. Member
 
Avatar
Total Posts:  125
Joined:  2007-08-31
 

Changed the port to 80 in MAMP, same result.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rodrigo81
Jr. Member
 
Total Posts:  4
Joined:  2007-09-04
 

Weird. Are you getting this from a brand new installation?  I tried changing mine to 8888, and got errors too, probably changing the ports in MAMP it’s not the way to go.
Maybe you could try re-installing to see what how it goes with the default port..

Rodrigo

 
Magento Community Magento Community
Magento Community
Magento Community
 
Travis
Sr. Member
 
Avatar
Total Posts:  125
Joined:  2007-08-31
 

The first several installations I tried using MAMP all detected 8888 as the default port in Magento.  No matter what I change it to still results in what seems to be an okay installation, followed by a naked admin and useless storefront.  Dying to give the new order tool a try.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sticky
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-09-05
UK
 

I have to say, I’m getting the same thing after trying to install the new version locally this morning. (magento-0.6.14100.zip)

Homepage looks fine but:-

- If I click on a product hyperlink (eg. Sony Viao...) I get a whoops missing page.
- If I use any link in the dropdown nav I get a blank white page.
- Admin loads and stops after the “Logged in as xxxxx |” span tag, just before the date display as below…

...</head>
<
body id="html-body">
<!
[if !IE]><table cellspacing="0" width="100%"><tr><td><![endif]>
<
div class="wrapper">
        <
div class="header">

        <
div class="header-top">
    <
a href="http://localhost:8888/magento/admin/"><img src="http://localhost:8888/magento/skin/adminhtml/default/default/images/logo.gif" alt="Magento Logo" class="logo"/></a>
    <
div class="header-right">
        <
class="super">
            
Logged in as sticky<span class="separator">|</span>

I’m going to keep playing with the .htaccess file I think…

Image Attachments
magscreen.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
sticky
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-09-05
UK
 

OK, making some headway.

Travis, add this to the top of your .htaccess file. By default php was installed with an 8MB memory limit, increasing this value fixed the backend. Magento Admin seems to be working fine now.

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
    php_flag display_errors on
    php_value memory_limit 24M
</IfModule>

Also by switching on the errors, I’ve uncovered some in the Magento frontend, I’ll post an update if i get it fixed… smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
sticky
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-09-05
UK
 

All sorted.

The error in the frontend I was seeing was:

exception 'Exception' with message 'Undefined rate from "GBP-USD"' in /Applications/MAMP/htdocs/magento/app/code/core/Mage/Directory/Model/Currency.php:92

Went into Magento Admin -> System -> Manage Currency

EUR and USD fields were empty!!

Added dummy values, clicked ‘Save Currency Rates’ and it’s all working…

Hope this helps out anyone on a Mac with the same trouble! smile

Image Attachments
magscreen2.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
sticky
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-09-05
UK
 

Dang it, all the links on the homepage are getting a 404 Whoops! but the rest of the links throughout are working fine…

EDIT:
As noted here by Moshe - http://www.magentocommerce.com/boards/viewthread/1818/

“Right after the installation or upgrade go to the Admin -> System -> Cache Management, check the ‘Refresh Catalog Rewrites’ checkbox and click on ‘Save cache settings’ button in order to get new URL rewrites updated”

Homepage links all fixed, doh! smile

PS. I had to up the memory limit for php to do this, eg:

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
    php_flag display_errors on
    php_value memory_limit 32M
</IfModule>
 
Magento Community Magento Community
Magento Community
Magento Community
 
Travis
Sr. Member
 
Avatar
Total Posts:  125
Joined:  2007-08-31
 

Thanks for the detailed run-down Sticky.  Going to give this a try right now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Travis
Sr. Member
 
Avatar
Total Posts:  125
Joined:  2007-08-31
 

Hmmmm, can’t seem to get it to work.

Here’s how the modified .htaccess looks:

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
    php_flag display_errors on
    php_value memory_limit 32M
</IfModule

DirectoryIndex index.php

RewriteEngine on

#RewriteBase /dev/magento/

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php

That results in a:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Are there any other steps you made to get this to work sticky?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sticky
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-09-05
UK
 

The only way I came across an internal server error was when I left off the forward slash in the RewriteBase, eg:

RewriteBase magento/

It should be:

RewriteBase /magento/

Try uncommenting the RewriteBase and getting it set properly…

One thing to note as I’m not sure how you’ve setup MAMP, my magento folder is in here:

Applications/MAMP/htdocs/magento/

My full .htaccess is:

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
    php_flag display_errors on
    php_value memory_limit 32M
</IfModule>

DirectoryIndex index.php

RewriteEngine on

RewriteBase 
/magento/

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php

Also, I’m runnning 10.4.11 incase it matters…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Travis
Sr. Member
 
Avatar
Total Posts:  125
Joined:  2007-08-31
 

Still won’t work.  I’m giving up for now.  Don’t have the time to work on this or worry about it any more until next month.  I’ll give it another try on my (mt) server with the next release.

Thanks for your help sticky.

 
Magento Community Magento Community
Magento Community
Magento Community
 
itboffin
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2007-10-10
Sydney Australia
 

Hi Travis

I have deployed magento on MAMP on OSX Tiger.  It’s been working just fine.  I see two potential problems with your configuration
database connection for mysql in MAMP is on port 8889 not 8888 or if you choose default 3306

localhost8889

You may also need to up the php memory limit to 32M as suggested by Stiky. 

php_value memory_limit 32M
I hope it works.  excaim  Try and let me know.

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
sticky
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-09-05
UK
 
itboffin - 10 December 2007 03:04 AM

I see two potential problems with your configuration
database connection for mysql in MAMP is on port 8889 not 8888 or if you choose default 3306

Strange, I installed MAMP literally on Friday morning and 8888 was the default, and it’s running fine for me.

Maybe it depends on how each Mac is setup and auto-detects it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
brandondrew
Member
 
Avatar
Total Posts:  64
Joined:  2007-09-12
 
sticky - 10 December 2007 03:10 AM

itboffin - 10 December 2007 03:04 AM
I see two potential problems with your configuration
database connection for mysql in MAMP is on port 8889 not 8888 or if you choose default 3306
Strange, I installed MAMP literally on Friday morning and 8888 was the default, and it’s running fine for me.

Maybe it depends on how each Mac is setup and auto-detects it?

It sounds like you’re confusing the Apache port with the MySQL port.  8888 is for Apache, and 8889 is for MySQL.  (Sorry if I misunderstood you.)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2