Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How do I remove index.php/ on godaddy shared hosting? 
 
dunce
Member
 
Total Posts:  33
Joined:  2009-09-12
 

the domain im working on is here: http://fwd4.me/Nrm

took awhile to setup on godaddy hosting but cant figure out the this 1 issue.. can anyone help?

here is my .htaccess

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    
DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    
php_value memory_limit 128M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    
php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

    
php_flag zend.ze1_compatibility_mode Off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    
RewriteBase /home/content/04/6136804/html/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

really appreciate any help!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

It has nothing to do with .htaccess file.
Go in the back-end: System->Configuration->Web.
Under the tab ‘Search Engines Optimization’ set ‘Use Web Server Rewrites’ to yes.
under ‘Unsecure’ set the base url and ‘Base Link URL’ to ‘http://ladjparts.com’.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dunce
Member
 
Total Posts:  33
Joined:  2009-09-12
 

that did it! thanks a ton!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
gaby rusu
Jr. Member
 
Total Posts:  7
Joined:  2010-05-18
 

hi, i did all that and i’m redirected to 404 error page. the server has mod_rewrite enabled

the host is http://magento.mysite.com does it metter? do in need to set another unsecure base url? or in another way?

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

Salut Gaby, smile

make sure you have an htaccess file on the same level as index.php (and you should have - standard behavior) and also make sure that on you httpd.conf file on your server you have this

<Directory />
    
Options Indexes FollowSymLinks
    AllowOverride All
    Order allow
,deny
    Allow from all
</Directory>
 
Magento Community Magento Community
Magento Community
Magento Community
 
gaby rusu
Jr. Member
 
Total Posts:  7
Joined:  2010-05-18
 

Salut Marius, smile

that worked. my httpd.conf was empty

 
Magento Community Magento Community
Magento Community
Magento Community
 
pw2005
Jr. Member
 
Total Posts:  1
Joined:  2010-07-08
 

Hi tzyganu,
I am also using godaddy and having the same problem but I cannot find the settings from godaddy dashboard. Can you tell me how to go to back end: System->Configuration->Web.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Artega Imports
Sr. Member
 
Avatar
Total Posts:  78
Joined:  2010-02-03
Liverpool, England, UK
 
pw2005 - 08 July 2010 05:25 AM

Hi tzyganu,
I am also using godaddy and having the same problem but I cannot find the settings from godaddy dashboard. Can you tell me how to go to back end: System->Configuration->Web.

Thanks

Its inside your Magento admin area.

Navigate to admin, then go to system>configuration>web>search engines optimisation>Use Web Server Rewrites (YES) then save config

Hope this helps, Mark Birchall

 
Magento Community Magento Community
Magento Community
Magento Community
 
vsnetfreak
Member
 
Avatar
Total Posts:  32
Joined:  2009-12-17
Bhilai, Chhattisgarh
 

I am getting 404 on my localhost.

APACHE on WINDOWS XP SP2.

Please help.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top