Magento Forum

   
Google checkout api link gives 404 error
 
robriggen
Jr. Member
 
Total Posts:  2
Joined:  2008-03-10
 

I am running Magento 1.1.6 and trying to use Google Checkout.  The URL for the API callback in Magento gives a 404 error:

http://storedomain.com/index.php/googlecheckout/api

or

http://storedomain.com/googlecheckout/api

Am I using the wrong url?  I can’t seem to find any information on this.

Thanks in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
mrtech
Sr. Member
 
Total Posts:  87
Joined:  2008-06-30
 

i have the same problem did you found anything?

 
Magento Community Magento Community
Magento Community
Magento Community
 
paddle74
Jr. Member
 
Total Posts:  28
Joined:  2008-02-28
 

me too.  Is this correct?

 
Magento Community Magento Community
Magento Community
Magento Community
 
purplemine
Sr. Member
 
Total Posts:  143
Joined:  2008-05-20
London
 

This is definitely not expected behaviour.  I had this working until upgrade to 1.2.1 and now the 404 error is preventing Google Checkout from working.

I guess this must be something to do with the routing??

Any help would be appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PleasureWithClass.com
Jr. Member
 
Total Posts:  2
Joined:  2009-02-11
 

I am also experiencing this issue however, not from an update but a fresh install.  I really would like to see someone from the Magento team give is a light in this topic! Seems like there are quite a few people experiencing this same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fzolee11
Jr. Member
 
Total Posts:  12
Joined:  2008-03-01
Massachusetts
 

According to JHubb it is normal. Read this thread: http://www.magentocommerce.com/boards/viewthread/25527/P15/
“...[If] you access the page directly then you will get a 404 error, but this doesn’t seem to have an effect on the api as it is using authentication. “

We still have issues fully implementing Google Checkout, so not sure if this is really true. It would be great to hear a feedback from someone who already has Google Checkout working and gets the same 404 page accessing this URL directly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Keep It Lucid
Jr. Member
 
Total Posts:  8
Joined:  2009-01-28
Ogden, UT
 

The Google Checkout API link gives me the 404 Not Found page as well.

The Google Checkout Integration Console also gives me this Error:

Send failed with code:  404.

Using this API Callback URL:  https://mydomain.com/googlecheckout/api

 
Magento Community Magento Community
Magento Community
Magento Community
 
fzolee11
Jr. Member
 
Total Posts:  12
Joined:  2008-03-01
Massachusetts
 

Finally we had Google Checkout installed and it works. So, it is normal, if Google Checkout API link gives the 404 Not Found page.

We had a problem thought with our SSL certificate. We purchased one from GoDaddy, the standard (turbo) SSL certificate.
Here is a recap of what was going on:

# Incorrectly installed SSL certificate

1. Problem: Google API callback didn’t work on SSL. The following message was shown in Goggle Checkout > Tools > Integration console: “We encountered an error trying to access your server at https://www.plastronproducts.com/googlecheckout/api/—the error we got is sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target”.
2. Cause: SSL certificate is installed incorrectly.
3. Solution: View your server’s SSL certificate in Linux type in the following command:

openssl s_client -connect yourdomain.com:443 -showcerts < /dev/null
It will display the certificate information and if there are any problems with it. Yes, I used to think that you can see this information from FireFox for example, but it turns out that it is not always the case. If the browser fills in missing information. In other words, it can’t be trusted for this installation. Use the Linux command to be sure.

Longer Story:
When we had this problem we were not sure if we had the correct SSL certification which is the cheapest from GoDaddy. According to Google Checkout’s API authentication and security: Accepted SSL certificates they accept “Go Daddy Class 2 CA” SSL certification, but nowhere on the GoDaddy site can you find which SSL option is “Go Daddy Class 2 CA”. I called GoDaddy and the support lady told me that the standard is not “Go Daddy Class 2 CA” and I would have to purchase at least the Deluxe SSL. I didn’t belie her for some reason, so I kept digging. After a few hours a found a post on one of the google checkout forums saying that the cheapest works and I would a site with Google Checkout installed so I compared the SSL certificates using openssl and I saw that mine had some problems. We are on KnownHost’s VPS so I sent them a note and asked them to reinstall the SSL, and voila everything worked.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Keep It Lucid
Jr. Member
 
Total Posts:  8
Joined:  2009-01-28
Ogden, UT
 

UPDATE

After scouring the forum I’ve finally got the Google Checkout Callback API to communicate properly with Magento!

The upside is that I got it to work.  The downside is that I made several changes at once before placing a test purchase, so I’m not sure which change (if not all of them) made it work.  My brain is fried right now, so I’ll log back on tomorrow and list all the changes that I made.

One quick note:  The callback API is working but I still get the 404 Not Found when I access the Callback URL in my browser.  So, to answer a previous post, yes you can get the 404 Not Found in your browser and still have the Callback API work with Google Checkout.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wmkeller
Jr. Member
 
Total Posts:  7
Joined:  2009-02-24
 

I’m getting the 401 error in my google tools logs. My hosting provider says everything is ok, what else could cause this ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
Keep It Lucid
Jr. Member
 
Total Posts:  8
Joined:  2009-01-28
Ogden, UT
 

It turns out that I had a typo in my URL.

1.) The correct URL is:  https://yourdomain.com/googlecheckout/api

2.) Go to: System Configuration => General => Web => Secure

Change the Base URL to:  https://yourdomain.com
Change the Base Link URL to:  https://yourdomain.com (Instead of {{secure_base_url}}.)

3.) Change your .php file to include:

magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so
always_populate_raw_post_data = On
mod_rewrite = On

4.) Change your .htaccess file to include:

RewriteCond %{SERVER_PORT} 80
RewriteCond %{REQUEST_URI} googlecheckout/api
RewriteRule ^(.*)$ https://yourdomain.com/googlecheckout/api/$1 [R,L]

These steps assume you have already installed a valid SSL key.

I may have forgotten something, but this is all I can remember.  I know, I’m a horrible person. wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
mul015
Jr. Member
 
Total Posts:  10
Joined:  2009-02-25
 

Where can i find this file??

Keep It Lucid - 30 March 2009 03:51 PM

3.) Change your .php file to include:

magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so
always_populate_raw_post_data = On
mod_rewrite = On

Thanks already

erik

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top