Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

What’s the dependency between LOCALE, ATTRIBUTES and USPS shipping quotes? 
 
Silenser
Jr. Member
 
Total Posts:  5
Joined:  2008-05-24
 

Hello everybody!

I had Magento 1.0.19870.4 installed and configured before. Now I have installed newest version (1.1.6) to give it a try.
First of all SEO is now much better. Thank you.

But I don’t get what is the dependency between locale, attributes and USPS shipping quotes in new version?
Please take a look at attribute.gif file attached. It is how I set up attribute values.
1. If I use ENGLISH (US) locale. USPS shipping quotes works beautifully but attribute’s titles in frontend show backend (in english) values instead of default store view values (in russian)! See frontend.gif file attached.
2. If I use RUSSIAN locale. Attribute’s titles in frontend show default store view values (in russian not english, correct!) (see frontend_correct.gif file attached) but USPS shipping quotes are not calculated anymore (see USPS_failed.gif file attached).

In other words, if I change locale to either ENGLISH or RUSSIAN I get one of the ways described above.
In previous 1.0.19870.4 version I had ENGLISH (US) locale set up. Attribute’s titles were shown correctly (in russian) and USPS shipping quotes were calculated correctly.

If someone have any suggestions any help will be greatly appreciated…

Image Attachments
attribute.giffrontend.giffrontend_correct.gifUSPS_failed.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
Sprout Collective
Member
 
Total Posts:  64
Joined:  2007-08-31
Portland, OR / Orange County, CA
 

We’ve run into this international shipping issue with all the locales we’ve tried other than English (US).  Were you able to find a solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
StevenW721
Jr. Member
 
Total Posts:  11
Joined:  2009-03-29
 

Having this same issue using the Italian Locale, the USPS shipping method shows that it\’s unavailable. Using Magento 1.4.0.1

Has anyone else experienced this?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top