Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

module
 
janim007
Jr. Member
 
Total Posts:  29
Joined:  2008-09-09
 

hi all
i have made additional page in magento ,it uses iframe to wok out of zend,magento classes
but i used module creator to create module pointing to this page and it’s working 100% in localhost ,when i uploaded every thing into server
my page contain nothing smile
just blank 2colums-right template , empty nothing
it can’t see my page.phtml maybe ? but i introduced it in page.xml , in layout
it should work on the server as it working on localhost

any suggestion plz , where to search for the problem ,any hist something
Thanx

 
Magento Community Magento Community
Magento Community
Magento Community
 
nikefido
Guru
 
Avatar
Total Posts:  481
Joined:  2008-07-11
New Haven, CT
 

did you hardcode the iframe URL? (localhost vs server name?)

 
Magento Community Magento Community
Magento Community
Magento Community
 
janim007
Jr. Member
 
Total Posts:  29
Joined:  2008-09-09
 

yes @nikefido
i have changed everything about this ,

 
Magento Community Magento Community
Magento Community
Magento Community
 
vianetz
Guru
 
Avatar
Total Posts:  537
Joined:  2008-04-13
Munich, Germany
 

Just to be sure:
You disabled the cache management and all other magento functions are working correctly?

 
Magento Community Magento Community
Magento Community
Magento Community
 
janim007
Jr. Member
 
Total Posts:  29
Joined:  2008-09-09
 

yes everything is working 100%
just this page ,it can’t see .phtml page
it gives me blank template like i configured in name.xml => 2colums-right and it’s working , but without viewing .phtml page , in local host it do
it’s working in localhost like magic
don’t know wht’s this

 
Magento Community Magento Community
Magento Community
Magento Community
 
janim007
Jr. Member
 
Total Posts:  29
Joined:  2008-09-09
 

you know what . may i missed the xml file or the class that present the .phtml file to be shown
in zend framework ,you need to name the phtml folder and file at the same name of your action… etc
but i thinnk not in magento
so what is the way in magento modules to present the .phtml file

 
Magento Community Magento Community
Magento Community
Magento Community
 
vianetz
Guru
 
Avatar
Total Posts:  537
Joined:  2008-04-13
Munich, Germany
 

Did you create your own template for that? If yes, have you set this in the administration interface?

 
Magento Community Magento Community
Magento Community
Magento Community
 
janim007
Jr. Member
 
Total Posts:  29
Joined:  2008-09-09
 

i don’t want it to be in admin. interface
just in frontend !

 
Magento Community Magento Community
Magento Community
Magento Community
 
vianetz
Guru
 
Avatar
Total Posts:  537
Joined:  2008-04-13
Munich, Germany
 

Ok, I suggest searching the wiki will help you to understand what themes can do and how they will be configured.

 
Magento Community Magento Community
Magento Community
Magento Community
 
janim007
Jr. Member
 
Total Posts:  29
Joined:  2008-09-09
 

i know how themes can work and how it will configured , i did this in my localhost but when i uploaded it to my server it’s not working , i think it can’t find the .phtml file
any one has any idea

 
Magento Community Magento Community
Magento Community
Magento Community
 
gabi
Jr. Member
 
Total Posts:  10
Joined:  2008-10-02
 

when I try to install module creator ago mistakes that appear

Notice: Undefined index: namespace in C:\Program Files\EasyPHP 2.0b1\www\moduleCreator\index.php on line 365

Notice: Undefined index: module in C:\Program Files\EasyPHP 2.0b1\www\moduleCreator\index.php on line 369

Notice: Undefined index: magento_root in C:\Program Files\EasyPHP 2.0b1\www\moduleCreator\index.php on line 373

Notice: Undefined index: interface in C:\Program Files\EasyPHP 2.0b1\www\moduleCreator\index.php on line 377

Notice: Undefined index: theme in C:\Program Files\EasyPHP 2.0b1\www\moduleCreator\index.php on line 381

Thank you for your help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
amine2005
Jr. Member
 
Total Posts:  23
Joined:  2008-09-11
 

me too i have this error????

 
Magento Community Magento Community
Magento Community
Magento Community
 
vianetz
Guru
 
Avatar
Total Posts:  537
Joined:  2008-04-13
Munich, Germany
 

First, please create a new thread for each problem.

@gabi: This is not an error just a notice. It appears because no values can be inserted in the input fields. That should be no problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vianetz
Guru
 
Avatar
Total Posts:  537
Joined:  2008-04-13
Munich, Germany
 
janim007 - 02 October 2008 12:17 AM

i know how themes can work and how it will configured , i did this in my localhost but when i uploaded it to my server it’s not working , i think it can’t find the .phtml file
any one has any idea

As I said my idea is that you haven’t activated your theme yet.

 
Magento Community Magento Community
Magento Community
Magento Community
 
janim007
Jr. Member
 
Total Posts:  29
Joined:  2008-09-09
 

@massi
i have made big theme and it’s RTL , it’s working , and i have created another module , payment methods
but this one it’s not working, it woking like i disabled this module from admin panel , but it’s not disabled ,
when you go to system>advanced and disable some modules there do you see how it’s gonna be
this is my problem

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top