Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Installation problems with last 3 preview versions (Zend_Db_Statement_Mysqli_Exception - Mysqli prepare error)
 
Phliplip
Member
 
Total Posts:  46
Joined:  2007-08-31
Copenhagen, Denmark
 

Hi All,

I’m having serious problems with installing the last 3 preview versions, the same problem every time - both full and light. I have attached a .txt file with the error.

I follow the WIKI page for SSH installation, then browse to my-domain.com/magento/ to begin installation, accept conditions, setting locale to Danish, Copenhagen and Danish krone (Same with default locale). Now i input my database credentials, sets HTTPS to HTTP and port 80 since i don’t have SSL on my dev-box. Continue, and then the attached error occours - every time.

In the database there’s only 2 tables created `core_layout` and `core_resource`.
DB user has all privileges except for Grant, lock table and references.

My setup is;

FreeBSD 6.1-RELEASE-p3
All following applications is installed from ports-catalog.

Apache/2.2.6 (FreeBSD) DAV/2 mod_perl/2.0.3 Perl/v5.8.8
MySQL 5.1.22-rc
PHP 5.2.5

Info about PHP
‘./configure’ ‘--with-layout=GNU’ ‘--with-config-file-scan-dir=/usr/local/etc/php’ ‘--disable-all’ ‘--enable-libxml’ ‘--with-libxml-dir=/usr/local’ ‘--enable-reflection’ ‘--program-prefix=’ ‘--disable-cgi’ ‘--with-apxs2=/usr/local/sbin/apxs’ ‘--with-regex=php’ ‘--with-zend-vm=CALL’ ‘--enable-zend-multibyte’ ‘--disable-ipv6’ ‘--prefix=/usr/local’ ‘--mandir=/usr/local/man’ ‘--infodir=/usr/local/info/’

Suhosin Patch 0.9.6.2 from Hardened-PHP Project
Zend Engine v2.2.0

mysqli
MysqlI Support enabled
Client API library version 5.1.22-rc
Client API header version 5.1.22-rc

PDO
PDO support enabled
PDO drivers mysql

pdo_mysql
PDO Driver for MySQL, client library version 5.1.22-rc

SimpleXML
Simplexml support enabled
Revision $Revision: 1.151.2.22.2.35 $
Schema support enabled

mcrypt
mcrypt support enabled
Version 2.5.8
Api No 20021217
Supported ciphers cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
Supported modes cbc cfb ctr ecb ncfb nofb ofb stream

Directive Local Value Master Value
mcrypt.algorithms_dir no value no value
mcrypt.modes_dir no value no value

mhash
MHASH support Enabled
MHASH API Version 20060101

dom
DOM/XML enabled
DOM/XML API Version 20031129
libxml Version 2.6.30
HTML Support enabled
XPath Support enabled
XPointer Support enabled
Schema Support enabled
RelaxNG Support enabled

Magento Staff can get direct acces to phpinfo(); or shell access if needed.

File Attachments
mysqli_error.txt  (File Size: 14KB - Downloads: 861)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi Philip,

Did you try to install/upgrade Magento using only pdo_mysql (no mysqli) ? Just replace your app/etc/config.xml file with the attached one. You have to install the latest Magento version (0.6.14100) in order to get it working.

Thank you.

File Attachments
config.xml  (File Size: 12KB - Downloads: 710)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Phliplip
Member
 
Total Posts:  46
Joined:  2007-08-31
Copenhagen, Denmark
 

Hi Michael,

I have changed the config.xml, applied the Zend_Cache patch. And i know you didn’t tell me to but i changed the install.xml like you told another user in this thread http://www.magentocommerce.com/boards/viewthread/1834/

I now get another DB-error, after the same step of installation as last time. Se attached.

Stil only 2 tables in DB and 25 rows in core_resource as with previous installation tries.

File Attachments
error2.txt  (File Size: 9KB - Downloads: 644)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Phliplip
Member
 
Total Posts:  46
Joined:  2007-08-31
Copenhagen, Denmark
 

Halp smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
piotrekkaminski
Magento Team
 
Avatar
Total Posts:  73
Joined:  2007-09-01
 

your last file with errors is empty smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phliplip
Member
 
Total Posts:  46
Joined:  2007-08-31
Copenhagen, Denmark
 

Damn, you are right :( Must reupload when i get home from work :S

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phliplip
Member
 
Total Posts:  46
Joined:  2007-08-31
Copenhagen, Denmark
 

Hi, i have uploaded the correct error file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phliplip
Member
 
Total Posts:  46
Joined:  2007-08-31
Copenhagen, Denmark
 
Kosta - 07 December 2007 09:44 AM

This helped in my case.
By I really think you should take this error seriously because I see it happens very frequently for a lot of people and there is no connection between the occurrence of this error and any specific software configuration.

By ‘you’ i think you (Kosta) mean Magento.. There shouldn’t be this much install problems on systems meeting system requirements. Fair enough, there has been (still is) a bug in Zend_Cache. I hope that the team has these errors ironed out before production release. I will happely help them in testing.

When reading about similar errors like mine, it seem’s like the install fails on different db-tables.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
Kosta - 07 December 2007 09:44 AM

This helped in my case.
By I really think you should take this error seriously because I see it happens very frequently for a lot of people and there is no connection between the occurrence of this error and any specific software configuration.

Hi Kosta,

Starting since the next release the installation/upgrade will be performed via pdo_mysql. We’ll remove mysli from Magento system requirements.

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top