Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Home Page (Homepage) Missing!! 
 
leppya
Jr. Member
 
Total Posts:  7
Joined:  2008-09-08
 

Help please...I spent many hours combing the forum and trying everything possible and my home page is still missing. That is:

I have a home page in CMS and it’s Identifier is ‘home’ and it is enabled and reachable when tested by doing ‘http://www.mystore.com/home’ directly.
I have the Admin->System->Configuration->Web values as: ‘Default web url’:’home’ AND ‘CMS Home Page’:’Home Page’
I have cleared my cache in the browser and in the admin and I threw out all the actual cache files in /var.

Yet http://www.mystore.com keeps pointing to the 404 Page Not Found page.... in fact, the only way that I can get to the Home Page is either by using:  http://www.mystore.com/home or by… get this..... setting the ‘CMS No Route Page’ as ‘Home Page’!!!!

Any clues out there - this is killing me!

Leppya

 
Magento Community Magento Community
Magento Community
Magento Community
 
LeeSaferite
Guru
 
Avatar
Total Posts:  322
Joined:  2007-08-31
Lake City, FL
 

default web url should be cms not home

The reason is, when you supply an empty url (the base of your site) it needs to know what frontname to use.  It looks this up under the config value you set with Default web url.  Then the site routes you to the CMS (cms/index/index) which in turn looks up your default cms page and shows you that.

So, change your Default web url to cms

 
Magento Community Magento Community
Magento Community
Magento Community
 
leppya
Jr. Member
 
Total Posts:  7
Joined:  2008-09-08
 

Heh—that was 100% correct!!

Somehow I got it in my had that the page’s ‘identifier’ should go there!

Thank-you very, very much!

grin

Leppya

 
Magento Community Magento Community
Magento Community
Magento Community
 
Guy Park
Jr. Member
 
Total Posts:  13
Joined:  2009-04-16
 

Cheers for the help Lee, thought I was going crazy. 
Had the same problem, very odd that they call it ‘’Default web url’ , it’s more of a default module I would say. smile

I think the 3 different levels (default/website/store), though very powerful and great, can get confusing and takes a while to get one’s mind in the right mindset.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top