Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Blank page when trying to install on PHP 5.2.5 - Magento V 0.6.13700
 
kyeranr
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2007-09-24
Edinburgh, Scotland
 

Hi,

I’m attempting to install magento - 0.6.13700 (have tested with light and full versions a number of times) on our new server but when i navigate to the directory to start installation i just get a blank page…
if i enable error_reporting in my htaccess file i get the following error message

Warning: include_once(Mage/Core/functions.php[function.include-once]failed to open streamNo such file or directory in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 40

Warning
: include_once() [function.include]Failed opening 'Mage/Core/functions.php' for inclusion (include_path='.:/usr/share/pear'in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 40

Warning
: include_once(Varien/Profiler.php[function.include-once]failed to open streamNo such file or directory in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 41

Warning
: include_once() [function.include]Failed opening 'Varien/Profiler.php' for inclusion (include_path='.:/usr/share/pear'in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 41

Fatal error
: Class 'Varien_Profiler' not found in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 43

I’ve made sure all the necessary directories are writable and have tested the installation on my local system without any trouble.
The server (shared hosting) is running PHP Version 5.2.5, pdo_mysql and mysqli extensions are installed fine, safe_mode if off and… well have a look at the phpinfo http://www.lunarrastar.com/content/info.php

I was wondering if this is related to the issue described in this thread http://www.magentocommerce.com/boards/viewthread/1600 as it looks like there are open_basedir restrictions and it’s PHP 5.2.5 or is something else going funny here?
I’ve also tried changing the /lib/Zend/Cache/Backend/File.php file as described in this thread http://www.magentocommerce.com/boards/viewthread/1600/P15/ but the results are the same.

is there anything else i can try? or should i wait for the next release when it has all been tested on PHP 5.2.5?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kyeranr
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2007-09-24
Edinburgh, Scotland
 

OK so now this is REALLY odd…

I was getting nowhere at all last night, I’d continue to refresh the page and would always get the same error message as above… but then this morning, i decide to try it again, Nothing has changed, it’s all set up exactly as it was before but this time i get the first installation screen appearing! I agree to the license and click the continue button and i get the next screen! Whooohoo progress! So continue to fill in the fields, click to continue and i get the same frustrating ERROR message again! Out of desperation i refresh the page and the next screen appears confused
It continues like that for the rest of the installation, occasionally I’d get the same error message appearing but after a refresh, or two, the next screen appears!

I’ve now managed to complete the installation, but still every once in a while I’ll get the same error message (or a blank screen if i disable the error reporting in the htaccess)…

I’m totally lost on this one, I’ve not changed anything on the server since last night and the error message seems to appear intermittently, Is there something up with the server? or something else going on here?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi kyeranr,

Can you verify please that there are no

php_admin_value include_path
setting in none of the .htaccess files above the Magento folder ?

It seems that it might be related to http://bugs.php.net/bug.php?id=41561 fix, released in PHP 5.2.5

 
Magento Community Magento Community
Magento Community
Magento Community
 
kyeranr
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2007-09-24
Edinburgh, Scotland
 

Hi, Michael, thanks for the reply.

I don’t have any .htaccess files above the magento folder yet, but saying that my phpinfo has the entry

include_path    .:/usr/share/pear
Should i and is it possible for me to change this using htaccess?

also, the server does seem to be using PHP 5.2.5…

additionally, after my last post, i did manage to finally get magento installed but even now i get the error message appearing for no apparent reason… hitting refresh, sometimes i have to hit it half a dozen times, does finally revel the expected page but this is VERY odd behavior.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
kyeranr - 03 December 2007 12:06 PM

I don’t have any .htaccess files above the magento folder yet, but saying that my phpinfo has the entry

include_path    .:/usr/share/pear
Should i and is it possible for me to change this using htaccess?

Let’s try to figure out why you cannot override default include_path setting. Please add the following code

echo ini_get('include_path');
in line 39 in app/Mage.php. Then you should be able to see on top of your Magento pages exactly the folllowing
.:/usr/local/share/pear:/var/www/vhosts/lunarrastar.com/httpdocs/content/lib:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/core:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/local:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/community

If the output will be still

.:/usr/share/pear
it means that it cannot set required include paths. It might be due to recently fixed http://bugs.php.net/bug.php?id=41561, in other words PHP 5.2.5 doesn’t allow to override php_admin_value include_path anymore.

You can try to find where do you have php_admin_value include_path “.:/usr/share/pear” setting and remove it (it might be in any of the .htaccess files above the magento folder, or in virtual host httpd.conf file.
Another option is to override it from within your .htaccess, i.e. you should add the following line to the .htaccess file in Magento root folder (/var/www/vhosts/lunarrastar.com/httpdocs/content/.htaccess):

php_admin_value include_path ".:/usr/local/share/pear:/var/www/vhosts/lunarrastar.com/httpdocs/content/lib:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/core:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/local:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/community"

also, the server does seem to be using PHP 5.2.5…

I do see PHP Version 5.2.5 in your phpinfo. Are you talking about another server ?

additionally, after my last post, i did manage to finally get magento installed but even now i get the error message appearing for no apparent reason… hitting refresh, sometimes i have to hit it half a dozen times, does finally revel the expected page but this is VERY odd behavior.

Btw, do you have any PHP accelerators installed ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kyeranr
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2007-09-24
Edinburgh, Scotland
 

Cheers Michael

I’ve uploaded the new release (0.6.14100) in the hope that it would change something, but unfortunately the same issue continues to trouble me in exactly the same way.

Let’s try to figure out why you cannot override default include_path setting. Please add the following code

echo ini_get('include_path');
in line 39 in app/Mage.php......

I changed the app/Mage.php file with the above code as you suggested and it returned

.:/usr/share/pear
Warning
: include_once(Mage/Core/functions.php[function.include-once]failed to open streamNo such file or directory in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 40

Warning
: include_once() [function.include]Failed opening 'Mage/Core/functions.php' for inclusion (include_path='.:/usr/share/pear'in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 40

Warning
: include_once(Varien/Profiler.php[function.include-once]failed to open streamNo such file or directory in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 41

Warning
: include_once() [function.include]Failed opening 'Varien/Profiler.php' for inclusion (include_path='.:/usr/share/pear'in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 41

Fatal error
: Class 'Varien_Profiler' not found in /var/www/vhosts/lunarrastar.com/httpdocs/content/app/Mage.php on line 43
however after a few refreshes (ok more than a few… perhaps 10 to 20) i get
.:/usr/share/pear:/var/www/vhosts/lunarrastar.com/httpdocs/content/lib:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/core:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/local:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/community
appearing at the top of my page…
which looks like what you were expecting

You can try to find where do you have php_admin_value include_path “.:/usr/share/pear” setting and remove it (it might be in any of the .htaccess files above the magento folder, or in virtual host httpd.conf file.
Another option is to override it from within your .htaccess, i.e. you should add the following line to the .htaccess file in Magento root folder (/var/www/vhosts/lunarrastar.com/httpdocs/content/.htaccess):

php_admin_value include_path ".:/usr/local/share/pear:/var/www/vhosts/lunarrastar.com/httpdocs/content/lib:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/core:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/local:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/community"

I tried adding this to my htaccess file as you suggested so my httpdocs/content/.htaccess file now looks like this

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
    php_flag register_globals on
    php_flag display_errors on
    php_value error_reporting 7
    php_admin_value include_path 
".:/usr/local/share/pear:/var/www/vhosts/lunarrastar.com/httpdocs/content/lib:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/core:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/local:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/community"
</IfModule>

DirectoryIndex index.php

RewriteEngine on

#RewriteBase /dev/magento/

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php

unfortunatly it returned a 500 internal server error

Internal Server Error

The server encountered an internal error 
or misconfiguration and was unable to complete your request.

Please contact the server administratorsupport@sitehq.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionallya 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.52 (Red HatServer at www.lunarrastar.com Port 80

so i’m guessing the hosting company don’t want me to be doing that… or have i made a mistake?
additionally, I don’t have any htaccess files above my magento folder (/var/www/vhosts/lunarrastar.com/httpdocs/content/) with php_admin_value include_path in so I’m assuming it’s in the httpd.conf file… I’m on shared hosting and don’t have access to that file unfortunately, but I’ll send a support request to my hosting company to see if they can help out.... fingers crossed.

I do see PHP Version 5.2.5 in your phpinfo. Are you talking about another server ?

Ignore me, I have one server (that matters). you and the info.php are correct.

Btw, do you have any PHP accelerators installed ?

I’ve not used any PHP accelerators before and i dont know if my hosting company do.

Thanks so much for your assistance, I’m learning a lot…

I’ll contact my host and ask them about the include_path in the virtual host httpd.conf

 
Magento Community Magento Community
Magento Community
Magento Community
 
kyeranr
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2007-09-24
Edinburgh, Scotland
 

Issue has been resolved… Thank you very much for your help, it has been very educational for me.

I wrote a support ticket to my host, they replied saying that i cant use the htaccess method at all any more, regardless of how apache is configured. so instead they made a config file that that contains the following.

[root@liverpoolst conf]# cat vhost.conf
<Directory /var/www/vhosts/lunarrastar.com/httpdocs/>
php_admin_value include_path ".:/usr/local/share/pear:/var/www/vhosts/lunarrastar.com/httpdocs/content/lib:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/core:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/local:/var/www/vhosts/lunarrastar.com/httpdocs/content/app/code/community"
AllowOverride All
</Directory>

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
cfipilot
Member
 
Total Posts:  39
Joined:  2007-12-09
 

I have the same problem.

http://www.epilotweb.com

http://www.epilotweb.com/info.php

include_path in the main php.ini file is set to .:/usr/lib/php:/usr/local/lib/php

I have access to the server so i am able to change it, but know what it should be.

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
cfipilot
Member
 
Total Posts:  39
Joined:  2007-12-09
 

I am have try this, still not fix.  Where did they add the conf file?

 
Magento Community Magento Community
Magento Community
Magento Community
 
cfipilot
Member
 
Total Posts:  39
Joined:  2007-12-09
 

OK, found my httpd.conf and edited it.  All working Now.  Well i hope.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Spaceout
Jr. Member
 
Total Posts:  5
Joined:  2008-02-07
 

I was having this same issue.  The fix above worked for me as well. Now on to the new problem...lol

 
Magento Community Magento Community
Magento Community
Magento Community
 
Xiano
Jr. Member
 
Total Posts:  25
Joined:  2008-02-25
 

I had the same problem, followed the threads through, and although it gets rid of the error messages it appears to just cause the page to enter a loop redirecting to itself.  That might not be whats happening, but thats what it looks like!

Can anyone help?

Alex
Xiano

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeroInferno
Jr. Member
 
Total Posts:  23
Joined:  2009-03-19
 

Hello people,
can you please describe the solution to fix this problem? I cant understand what to edit and what to add!

Thanks,
Fabio

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeroInferno
Jr. Member
 
Total Posts:  23
Joined:  2009-03-19
 

Hello,
i’ve runned the magento-check.php and it’s passed:

Congratulations! Your server meets the requirements for Magento.

* You have PHP 5.2.0 (or greater)
* Safe Mode is off
* You have MySQL 4.1.20 (or greater)
* You have the curl extension
* You have the dom extension
* You have the gd extension
* You have the hash extension
* You have the iconv extension
* You have the mcrypt extension
* You have the pcre extension
* You have the pdo extension
* You have the pdo_mysql extension
* You have the simplexml extension

I’ve also enabled the debug mode:

ini_set('display_errors'1);

I’ve also tried to raise the memory_limit in the php.ini from 32M to 64M and 128M

..but when I try to install Magento I always have a total blank page, without any errors or text!

Any help?

I use a Bluehost hosting.

Thanks smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
jsalmont
Jr. Member
 
Total Posts:  2
Joined:  2011-09-15
 

Hey all, having a similar problem.

Blank screen problem / WSOD white screen.

After copying Magento files over to webserver testbed.webformix.com and setting file permissions as per installation instructions I get a blank screen with no useful error information.  Blankness leads unto darkness.  There is no generated “reports” folder in /var.  After changing the flag below, was not able to find apache/php error info either.

Uncommented/Enabled following error handling in index.php (no additional error info about mystery problem after this):

ini_set(’display_errors’, 1);

Also set memory limit to 512mb

Php info results:

http://testbed.webformix.com/phpinfo.php

ps: we also added to the httpd.conf:

php_admin_value include_path “.:/usr/share/php:/home/testbed/testbed.webformix.com/htdocs/lib:/home/testbed/testbed.webformix.com/htdocs/app/code/core:/home/testbed/testbed.webformix.com/htdocs/app/code/local:/home/testbed/testbed.webformix.com/htdocs/app/code/community”

Did not change the white screen issue.

As opposed to OP, no amount of refreshing changes white screen behavior.

Any suggestions?  It’s frustrating!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mohsinkhan
Jr. Member
 
Total Posts:  11
Joined:  2012-01-20
 

Hi All,
Me too have the same problem, I am in a big trouble please post a solution for it.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2