Magento Forum

   
Fatel error when upgrading to 1.1.6 HELP
 
RH
Sr. Member
 
Avatar
Total Posts:  81
Joined:  2007-10-09
 

PDOException Object
(
[message:protected] => SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘core_flag’ already exists
[string:private] =>
[code:protected] => 42S01
[file:protected] => /home/manicure/domains/manicured.co.uk/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php
[line:protected] => 156
[trace:private] => Array
(
[0] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php
[line] => 156
[function] => query
[class] => PDO
[type] => ->
[args] => Array
(
[0] => CREATE TABLE core_flag (
`flag_id` smallint(5) unsigned NOT NULL auto_increment,
`flag_code` varchar(255) NOT NULL,
`state` smallint(5) unsigned NOT NULL default ‘0’,
`flag_data` text,
`last_update` datetime NOT NULL,
PRIMARY KEY (`flag_id`),
KEY (`last_update`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8
)

)

[1] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php
[line] => 218
[function] => raw_query
[class] => Varien_Db_Adapter_Pdo_Mysql
[type] => ->
[args] => Array
(
[0] => CREATE TABLE core_flag (
`flag_id` smallint(5) unsigned NOT NULL auto_increment,
`flag_code` varchar(255) NOT NULL,
`state` smallint(5) unsigned NOT NULL default ‘0’,
`flag_data` text,
`last_update` datetime NOT NULL,
PRIMARY KEY (`flag_id`),
KEY (`last_update`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8
)

)

[2] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 493
[function] => multi_query
[class] => Varien_Db_Adapter_Pdo_Mysql
[type] => ->
[args] => Array
(
[0] =>
CREATE TABLE core_flag (
`flag_id` smallint(5) unsigned NOT NULL auto_increment,
`flag_code` varchar(255) NOT NULL,
`state` smallint(5) unsigned NOT NULL default ‘0’,
`flag_data` text,
`last_update` datetime NOT NULL,
PRIMARY KEY (`flag_id`),
KEY (`last_update`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

)

)

[3] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/sql/core_setup/mysql4-upgrade-0.8.9-0.8.10.php
[line] => 42
[function] => run
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] =>
CREATE TABLE core_flag (
`flag_id` smallint(5) unsigned NOT NULL auto_increment,
`flag_code` varchar(255) NOT NULL,
`state` smallint(5) unsigned NOT NULL default ‘0’,
`flag_data` text,
`last_update` datetime NOT NULL,
PRIMARY KEY (`flag_id`),
KEY (`last_update`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

)

)

[4] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 268
[args] => Array
(
[0] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/sql/core_setup/mysql4-upgrade-0.8.9-0.8.10.php
)

[function] => include
)

[5] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 178
[function] => _modifyResourceDb
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] => upgrade
[1] => 0.8.8
[2] => 0.8.11
)

)

[6] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 145
[function] => _upgradeResourceDb
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] => 0.8.8
[1] => 0.8.11
)

)

[7] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 120
[function] => applyUpdates
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
)

)

[8] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Config.php
[line] => 215
[function] => applyAllUpdates
[class] => Mage_Core_Model_Resource_Setup
[type] => ::
[args] => Array
(
)

)

[9] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/App.php
[line] => 236
[function] => init
[class] => Mage_Core_Model_Config
[type] => ->
[args] => Array
(
[0] => Array
(
)

)

)

[10] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/app/Mage.php
[line] => 424
[function] => init
[class] => Mage_Core_Model_App
[type] => ->
[args] => Array
(
[0] =>
[1] => store
[2] => Array
(
)

)

)

[11] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/downloader/Maged/Controller.php
[line] => 378
[function] => app
[class] => Mage
[type] => ::
[args] => Array
(
)

)

[12] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/downloader/Maged/Controller.php
[line] => 332
[function] => isInstalled
[class] => Maged_Controller
[type] => ->
[args] => Array
(
)

)

[13] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/downloader/Maged/Controller.php
[line] => 164
[function] => dispatch
[class] => Maged_Controller
[type] => ->
[args] => Array
(
)

)

[14] => Array
(
[file] => /home/manicure/domains/manicured.co.uk/public_html/downloader/index.php
[line] => 29
[function] => run
[class] => Maged_Controller
[type] => ::
[args] => Array
(
)

)

)

[errorInfo] => Array
(
[0] => 42S01
[1] => 1050
[2] => Table ‘core_flag’ already exists
)

)

Magento Downloader

Fatal error: Uncaught exception ‘Exception’ with message ‘Warning: session_start() [<a href=’function.session-start’>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php:285) in /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 79’ in /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/functions.php:246 Stack trace: #0 [internal function]: mageCoreErrorHandler(2, ‘session_start()...’, ‘/home/manicure/...’, 79, Array) #1 /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(79): session_start() #2 /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(111): Mage_Core_Model_Session_Abstract_Varien->start(NULL) #3 /home/manicure/domains/manicured.co.uk/public_html/app/code/core/M in /home/manicure/domains/manicured.co.uk/public_html/app/code/core/Mage/Core/functions.php on line 246

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Where do you see this? Is it in your front page?
Btw, do you have a php.ini file present in your Magento’s root folder?

 
Magento Community Magento Community
Magento Community
Magento Community
 
RH
Sr. Member
 
Avatar
Total Posts:  81
Joined:  2007-10-09
 

I select upgrade to 1.6 in the magento connect and then when its finsihed press refresh and i get the code error.

If i go to my domain i also get this error.

I dont have a php.ini in my root wahterver that it?

Regards

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Try creating a file with the name php.ini (through notepad) and upload it into your Magento root directory.

 
Magento Community Magento Community
Magento Community
Magento Community
 
RH
Sr. Member
 
Avatar
Total Posts:  81
Joined:  2007-10-09
 

Same error.

I loaded up from my backup and then tryied to upgrade,

Same error.

What does php.ini do?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

What about renaming the php.ini to php5.ini?
These normally works for us.

 
Magento Community Magento Community
Magento Community
Magento Community
 
RH
Sr. Member
 
Avatar
Total Posts:  81
Joined:  2007-10-09
 

No doesnt work.

I’m not sure what these files will do to the installation. Could you explain, thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Normally a php.ini file comes together with the installation package. The above issues normally happens when this file is missing.

php.ini attached. Be sure to rename it and remove the “.txt”.

File Attachments
php.ini.txt  (File Size: 1KB - Downloads: 125)
 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

Just to add to this, you do not need to use php.ini, as we are on special kind of environment with suExec as our base, which will enable all features of Magento as well as relieving the need to perform any kind of chmod methods on your files. Everything should just work without any tricks or hacks.

RH: Let me know from which version to which you are performing the upgrade

 
Magento Community Magento Community
Magento Community
Magento Community
 
RH
Sr. Member
 
Avatar
Total Posts:  81
Joined:  2007-10-09
 

Hello.

I’m trying to upgraded to the latest version 1.1.6

Any ideas?

Simple helix rule. They are the best host unlike others.

 
Magento Community Magento Community
Magento Community
Magento Community
 
shuron
Member
 
Avatar
Total Posts:  58
Joined:  2007-12-09
 

I get same problem on full new instaltion of 1.1.6

PHP 5.2.2
MYSQL 5.0.51

Error in file: “/kunden/203484_21035/webseiten/de/dentotechnik3/app/code/core/Mage/Core/sql/core_setup/mysql4-install-0.8.0.php” - SQLSTATE[HY000]: General error: 1005 Can’t create table ‘./db203484_1/#sql-1dd4_17baf.frm’ (errno: 121)
Trace:
#0 /kunden/203484_21035/webseiten/de/dentotechnik3/app/code/core/Mage/Core/Model/Resource/Setup.php(286): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /kunden/203484_21035/webseiten/de/dentotechnik3/app/code/core/Mage/Core/Model/Resource/Setup.php(166): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘0.8.11’)
#2 /kunden/203484_21035/webseiten/de/dentotechnik3/app/code/core/Mage/Core/Model/Resource/Setup.php(154): Mage_Core_Model_Resource_Setup->_installResourceDb(’0.8.11’)
#3 /kunden/203484_21035/webseiten/de/dentotechnik3/app/code/core/Mage/Core/Model/Resource/Setup.php(120): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /kunden/203484_21035/webseiten/de/dentotechnik3/app/code/core/Mage/Core/Model/Config.php(215): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /kunden/203484_21035/webseiten/de/dentotechnik3/app/code/core/Mage/Core/Model/App.php(236): Mage_Core_Model_Config->init(Array)
#6 /kunden/203484_21035/webseiten/de/dentotechnik3/app/Mage.php(424): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /kunden/203484_21035/webseiten/de/dentotechnik3/app/Mage.php(443): Mage::app(’’, ‘store’, Array)
#8 /kunden/203484_21035/webseiten/de/dentotechnik3/index.php(52): Mage::run()
#9 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top