Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error in top menu of page
 
jazn54
Jr. Member
 
Total Posts:  6
Joined:  2009-10-09
 

Hi Magento experts,

I’m hoping someone can help me fix a small issue I’m having with the menu bar. I had a static block with links to CMS pages that would populate the menu but I changed something in it and now links aren’t aligned properly anymore. The category links look fine but once it calls the list from the menu, the formatting is wrong and it doesn’t space the links apart.

top.phtml
...
<div class="header-nav-container">
<div class="header-nav">
<h4 class="no-display"><?php echo $this->__('Category Navigation:') ?></h4>
<ul id="nav">
<?php foreach ($this->getStoreCategories() as $_category): ?>
<?php echo $this->drawItem($_category) ?>
<?php endforeach ?>
<?php echo $this->getLayout()->createBlock('cms/block')->setBlockId('menu')->toHtml() ?>
</ul>
</div>
<?php echo $this->getChildHtml('topLeftLinks') ?>
</div>

static block
menu

<li><a href="about-us">about us</a></li>
<li><a href="faq">faq</a></li>
<li><a href="contactus">contact us</a></li>

Does anyone know the solution to the problem.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top