Magento Forum

Magento 1.4 “setWebsite() must be an instance of Mage_Core_Model_Website"-Problem
 
flashmike
Jr. Member
 
Total Posts:  3
Joined:  2010-03-10
 

Hi,

i’m trying to restore a magento Store.

Whatever I try I always get the same error:

a:4:{i:0;s:317:"Recoverable Error: Argument 1 passed to Mage_Core_Model_Store_Group::setWebsite() must be an instance of Mage_Core_Model_Website, null given, called in \app\code\core\Mage\Core\Model\App.php on line 574 and defined  in \app\code\core\Mage\Core\Model\Store\Group.php on line 227";i:1;s:642:"#0 C:\xampp\htdocs\zs10\app\code\core\Mage\Core\Model\Store\Group.php(227): mageCoreErrorHandler(4096, 'Argument 1 pass...', 'C:\xampp\htdocs...', 227, Array)
#1 \app\code\core\Mage\Core\Model\App.php(574): Mage_Core_Model_Store_Group->setWebsite(NULL)
#2 \app\code\core\Mage\Core\Model\App.php(393): Mage_Core_Model_App->_initStores()
#3 \app\code\core\Mage\Core\Model\App.php(299): Mage_Core_Model_App->_initCurrentStore('', 'store')
#4 \app\Mage.php(596): Mage_Core_Model_App->run(Array)
#5 \index.php(78): Mage::run('', 'store')
#6 {main}"
;s:3:"url";s:6:"/zs10/";s:11:"script_name";s:15:"/zs10/index.php";}

I tryed to fix it replacing the “app/code"-folder and checked the website- and store-setings in the database. Here are the current values:

core_store
store_id code website_id group_id name sort_order is_active
0 admin 0 0 Admin 0 1
1 default 1 1 Default Store View 0 1

core_website
website_id code name sort_order default_group_id is_default
0 admin Admin 0 0 0
1 base Main Website 0 1 1

Has anybody an idea how to fix this?

Thanks a lot!

Best regards

 
Magento Community Magento Community
Magento Community
Magento Community
 
Olof
Sr. Member
 
Total Posts:  152
Joined:  2008-10-17
 

Any luck finding a fix to this?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top