Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

One of the most reason for upgrade issues / categories / Adminhtml / version-stamp not updated
 
stefan_herxe
Member
 
Total Posts:  49
Joined:  2008-08-20
 

Hello Guys,

i wont be a smart-aleck but it happen to me and everywhere in this forum i can read issus that caused by the same reason.
The reason is that some necessary modules (like Interface_Adminhtml_Default) are not installed.

If you now push update, the “Mage_Core_Modules” will upgrade, but not the absolutly necessary files in /design/adminhtml/ and magento will run into trouble. No wonder, the files are handle by the missing “Interface_Adminhtml_Default” module and both modules have a really strong interdependency.

This can happen if you upload the initial installation by ftp. So the module is not automaticly present. If you use the downloader for initial installation the module is present.

To ensure the integrity of the magento core-modules i will quote Micheal. His hint helped me

In order to prevent this kind of problems please install Mage_All_Latest meta-package.

The extension key to copy-paste is

magento-core/Mage_All_Latest

This meta-package ensures the integrity of Magento core modules. Basically it should be already shown as installed, because it is the package that is installed during download process from magento-downloader.

When upgrading to the next version you will have to select “Upgrade” only for Mage_All_Latest - all other core modules will be upgraded automatically.

Ok, iam a newbie on magento and i am all others as sure about this. But i see.. or feel that this is one of the reasons for many upgrade-issus. If not, so please admin delete this post.

good luck
Stefan

sorry for my bad english syntax. I hope its readable.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Matt Webster
Jr. Member
 
Total Posts:  13
Joined:  2008-08-29
 

+1 for this solution!

 
Magento Community Magento Community
Magento Community
Magento Community
 
SteveM
Jr. Member
 
Total Posts:  20
Joined:  2008-07-25
 

Stefan, thank you my friend! I have been trying to find a solution to this for many days. It worked perfectly and took only one minute to fix smile

Thank you again for sharing this with us.

Best regards
Steve

 
Magento Community Magento Community
Magento Community
Magento Community
 
moritz_a
Jr. Member
 
Total Posts:  11
Joined:  2008-06-12
 

That was the key solution for all the problems we encountered since the upgrade.

Excellent work! Thank you for sharing this with us.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hive.net.au
Jr. Member
 
Total Posts:  17
Joined:  2008-08-14
Gold Coast, Australia
 

This worked for me after upgrading, great work

 
Magento Community Magento Community
Magento Community
Magento Community
 
PatrickCM
Member
 
Total Posts:  54
Joined:  2008-09-07
 

great, you rock smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top