Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
Disabling the Magento compiler is not possible
 
MarekObuchowicz
Jr. Member
 
Total Posts:  3
Joined:  2010-06-08
 

Yeah guys, i had similiar issue - another not documented \\\"magento magic\\\”.

Please look at Mage_Shell_Abstract::_applyPhpVariables - it reads the .htaccess file and applies the memory_limit from there. I have totally no idea why this stupid solution is implemented, as .htaccess logically contains settings for webserver php processes, not the shell…
Actually, your webserver can even ignore .htaccess (if you\\\’re not using SlowPache + mod_php).

So, remove or adjust value in your magento root / .htaccess, or rewrite the method mentioned above.

Again, \\\"Magento/Varien magic\\\” which tries to implement good things in very bad way. This software sucks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
serdarsenay
Jr. Member
 
Total Posts:  1
Joined:  2011-12-10
 
zumajimi - 04 September 2011 12:24 AM

Well I got it working now. My site comes back on now.  Thanks for the solution.  Works perfectly well.  Finally, I was able to manage this without an SSH access by creating a new class copied from class ‘Mage_Shell_Compiler’ and also override ‘protected function _validate()’ .  If I didn’t override this function, it wouldn’t let me run the code.  It said ‘This script cannot be run from Browser. This is the shell script.’

Thank you so much, done the same, just want to add the step for clarification, make a new file next to compilerBrowser.php in your file manager, paste contents of compiler.php but add an empty method _validate() to override browser protection, than run this on your browser: compilerBrowser.php?disable

I have included the file as an attachment

Zumajimi, Thank you again!

File Attachments
compilerBrowser.php  (File Size: 5KB - Downloads: 209)
 
Magento Community Magento Community
Magento Community
Magento Community
 
TORANJ
Jr. Member
 
Total Posts:  4
Joined:  2012-01-15
 

Hi,

Same thing happened to my website last night when I was trying to install an extension and enabled the compiler.

Then I read this thread, emptied the Cache and installed a compiler extension through downloader. It did not fix the problem though. Can someone help me please ? I don’t know what SSH is ...

Regards,

 
Magento Community Magento Community
Magento Community
Magento Community
 
bsr
Jr. Member
 
Total Posts:  12
Joined:  2010-01-01
 
serdarsenay - 01 February 2012 06:14 PM

zumajimi - 04 September 2011 12:24 AM
Well I got it working now. My site comes back on now.  Thanks for the solution.  Works perfectly well.  Finally, I was able to manage this without an SSH access by creating a new class copied from class ‘Mage_Shell_Compiler’ and also override ‘protected function _validate()’ .  If I didn’t override this function, it wouldn’t let me run the code.  It said ‘This script cannot be run from Browser. This is the shell script.’

Thank you so much, done the same, just want to add the step for clarification, make a new file next to compilerBrowser.php in your file manager, paste contents of compiler.php but add an empty method _validate() to override browser protection, than run this on your browser: compilerBrowser.php?disable

I have included the file as an attachment

Zumajimi, Thank you again!

Thank you so much for this solution. I was completely blind as was site was down, neither frontend nor my admin panel was working.
I tried this on Magento 1.4.2.0. What I did is I copied this file compileBrowser.php in my /public_html/shell folder and then I simply did
www.mydomain.com/shell/compileBrowser.php?disable And I got my site running.  Thank you so much again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hidonet
Member
 
Avatar
Total Posts:  52
Joined:  2008-03-25
Istanbul
 

I’ve experienced same problem in my Cpanel/Linux box.

Problem is PEAR.
Disable PEAR and voila…

http://SERVER_IP:2086/scripts2/module_installers_index?lang=php-pear
Click to disable button if enabled…

 
Magento Community Magento Community
Magento Community
Magento Community
 
happygerl
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2013-04-24
 

I had my site go blank white after running the compiler too, I followed the steps in this link and everything was back to normal.

blank page enabling compiler

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Disabling the Magento compiler. Use WinSCP or any other FTP Client

find the file includes/config.php and comment the lines out with # like so.

<?php
/**
 * Magento
 *
 * NOTICE OF LICENSE
 *
 * This source file is subject to the Open Software License (OSL 3.0)
 * that is bundled with this package in the file LICENSE.txt.
 * It is also available through the world-wide-web at this URL:
 * http://opensource.org/licenses/osl-3.0.php
 * If you did not receive a copy of the license and are unable to
 * obtain it through the world-wide-web, please send an email
 * to license@magentocommerce.com so we can send you a copy immediately.
 *
 * DISCLAIMER
 *
 * Do not edit or add to this file if you wish to upgrade Magento to newer
 * versions in the future. If you wish to customize Magento for your
 * needs please refer to http://www.magentocommerce.com for more information.
 *
 * @category   Mage
 * @package    Mage
 * @copyright  Copyright (c) 2008 Irubin Consulting Inc. DBA Varien (http://www.varien.com)
 * @license    http://opensource.org/licenses/osl-3.0.php  Open Software License (OSL 3.0)
 */


#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

and then find the var/cache directory and delete all the mage--? subfolders.

 
Magento Community Magento Community
Magento Community
Magento Community
 
romanza
Jr. Member
 
Total Posts:  4
Joined:  2012-01-04
 

Clicked “Enable” on System, Tools, Compilation and killed my Magento site

Was immediately locked out of front end and back end with the following error;

Fatal error: Call to a member function initCache() on a non-object

Fixed it by going to http://www.yoursite.com/downloader/ and reinstalling Mag_Compiler

Thanks to everyone who posted this.... ended my panic attack in only 20 minutes or so!  Whew!

 
Magento Community Magento Community
Magento Community
Magento Community
 
tahirekhan
Jr. Member
 
Total Posts:  2
Joined:  2013-06-25
 
Simon Janssen - 24 January 2012 04:51 AM

You have to login to your Magento Connect Manager. The url is: www.yourdomainname.com/downloader

You should see a login page. Have you ever visited this page?

If you don’t see any page, the folder is either not present, or something is really wrong with your website......

Please let me know what happens....

Thank you Simon, this just saved my behind.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2