Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

magento connect manager and all 404 error pages redirect to home page
 
astond
Jr. Member
 
Total Posts:  1
Joined:  2010-03-24
 

Hi All

I have recently moved hosts and managed to migrate the store successfully except for the following problem.

I am unable to get to the magento connect manager page.

when I select the option within the admin section I get the following URL.

https://astonsoflondon.co.uk/downloader/?return=http://astonsoflondon.co.uk/index.php/admin/

I am running 1.3.1

help please.

Thx

David

 
Magento Community Magento Community
Magento Community
Magento Community
 
subxing
Jr. Member
 
Total Posts:  2
Joined:  2009-04-25
 

Same problem,

you solved it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
timpletcher
Jr. Member
 
Avatar
Total Posts:  12
Joined:  2010-03-24
 

try changing yur file perm\’s to 755:

Try changing the permission of: downloader/index.php to 755

this worked for me

 
Magento Community Magento Community
Magento Community
Magento Community
 
camrinp
Jr. Member
 
Total Posts:  1
Joined:  2010-08-18
 

I have the same reply but the url i get is

http://www.cspsolutions.ca/tbayindustrial/index.php/key/5cbe2dc71889281dc483561158ba8027/?return=http://www.cspsolutions.ca/tbayindustrial/index.php/admin/

and i changed the permissions it goes to a 404 page but its not blank it looks like the theme

 
Magento Community Magento Community
Magento Community
Magento Community
 
Larsa
Jr. Member
 
Total Posts:  2
Joined:  2009-11-03
 

Anyone a fix for this, I\’ve this problem with different versions of Magento (1.3.xx and 1.4.xx)
A used the cleanup tool, checked permissions, cleared cache but nothing seems to be working
Any help appreciated

 
Magento Community Magento Community
Magento Community
Magento Community
 
invivid
Jr. Member
 
Total Posts:  1
Joined:  2010-11-27
 

Thanks timpletcher, that worked for me too!

timpletcher - 22 June 2010 08:45 AM

try changing yur file perm\’s to 755:


Try changing the permission of: downloader/index.php to 755


this worked for me

 
Magento Community Magento Community
Magento Community
Magento Community
 
Boldbaber
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2010-05-30
 

Can anyone help me i was working on magento project it was getting awesome but when i installed the page peel extension

http://www.magentocommerce.com/magento-connect/gdelfava/extension/3662/connectgentopagepeelads

via magento connect manager after installing this extension i.m unable to access my site i.m working on locally at wamp server every page is redirecting to

http://localhost/magento/downloader/

every time and i can login to connect manager only and can install and uninstall extension but can’t access all rest of site please help

as u can see in attached file when i.m clicking on return to admin link it redirecting page to http://localhost/magento/downloader/index.php

Image Attachments
problem.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
Boldbaber
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2010-05-30
 

@ astond try to delete your sessions and cache and then refresh hopes its help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
safakkaya
Jr. Member
 
Total Posts:  2
Joined:  2012-01-06
 

If any above solutions didn’t work for you, I would suggest to disable URL rewrite completely. I mean you need to clear rewrite rules in your .htaccess file.

I was suffering the sam issue and tried all suggestions. And then I just disabled URL rewrite in magento admin (configuration - web - search engine optimisation - use web server rewrites: NO) However this is not the main issue. After that, I just clean rewrite rules in .htaccess file.
And it worked!

I hope this could be helpful someone else.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jeremy1l
Jr. Member
 
Total Posts:  1
Joined:  2013-09-18
 
safakkaya - 12 June 2012 09:23 PM

I just clean rewrite rules in .htaccess file.

worked for me
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top